Previous 1 2 Next 26 Replies Latest reply: Dec 5, 2012 11:26 AM by patafix95
patafix95 Level 1 Level 1

my iPhoto upgraded badly and now everytime i open an image it shuts down. how do i fix this?

what happened was that intenet went off while i was upgrading. when it came back on it finished upgrading but now, everytime i add a picture to iPhoto it tells me to trace the picture to one on the computer, when i click "search in finder" iPhoto instantly shuts down. now i'm sure i have those pics on my pc.

how do i solve this??

help!!!


MacBook Pro, Mac OS X (10.7.5)
Solved by LarryHN on Dec 5, 2012 9:54 AM Solved

corect that was my original suggestion

 

Depress and hold the option key and launch iPhoto - create a new test library and import a few photos to it - does it work properly?

However this does not really solve the problem unless you want to start over with a totally new library - it does verify that iPhoto is working and that your account is fine -  that the issue is with the iPhoto library

 

The next suggestion I made probably will resolve the issue with your existing library so you do not have to start over

 

Back up your iPhoto library, Depress and hold the option (alt) and command keys and launch iPhoto - rebuild your iPhoto library

 

LN

Reply by LarryHN on Dec 3, 2012 12:21 PM Helpful

what is the exact error message you get? In the iPhoto preferences is "copy imported items to the iPhoto library checked"?

 

Depress the option key and launch iPhoto - create a new test library and import a few photos to it - does it work properly?

 

LN

Reply by LarryHN on Dec 4, 2012 9:49 AM Helpful

Ok that helps - Back up your iPhoto library, Depress and hold the option (alt) and command keys and launch iPhoto - rebuild your iPhoto library

 

LN

All replies

  • LarryHN Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    what is the exact error message you get? In the iPhoto preferences is "copy imported items to the iPhoto library checked"?

     

    Depress the option key and launch iPhoto - create a new test library and import a few photos to it - does it work properly?

     

    LN

  • patafix95 Level 1 Level 1

    it doesn't work. when i carry the pictures iphot uploads them but doesn't show them. however now it doesn't shut down

  • LarryHN Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    And the answers are?

     

    1 - what is the exact error message you get?

     

    2 - In the iPhoto preferences is "copy imported items to the iPhoto library checked"?

     

    3 - Depress the option key and launch iPhoto - create a new test library and import a few photos to it - does it work properly?

     

    LN

  • patafix95 Level 1 Level 1

    i get no message now. it's like it loads the picture but doesn't show it. if i click edit this message shows: La foto “(null)” non può essere aperta, perché non è stato trovato l'elemento originale.  but my iPhoto is swt in italian as it is my first language. also it says thath the picture is not on line.

    i tried depressing the option key lke you suggested but nothing changes.

    P

  • LarryHN Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    Are you saying that you can not create a new library and import a few photos into it as a test?

     

    In the iPhoto preferences is "copy imported items to the iPhoto library" checked or have you unchecked it?

     

    LN

  • patafix95 Level 1 Level 1

    it was checked and i unchecked it but i still cannot create a new libary or even upload a new image.

  • LarryHN Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    DO NOT UNCHECK the preference to 'copy imoported items to the iPhoto library" that was a question - not a suggestion - it should be checked

     

    What exactly happens when you try to create a new library?

     

    LN

  • patafix95 Level 1 Level 1

    ok so this is what happens when i open my iphoto.

    it goes into events and the little circle keeps going round and round like it's loading but never stops. if i select new album and i drag the picture into iphoto it loads it in a realy short time and then i see no picture. however at the top there is written "album.. one photo". i repeat i see no icon with the picture on the iphoto deck. if i click edit, it tells me that the picture can't be open as the original file hasn't been found. when i click "search for the original file" iPhoto shuts down.

     

    i'm really worried

  • LarryHN Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    Ok that helps - Back up your iPhoto library, Depress and hold the option (alt) and command keys and launch iPhoto - rebuild your iPhoto library

     

    LN

  • patafix95 Level 1 Level 1

    ok i tried it but the same message appears. if i delete iphoto and re-install it would it help? would i have to pay?

  • LarryHN Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    That sounds like you have imported photos with the copy preference turned off - have you?

     

    LN

  • patafix95 Level 1 Level 1

    no it's back on

  • LarryHN Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    But have you ever imported any photos while that preference was unchecked - at any time in the past?

     

    LN

  • patafix95 Level 1 Level 1

    No i haven't do you think that if i delete iphoto and re-install it would it help? would i have to pay?

Previous 1 2 Next