9 Replies Latest reply: Dec 6, 2012 7:42 AM by jemorgan222
jemorgan222 Level 1 (0 points)

My iphoto 11 pictures are not visible in the edit screen and the slideshow will not run.  I've tried everything that I know and I'm at the point of deleteing iPhoto and do a clean install.  However, I'm not clear on the procedures and if I need to purchase iPhoto (it came pre-installed on my mid 2010 macbook pro).  Or should  I need do a clean install on my mountain lion?

  • Terence Devlin Level 10 (136,660 points)

    There are several possible causes for the Black Screen issue


    1. Permissions in the Library: Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Include the option to check and repair permissions.


    2. Minor Database corruption: Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild.


    3. A Damaged Photo: Select one of the affected photos in the iPhoto Window and right click on it. From the resulting menu select 'Show File (or 'Show Original File' if that's available). (On iPhoto 11 this option is under the File -> Reveal in Finder.) Will the file open in Preview? If not then the file is damaged. Time to restore from your back up.


    4. A corrupted iPhoto Cache: Trash the com.apple.iPhoto folder from HD/Users/Your Name/Library/ Caches...


    5. A corrupted preference file: Trash the com.apple.iPhoto.plist file from the HD/Users/ Your Name / library / preferences folder. (Remember you'll need to reset your User options afterwards. These include minor settings like the window colour and so on. Note: If you've moved your library you'll need to point iPhoto at it again.)


    If none of these help:


    As a Test:


    Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Create Library'


    Import a few pics into this new, blank library. Is the Problem repeated there?

  • jemorgan222 Level 1 (0 points)

    Thank for the reply.... tried your "as a test:" and the problem repeated in the new library as well. 

    Tried option 1 thru 3 and it did not help.  Could not try option 4 or 5 as my Finder could not find a file named com.apple.iphoto.plist? or even a com.apple.iphoto?  Any more suggestions would be appreciated. Thanks, Jim

  • Old Toad Level 10 (133,340 points)

    NOTE: In Lion and Mountain Lion the Home/Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.


    Also starting with Lion the iPhoto cache file is in the


    Home/Library/Containers/Data/Caches/com.apple.iPhoto folder



  • jemorgan222 Level 1 (0 points)

    Thanks again for the quick reply... I was able to delete com.apple.iphoto file but it did nothing to correct my problem.  Photos still are invisible in edit mode and no slideshow. 


    Am I at the point where I need to remove iphoto 11 and do a clean install? or maybe wait for iphoto 12? If so what are the steps I should take to make this happen?  I'm a new at this sort of thing.  Thanks for all your input, Jim

  • Terence Devlin Level 10 (136,660 points)

    We're not finished troubleshooting yet


    Create a new account (systempreferences -> accounts or Users & Groups on 10.7 and 10.8), make a new Library in that account, import some shots  and see if the problem is repeated there. If it is, then a re-install of the app might be indicated. If it's not, then it's likely the app is okay and the problem is something in the main account.

  • jemorgan222 Level 1 (0 points)

    Created a new account and loged into it with the same results; Photos still are invisible in edit mode and the slideshow does not work. 

    While this problem is fustrating the upside is I'm learning more about using a mac from you so I appreaciate all and any suggestion you have. - Thanks, Jim

  • Terence Devlin Level 10 (136,660 points)

    Next move:


    reinstall iPhoto.


    To re-install iPhoto


    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)


    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.


    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type




    2c: on 10.7 they're at




    A Finder Window will open at that location and you can remove the iPhoto pkg files.


    3. Re-install.


    If you purchased an iLife Disk, then iPhoto is on it.


    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.


    If you purchased it on the App Store or have a Recent Mac you can find it in your Purchases List.

  • jemorgan222 Level 1 (0 points)

    I've done all the above and the photos still are invisible in edit mode and the slideshow does not work.  Tried it a 2nd time and took it a step further and used a "clean my mac" to delete all associated file to iPhoto.  Then I downloaded a new copy of iPhoto from the app store and it still doesn't work.

    I'm open to any sggestion you may have.  Lost in Virginia, Jim

  • jemorgan222 Level 1 (0 points)

    As a recap on iPhoto 11 (version 9.4.2) I have a black screen in edit mode and the slide show does not work. My system is a 15" macbook pro purchased in mid 2010.  I'm running mountain lion (version 10.8.2) and all my software is up to date.  I have tried all the normal steps to repair, rebuild, and replace the library.  In additions I have:

         1.  Deleted the library and the app.apple.iphoto file

         2.  Deleted iPhoto 11 and all the supporting files to it using an app cleaner (Clean My Mac)

         3.  Downloaded a new iPhoto 11 (version 9.4.2)

         4.  Did a clean install

         5   Imported new test photos into a newly created library


    The problem still exist.  I have this black screen in edit mode making the photos invisible and the slide show doesn't work.  I'm at a lost to know what to try or change next.  Any suggest or recomendation would be appreciate.  Thanks, Jim