14 Replies Latest reply: Jan 11, 2013 11:49 PM by Priost
Bart ek Level 1 (0 points)

I have installed Windows 7 64 bit with Boot Camp. All games work fine except Far Cry 3. I installed it today and was getting around 10 fps in 720p with the lowest settings. The fps didnt go up much even when I tried with the absolute lowest resolution and lowest settings. I tried clearing the PRAM and SMC however still no luck. I have updated my graphics card drivers to the latest version and then even tried the beta drivers which are supposed to help with Far Cry 3. Is anyone else having these issues?



MacBook Pro with Retina display, OS X Mountain Lion (10.8.1)
  • Bart ek Level 1 (0 points)

    Sorry I forgot to mention I had patched the game. I used the first patch which was avaliable from release and now even the latest patch. I have read on youtube some others are experiencing this issue :S

  • Seann7656 Level 1 (5 points)

    Under video quality options turn "Post FX" to low. Made a massive overall difference in performance to me.



    After much aggravation I narrowed it down to that single option really messing with most peoples performance. Not sure if it's a bug or not.



    Hope this works!

  • Bart ek Level 1 (0 points)

    That definitely helped a ridiculous amount! It is now around 28-30 fps. However goes down to as low as 25 sometimes and seems really jerky when there are quick movements. Do you get some screen tear? Thank you for this it has helped lots. Can I ask how many fps are you getting?

  • saturnotaku Level 3 (525 points)

    If there's an option to disable vertical sync (vsync) in-game, you might want to try that. That often improves performance, but it can result in screen tearing if the framerate is at and above the refresh rate of your display (60 Hz in most cases). Since Far Cry 3 won't achieve that kind of performance on a GT 650M, this might be an option for you.

  • Bowbox Level 1 (0 points)

    I am having Similar Problems, Im on the 2.6Ghz rMBP and I cant get the fps above 20 unless I go to 800x600 resolutions (or similarly rediculously small res). Its very frustrating!

  • Bowbox Level 1 (0 points)

    Let me be more detailed,


    Game Details:

    Res: 1280 x 720

    Video Settings: All Low


    FPS: ~25


    Most Frustrating!

  • minnepinne Level 1 (0 points)

    I have the same problem. Same computer. Other games work fine. Tried to reinstall the graphics drivers. Disable every other service and applications. Nothing seems to fix it.


    All settings to low. It doesnt even seem to lag any more or less if I adjust settings.

  • Bowbox Level 1 (0 points)

    My current solution is going through the Nvidia drivers and selecting the Far Cry 3 application and selecting optimize performance. This seems to make things alittle better and hovering around 28-30 which makes it playable but just not fluid.


    However seeing some youtube videos of people playing farcry3 at 1920x1080 makes me wonder what else I could do to improve my computers performance.

  • saturnotaku Level 3 (525 points)

    Are those gameplay videos you're seeing coming from people with the same hardware and using the same graphical settings as you? An Alienware or similar gaming-focused laptop with an AMD Radeon 7970M or GeForce GTX 680M will be able to play the game reasonably fluidly at 1920x1080. The Mac's GeForce 650M is not a powerhouse by any stretch.

  • minnepinne Level 1 (0 points)

    Seems like it should run really good: http://www.youtube.com/watch?v=N0sSOHiK_uU

  • Bowbox Level 1 (0 points)

    Wow! Huge Difference when you do a SMC Reset!


    Everyone try a SMC Reset!

    This will reset your graphics card to its standard settings which makes a huge difference!


    Turn your Macbook off and make sure the power is connected, hold down (left) shift, control, option and power keys for a second or two and then release all buttons. Now boot your mac up properly and your gaming performance should match the video above. (Thanks Marcus Ball)


    Enjoy Everyone!!

  • saturnotaku Level 3 (525 points)

    Problem is after maybe 10 or so reboots into Windows, the problem will come back again. Reset the SMC, wait another several reboots, lather, rinse repeat. As far as I know, Apple still has yet to release a fix for this.

  • Priost Level 1 (0 points)

    Hello together,


    I have the same problem.


    I´m using a Macbook Pro with i7 3720QM (2,6GHz), 8 GB RAM, NVidia GeForce GT 650M.

    FPS always around 25-30.


    The straingh thing is:

    Other notebooks with two graphics card are realising the same problem because Far Cry 3 runs under the smaller, Intel one by default. On Macbook we don´t have the possibillity to choose the graphics card...


    I was searching for a solution for over a week now. The games runs best with the following properties:

    - Direct X 11 (Nicer graphics and DX9 don´t brings an power boost)

    - Post FX: Low

    - Shadow: Middle

    - All others to the highest level


    I´ve tried:

    - Various VSync options (No one helped)

    - Changing the Far Cry 3 Gameprofil

    - Try to set all the properties on the NVidia system center to best performance like

        - Tripple Buffering

        - VSync

        - Quality management


    I hope all customers bothering with this problems will post here because with this few posts Apple will never recognize the problem!