5 Replies Latest reply: Dec 4, 2012 12:20 PM by chachafrisk
chachafrisk Level 1 Level 1 (0 points)

Please help - I cannot access my photos any more.  I have >400Gb in my library and all attempts to access it have failed.  If I click on Aperture it says I do not have the right file permissions to access.  I have read and write: I unlock it in Finder but there is nothing I can do.  I looked in Disk Utility and tried First Aid, but the Repair Disk says it is ok.  I have held down Option and Cmd and double clicked on Aperture, and have attempted to repair the permissions - it gets half way through a check then says "Could not enforce consitency of files".  The other options to repair do not work as it says I have the wrong permissions!!

 

My only idea now is to put my old discs for Aperture in and apply updates, as the library won't be readable on old versions.  Any ideas welcome ...... please?

 

Thanks, James

  • léonie Level 9 Level 9 (75,645 points)

    James.

    we need more information to get an idea what to suggest:

    • What is your current Aperture version and what version of Mac OS X?
    • Where is your Aperture library located? On an external drive or your system drive? Are the images referenced or managed?
    • If the library is on external drive, what kind of drive, and how is it connected, directly or network volume?
    • When did this start? Was there anything special before you could not open Aperture anymore? Did you install or upgrade new software? Were there any crashes?

     

    To narrow the problem down: Create a new, empty Aperture library for testing and import some images. Can Aperture work with a new library? Then probably reinstalling will not help.

     

    Regards

    Léonie

  • chachafrisk Level 1 Level 1 (0 points)

    Hi Léonie

     

    Thank you so much for offering to help me.  I was gathering answers to your questions (OS X 10.7.5; 3.4.3; external, direct; when I tried to log in today, after a week away - the hard disc, a Fujitsu Siemens 1.5Gb drive, does die inexplicably sometimes, and this may have corrupted it I guess), when it suddenly decided to open!  I have done nothing other than log in via a different login, attempted to open Aperture and got the same error message.  I then logged in via the one I normally use, which failed so many times, on so many fronts, earlier; I read you answer and clicked on Aperture to get the version number to reply to you.......and it opened my library!  I have no idea why, but what a relief! 

     

    Again, thank you for taking the time to help me, I really appreciate it.

     

    Regards

     

    James

  • léonie Level 9 Level 9 (75,645 points)

    You are welcome, James.

     

    It is good to know, you now have access again to your library. But I would really not trust your harddrive, if it is that temperamental, so you may want to check your backup if it is current and working, while your luck lasts

     

    Cheers

    Léonie

  • Lovie1 Level 1 Level 1 (0 points)

    I had the same problem today and called APPLE. I have an older version of APERTURE (Version 2.1.4). They sent me a very helpful pdf file that gave me steps to follow to restore my library.  The very first step worked and all the photos in my 52 projects are back!

     

    The first step said to hold the Option and Command keys as you start Aperture. The Aperture Library First Aid dialog will appear and offer options. 

     

    I hit "Rebuild Database" and after a few minutes all my pictures returned. 

     

    Does Aperture get confused with you delete a number of projects from the library?  Is this "rebuilding" necessary after deleting a number of projects? Should I upgarde my Aperture (I will also have to upgrade my MAC OS) and am not sure I can on an older MacBook PRO?  Advice???

  • chachafrisk Level 1 Level 1 (0 points)

    Glad it worked for you Lovie1 - I tried that with no luck, but thankfully I'm back on.....though I have no idea why!  I am backing it up now though, thanks again Léonie.