Skip navigation

Multimix 8 USB 2.0 multitrack problems with garageband

825 Views 0 Replies Latest reply: Dec 4, 2012 9:31 AM by Benj-TGME RSS
Benj-TGME Calculating status...
Currently Being Moderated
Dec 4, 2012 9:31 AM

Hi everyone,

 

I recently bought the Multimix 8 USB 2.0 FX mixer from Alesis. I'm having problems with the multitrack. The mixer is correctly recognized by the alesis software and garageband (I have the choice with 10 mono entries or 5 stereo entries when creating a new track) but what's surprizing is that only 2 of those entries seem to work correctly (the 9 and 10 mono and the 9/10 stereo). So the signal I receive in garageband is the sound of the entire mixer and not of just one particular channel. The Alesis software is mentionning that I have 10 inputs but only 2 outputs.. Is that normal? Since with the USB 2.0 you are suppose to be able to record each channel separately so having at least 8 outputs...

 

I tried to uninstall the driver and install it again assuming it might have been a software issue but it doesn't make any difference. It's sometime even worst saying I only have 2 inputs...

What should I do?

 

 

I am using:

 

GarageBand 11' version 6.0.5 (428.5)

 

Mac OS X 10.6.8

 

What should I do?

 

Ben

GarageBand (Mac) '11, Mac OS X (10.6.8), Alesis Multimix 8 USB 2.0

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.