4 Replies Latest reply: Dec 5, 2012 9:28 AM by nortonloaf
nortonloaf Level 1 Level 1 (0 points)

I have a PowerMac Quadcore, running OSX 10.5.8.  I'd like to run software that requires Java 1.6 or higher.  I've been searching for awhile and found many similar questions, but no definitive answer:  is this possible?

 

I see that 1.6 is listed on the machine, and I changed the version link, but it didn't seem to 'take':

 

Macintosh:versions bobcold$ ls -als

total 64

0 drwxr-xr-x  14 root  wheel  476 Dec  4 16:31 .

0 drwxr-xr-x  12 root  wheel  408 Dec  4 15:05 ..

8 lrwxr-xr-x   1 root  wheel    5 Dec  4 15:05 1.3 -> 1.3.1

0 drwxr-xr-x   3 root  wheel  102 Sep 28  2007 1.3.1

8 lrwxr-xr-x   1 root  wheel    5 Dec  4 14:16 1.4 -> 1.4.2

8 lrwxr-xr-x   1 root  wheel    3 Dec  4 12:19 1.4.1 -> 1.4

0 drwxr-xr-x   8 root  wheel  272 Oct 31 10:18 1.4.2

8 lrwxr-xr-x   1 root  wheel    5 Dec  4 15:05 1.5 -> 1.5.0

0 drwxr-xr-x   8 root  wheel  272 Oct 31 11:07 1.5.0

8 lrwxr-xr-x   1 root  wheel    5 Dec  4 15:05 1.6 -> 1.6.0

8 lrwxr-xr-x   1 root  wheel   59 Dec  4 15:05 1.6.0 -> /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents

0 drwxr-xr-x  10 root  wheel  340 Dec  4 15:05 A

8 lrwxr-xr-x   1 root  wheel    1 Dec  4 15:05 Current -> A

8 lrwxr-xr-x   1 root  wheel    3 Dec  4 16:31 CurrentJDK -> 1.6

Macintosh:versions bobcold$ java -version

java version "1.5.0_30"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_30-b03-389-9M3425)

Java HotSpot(TM) Client VM (build 1.5.0_30-161, mixed mode, sharing)

Macintosh:versions bobcold$

 

Also, Utilities --> Java_Preferences doesn't show 1.6 as being available, only 1.5 and 1.4 (both show a "CPU-Type" as 32-bit, also).

 

Any help would be appreciated.