7 Replies Latest reply: Dec 6, 2012 6:23 PM by Pancenter
the-design-guy Level 1 Level 1 (0 points)

I had a couple of guys over for a recording session today and ran into a problem with the Independent Input Monitoring function. I had both "Software Monitoring" and "Independent Input Monitoring" checked in Preferences > Audio > Core Audio, and Auto Input Monitoring checked under the Options > Audio menu.

 

When I record-enabled tracks, the fader had NO effect on the monitoring level. One keyboard track was so loud, I had to cut the input level unacceptably low just so the other players could hear themselves. Am I missing something here? I don't recall having this problem in the past. I'm not sure what settings might have changed.

 

I have recently added a Mackie Onyx Blackbird to my TC StudioKonnekt to get some more input channels, but I don't see why this would affect the software monitoring. I just created a new file to see if there might have been some problem with the file I recorded earlier. No luck. Same problem.

 

******BREAK******

 

After writing that last paragraph, I did some additional testing and verified that the channels that aren't affected by the fader are the ones that are being input through the Blackbird (which is connected via ADAT lightpipe to my TC Studio Konnekt). Meaning, I guess, I have to adjust the monitor levels of the channels hooked up to the Blackbird using the Blackbird Control software mixer (which, as far as I can tell is as unstable as the TC Near software that came with the Studio Konnekt). Hopefully this will solve the problem, but thought I'd post this anyway in case others had the same issue. I guess another option is to create an Aggregate audio device with the TC and the Blackbird. That'll be my next waste of an hour or two...

 

 

Using Logic Pro 9.1.8, System 10.8.2, on a mid-2007 iMac 2.8 GHz


iMac, OS X Mountain Lion (10.8.2), 2.8 GHz, Core 2 Duo
  • 1. Re: Input monitoring not working
    Pancenter Level 5 Level 5 (7,640 points)

    Just curious as to your final results.

     

    Since you're using ADAT into the TC unit do you have The Onyx as the Master digital clock and the TC set to slave to incoming digital clock on the ADAT line?

  • 2. Re: Input monitoring not working
    the-design-guy Level 1 Level 1 (0 points)

    Hi Pancenter,

     

    I am using the TC unit as the clock master. Since I was unable to adjust the monitor volume of the Onyx inputs when they were inserted through the ADAT lightpipe, I unhooked the optical connection and set up a TC/Onxy Aggregate in the Audio MIDI setup.

     

    So far, I've been happy with the results. I can once again control all of the monitor levels. What I did lose, was the ability to add low-latency monitor reverb and compression to the Onyx inputs using TC Near. I've decided that the latency with Logic's Software Monitoring isn't unworkable though.

     

    BTW, I notice some people were reporting problems with not being able to order the devices when making an Aggregate device...hence, not being able to control which device was used for output. I solved this by using TC Near as the Output Device and TC/Onyx Aggregate as the Input Device (in Preferences > Audio > CoreAudio). You have to first set the Output Device (which changes both) and then reset the Input Device.

  • 3. Re: Input monitoring not working
    Pancenter Level 5 Level 5 (7,640 points)

    Thanks for the reply, If I remember correctly they still recommend syncing the two units together by digital clock. s/pdif or optical.

     

    http://support.apple.com/kb/HT1215

     

    They show wordclock in the aggregate tutorial but you could use the Onyx as master clock and the TC as slave.

    The first unit in a digital link setup is almost always (if not always) the master clock.

     

    However, if it's working without dropouts or digital hash at random intervals, why change!  :-)

     

    Unfortunately, an aggregate device will never give you the ability to software monitor at low latency

  • 4. Re: Input monitoring not working
    the-design-guy Level 1 Level 1 (0 points)

    The device setup in Mountain Lion looks a little different than that shown in the Apple docs. I have the units connected with a BNC clock cable, and had to specify which clock to use in both the TC Near and the Blackbird Control software (it took a while for me to figure that out...lots of snap crackle pop in the interim). I'm not sure which unit has the better clock, but it sounds great now.

     

    I had some issues this morning though that lead me to believe that it may matter in which order I turn the two units on. More experimentation required...Audio-Devices-ML.jpg

  • 5. Re: Input monitoring not working
    Pancenter Level 5 Level 5 (7,640 points)

    Thanks for posting the pic and info.

     

    I'd appreciate it if you would post back what you come up with regarding powering up the units and any other issues you might have.

  • 6. Re: Input monitoring not working
    the-design-guy Level 1 Level 1 (0 points)

    A quick update. I did a bit more testing this evening and determined that YES, it does matter in which order I turn on the interfaces. When I hit my power strip that turns them on simultaneously, and then open a Logic project, everything looks okay (i.e. correct interfaces showing in Preferences > Audio > Core Audio with no parentheses around the name), BUT no sound comes out of my monitors. Checking the TC Near software shows that it no longer sees the interface. I have to restart the computer to get it to see the interface again.

     

    The TC interface takes 6 or 7 seconds to boot up, the Blackbird seems to boot up almost instantly. I found that if I turned the TC on first, wait until its booted, then turn the Blackbird on, things work fine. Knowing me, I would probably forget to do that regularly and have to restart my computer a lot. P.I.T.A.

     

    Thinking about it, I came to the conclusion that the problem may be using the clock on the slower booting interface (TC) as the master clock. I switched the BNC cable to go from the Blackbird "out" to the TC "in" and changed the clock source in the TC Near software and the Blackbird Control software to allow the Blackbird to be the master clock. Now I can start the two interfaces simultaneously with my power strip and everything works fine.

     

    I was also considering just keeping the Blackbird turned off except when I needed the additional inputs, but there is a problem with that as well. If you use the Options > Audio > I/O Labels to label your inputs with an aggregate device and then switch to a non-aggregate device, the I/O labels no longer apply (at least in my case).

     

    Hopefully, I'm good to go now. I'll let you know if I find more surprises though.

  • 7. Re: Input monitoring not working
    Pancenter Level 5 Level 5 (7,640 points)

    Thanks for getting back...

     

    Having installed digital patchbays in a couple of studios I can confirm the way you now have digital clock is the correct and most trouble free method, that's why I mentioned it earlier. The first unit in a digital chain (the Onyx in this case) is always the master, at least in all scenarios I've worked with.

     

    Good luck-