1 2 3 Previous Next 35 Replies Latest reply: Dec 13, 2012 3:47 PM by g_wolfman Go to original post
  • 15. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Courcoul Level 6 Level 6 (11,470 points)

    I agree that the shortest and least-effort path to getting the Mac to access the Ext-3 filesystem is thru the OSXFuse solution. Using a virtualized Linux instance thru VBox is vastly more complicated (althoug vastly more interesting to a redblooded geek...).

  • 16. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    I found the free version of virtual box.  I'm just stumped on how to get it working.  I'll try osxfuse or macfuse.  I"m not a complete noob with computers, just linux.  I know absolutely nothing about linux.  To answer your question about the hard drive formatted in linux, I have a hard drive connected to my xbox and the hard drive is formatted in linux so the hard drive needs to be also.  I'll keep you posted.  Thanks!!!

  • 17. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    Ok I'm almost there!  I just need a little more help.  I"m stuck on this step:

    4. Create a mount point by making a directory in your /Volumes folder or anywhere on your system.

    How do I access the Volumes Folder?  And is the directory just a subfolder in the volumes folder?  Thanks.

  • 18. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Courcoul Level 6 Level 6 (11,470 points)

    First you need to get into the Volumes subdirectory, it is normally hidden. So go to the Finder and in its Go menu choose Go to Folder... type exactly  /Volumes  with no spaces in the textbox that pops up and click Go. A window will pop up and you're there. The mount point thing means "create a new folder inside /Volumes". Just check if a specific name is needed.

  • 19. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    Thanks!  I made a folder titled mountpoint there.  THis is what I type into my terminal:

    fuse-ext2 /dev/disk1s1 /Volumes/mountpoint

     

    After I hit enter I get the following message:

     

    dyld: Library not loaded: /usr/local/lib/libfuse.2.dylib

      Referenced from: /usr/local/bin/fuse-ext2

      Reason: image not found

     

    If I type in the above line without any spaces I get a different message:

     

    -bash: fuse-ext2/dev/disk1s1/Volumes/mountpoint: No such file or directory

     

    What am I doing wrong?  I installed fuse-ext2 module and I installed macfuse.  I put them both in my applications directory.  Do I need to do something else iwth them?  Thanks.

     

     

     


  • 20. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    I also noticed that when I look at the name of my external hard drive in disk utility it now reads:

     

    Mount Point : Not mounted  Capacity : 1.5 TB (1,500,298,346,496 Bytes)

      Format : fuse-ext2  Available : -

      Owners Enabled : -  Used : -

      Number of Folders : -  Number of Files : -

     

    I don't believe it said that the format was fuse-ext2 before, so I may be making progress.

  • 21. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    g_wolfman Level 4 Level 4 (1,120 points)

    Your first command looks correct.

     

    Did you install OSXFuse (or MacFuse)?  If so, then libfuse.2.dylib should be present in /usr/local/lib - probably as a symlink to another dynamic library file.

     

    You probably also need to reboot after installing whichever Fuse system you chose.  Did you reboot?

  • 22. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    Yup, I installed MacFuse.  I did reboot.  Not sure what symlink is.  Same error.

  • 23. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    I installed OSXfuse and tried it again.  Here is the message I got when I ran the line in Terminal:

     

    fuse-ext2: version:'0.0.7', fuse_version:'27' [main (../../fuse-ext2/fuse-ext2.c:324)]

    fuse-ext2: enter [do_probe (../../fuse-ext2/do_probe.c:30)]

    fuse-ext2: Error while trying to open /dev/disk1s1 (rc=13) [do_probe (../../fuse-ext2/do_probe.c:34)]

    fuse-ext2: Probe failed [main (../../fuse-ext2/fuse-ext2.c:340)]

  • 24. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    Ok, my drive miraculously mounted.  However, I still can't write to it.  It won't let me drag and drop a file to it.  Here is the terminal message I get:

    fuse-ext2 -o force /dev/disk1s1 /Volumes/mountpoint

    fuse-ext2: version:'0.0.7', fuse_version:'27' [main (../../fuse-ext2/fuse-ext2.c:324)]

    fuse-ext2: enter [do_probe (../../fuse-ext2/do_probe.c:30)]

    fuse-ext2: Error while trying to open /dev/disk1s1 (rc=13) [do_probe (../../fuse-ext2/do_probe.c:34)]

    fuse-ext2: Probe failed [main (../../fuse-ext2/fuse-ext2.c:340)]

  • 25. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    g_wolfman Level 4 Level 4 (1,120 points)

    OK, I took a few minutes to install fuse-ext2 (already have OSXFuse) and format a USB stick in a Linux VM so I had a disk to play with.

     

    This is what you need to do (and in my opinion, the whole process is shaky and error-prone, so you are working at your own risk here...this is simply the least shaky and error-prone method I got to work):

     

    When you have OSXFuse and fuse-ext2 installed, simply attaching the drive should cause it to mount and be displayed in the Finder.  This is going to be read-only.  If all you need to do is recover data off this disk, then great.  Everything works and when you are done simply eject it like any other disk.

     

    If you need to write to this disk (and really aren't willing to just use a Linux VM) then:

     

    1. Open Disk Utility.  You will see the disk with its volume directly underneath it. 

     

    2. Select the volume.  Click the Info button in the toolbar and note the device identifier (disk3s1, disk4s1, or something similar.  If it's simply like "disk3", then you selected the disk, not the volume), as you will need it later;

     

    3. Ensuring you have still got the volume selected, click Unmount (NOT Eject) in the toolbar.  The volume should be greyed out now;

     

    4. Open the terminal.  Type the following line (except replacing the disk identifier and mountpoint with the correct information specific to your set up) at the command prompt:

     

    sudo fuse-ext2 -o force /dev/disk4s1 /Volumes/Linux

     

    You will be asked to type your administrator password, which will not be echoed back at all as you type it.  The volume should now mount on your Desktop.

     

    5.  Do whatever work you plan to do.  Note that the fuse-ext2 project makes the warning that there is no guarantee that a read-write mount is safe or bug-free.  Caveat emptor.

     

    6.  When done, return to Disk Uitility, select the disk (not the volume this time) and click the Eject button in the toolbar.

     

    Essentially, fuse-ext2 mounts the disk as owned by root with rwxr-xr-x permissions.  Therefore, you need to authenticate using sudo to get the -o force option to "take" in order to allow write access.  If you "Get Info" on the volume in the Finder after it mounts, you will see you have "custom access".  Personally, I would call this a bug in fuse-ext2, but it is only version 0.0.7...so it's not like bug-free can be expected.

     

    And one final time...caveat emptor.  No guarantees about stability, data loss or anything else if you are trying to use fuse-ext2 for read-write access.

  • 26. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    Thank you so muCh!  I'll try it as soon as I get home.  Just to clarify, the risks are too the linux drive and the file I am trying to transfer, not to my macbook right?  SO worst case scenario I lose the data on the linux drive or the file I am transfering right?  If so, that's a risk I'm willing to take.  Linux VM refers to using the virtual box application right?  I already gave that a shot and probably didn't use it right.  I wasn't sure which options I needed.  If all else fails, I would be willing to partition my HD into linux even though I have no ideo how to use linux.  Am I correct in assuming that I would not be able to transfer files from my OSX partition to my linux partition?  I would have to put all the software on my linux partition and reaqquire those files right?  Wolfman:  I'll try your suggestion tonight and let you know how it goes.  Thanks again!!!!

  • 27. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Courcoul Level 6 Level 6 (11,470 points)

    Turpulus wrote:

     

    I would be willing to partition my HD into linux even though I have no ideo how to use linux. 

    That is practically a no-go solution for most users. BootCamp now supports only Win7, maybe Win8 with an update. Coercing BC to install other OS's or using alternate non-BC dualboot strategies require a profound knowledge of both the Mac's architecture as well as all the OS's involved.

     

    In other words, even Sheldon Cooper would have to think twice for this one.

  • 28. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    g_wolfman Level 4 Level 4 (1,120 points)

    The risks would be to the file you are trying to transfer - mainly that the write would fail partway through - and to the Linux partition - mainly that a failure could corrupt the partition.

     

    I imagine that the risks are fairly low...but I have no idea for certain.

     

    In any case, the original file and your Mac hard drive should be safe enough; you are only reading from them.  Anything that goes wrong would be on the writing side.

  • 29. Re: Macbook Pro won't detect linux partitioned external HD.  HELP!
    Turpulus Level 1 Level 1 (0 points)

    Still won't work.  I'm getting the bad mountpoint message.  Here is the info:

     

    Name : X360ISOS

              Type :           Partition

     

              Disk Identifier :           disk1s1

              Mount Point :           /Volumes/X360ISOS

              File System :           fuse-ext2

              Connection Bus :           USB

              Device Tree :           IODeviceTree:/PCI0@0/EHC2@1A

              Writable :           No

              Capacity :           1.5 TB (1,500,298,346,496 Bytes)

              Free Space :           1.12 TB (1,115,764,486,144 Bytes)

              Used :           361 GB (360,996,397,056 Bytes)

              Number of Files :           115

              Number of Folders :           0

              Owners Enabled :           Yes

              Can Turn Owners Off :           No

              Can Repair Permissions :           No

              Can Be Verified :           Yes

              Can Be Repaired :           Yes

              Can Be Formatted :           Yes

              Bootable :           No

              Supports Journaling :           No

              Journaled :           No

              Disk Number :           1

              Partition Number :           1

     

     

    Here is what is going on in the terminal:

     

    sudo fuse-ext2 -o force /dev/disk1s1 /Volumes/X360ISOS

    fuse-ext2: version:'0.0.7', fuse_version:'27' [main (../../fuse-ext2/fuse-ext2.c:324)]

    fuse-ext2: enter [do_probe (../../fuse-ext2/do_probe.c:30)]

    fuse-ext2: leave [do_probe (../../fuse-ext2/do_probe.c:55)]

    fuse-ext2: opts.device: /dev/disk1s1 [main (../../fuse-ext2/fuse-ext2.c:351)]

    fuse-ext2: opts.mnt_point: /Volumes/X360ISOS [main (../../fuse-ext2/fuse-ext2.c:352)]

    fuse-ext2: opts.volname: X360ISOS [main (../../fuse-ext2/fuse-ext2.c:353)]

    fuse-ext2: opts.options: force [main (../../fuse-ext2/fuse-ext2.c:354)]

    fuse-ext2: parsed_options: force,allow_other,local,noappledouble,fsname=/dev/disk1s1,fstypename=ext2,volna me=X360ISOS [main (../../fuse-ext2/fuse-ext2.c:355)]

    fuse-ext2: mounting read-write [main (../../fuse-ext2/fuse-ext2.c:369)]

    fuse: bad mount point `/Volumes/X360ISOS': No such file or directory