1 Reply Latest reply: Dec 5, 2012 5:21 AM by lllaass
tmillsy12 Level 1 Level 1 (0 points)

Every time I plug in my iPod it says "The iPod “Taylor's Touch” cannot be used because it requires iTunes version 10.6.3 or later. Go to www.itunes.com to download the latest version of iTunes." I went onto iTunes.com to download the newest version but when I went to install it, it said "This software requires Mac OS X version 10.6.8 or later." So then I go to try to download this software and that doesn't work either. This all started after I updated my iPod touch. So do I need to buy the Mac OS X snow leopard version or is there a way to go back to the old version I had on my iPod touch? Help please!?!

iPod touch (3rd generation), iOS 6.0.1