1 2 3 4 Previous Next 50 Replies Latest reply: Feb 19, 2013 7:29 PM by steve_kn
steve_kn Level 1 Level 1 (0 points)

The remote app on my iPhone (latest version of remote app and IOS 6.0.1) has limited ability to control my iTunes library on my iMac (OS X 10.6.8) compared to earlier versions of iTunes. This occurs whenever anything is typed in the search iTunes window on my iMac. This example is when iTunes is displaying the "Songs" view, but I believe it's present in all iTunes 11 views. Once a text string is typed in the search window, the iTunes window on my Mac only displays items matching that search text string. This is normal. On my remote app on my iPhone 4s, I can browse my full iTunes library. This is also expected behavior. From my remote app, I can play any song in my library that is also displayed on the iMac iTunes 11 window (limited by the search window string.) This is normal.

 

This is where things get odd. If I use my remote app to browse to a song in my library that is NOT displayed on my iTunes 11 window, the song will not play. It gives the following error message:

 

"The song "x" could not be played because the original file could not be found."

 

This is unexpected becuase previous versions of iTunes allowed the remote browsing to supercede any iTunes search window text displays. I can only use the remote app to play whatever is in the iTunes windows on my iMac.

 

Another thing that's really odd is that the error message on the remote appears to be a bug. When it says "the song "x" could not be played...", the error message actually lists the "artist" and not the "song". Maybe that's the source of the problem, as the remote app error message is confusing the "song" with the "artist". The error message is:

 

"The song "[artist, not song]" could not be played because the original file could not be found."

 

Has anyone else seen this? If so, is there a fix? (Other than going to the iTunes 11 window on my iMac and clearing the search string. Sort of defeats the purpose of the remote if you have to run back to your desktop.)

 

Also, iTunes 11 INCREDIBLY slow, but you already have numerous complaints about that. Disabling "Search Entire Library" improved iTunes 11 from being unusable, to undesirable.

 

Thank you


remote app, iOS 6.0.1
  • 1. Re: remote app not working with iTunes 11
    james dawson (twibble) Level 1 Level 1 (15 points)

    Sorry, no solution. I get the same message when playing a song that it cannot be found

  • 2. Re: remote app not working with iTunes 11
    k1r Level 1 Level 1 (0 points)

    I had the same issue UNTIL I ejected my iphone from iTunes.  I had been using WiFi Sync.  That fixed it for me.

  • 3. Re: remote app not working with iTunes 11
    Superleccy Level 1 Level 1 (5 points)

    Had the same problem but seem to have fixed it now.  I can't remember exactly what I did, but try the following:

     

    1. On iTunes 11: Log out of the iTunes store, and turn-off home sharing.  Then quit iTunes.

    2. On the iPad: Delete the Remote App.  Then re-download it and open it again.  This should force you to re-login to Home Sharing from the iPad.

    3. On iTunes 11: Open iTunes again, log back into the iTunes store, and re-enable Home Sharing.

     

    Some of those steps may be superfluous, or maybe it was something else I was doing that fixed it.  Let me know how you get on.

     

    SL

  • 4. Re: remote app not working with iTunes 11
    steve_kn Level 1 Level 1 (0 points)

    Thank you for the replis, k1r and Superleccy. I tried repeating your steps on my iPhon and I'm still seeing the same problem.


    This is initeresting. I can play any song that it's in a playlist from the remote on my iPhone, but if I try to play anything other than a playlist song (or whatever is already displayed in the iMac's iTunes 11 window) I keep seeing the bogus error message that reads:

     

    "The song "x" could not be played because the original file could not be found." Where x is actually the artist and not the song.

     

    If I play a song from within the playlist with the remote, then go back and try to play the same song by finding it on the remote under artist, album, or song, the same song won't play from the remote. Even though it will play it from the remote from within the playlist.

     

    This looks like a bug.

  • 5. Re: remote app not working with iTunes 11
    Superleccy Level 1 Level 1 (5 points)

    Yes, I had the same error message (x was indeed the artist rather than the song), but it seems to be fixed now.  I did a fair amount of frustrated hacking so maybe it was something else I did that fixed it.

     

    When I restarted iTunes, I did so prior to disabling "stealth mode" on the firewall.  I've come across situations before where stealth mode was the culprit, although in this instance I could now be clutching at straws.

     

    But you are right, it is a "bug".  It shouldn't be this complicated.

     

    SL

  • 6. Re: remote app not working with iTunes 11
    colmaclean Level 1 Level 1 (0 points)

    I managed to remedy it by playing a song using iTunes directly. This seems to kick the Remote app into life.

     

    However, the problem reappears intermittently. Definitely a bug.

  • 7. Re: remote app not working with iTunes 11
    Superleccy Level 1 Level 1 (5 points)

    The bug came back.  This time I magaed to fix it by ejecting all my attached iDevices (iPad & iPhone on WiFi sync, plus my old iPod Classic that happened to be attached by USB at the time).  Been fine since so-far.

  • 8. Re: remote app not working with iTunes 11
    robotron_89 Level 1 Level 1 (0 points)

    This seems to fix this weird bug. Seems to be working fine since ejecting my iPhone from WiFi syncing.

  • 9. Re: remote app not working with iTunes 11
    Brovig Level 1 Level 1 (5 points)

    I am also experiencing the very same issue as outlined by steve_kn, and my setup is a little different from the rest of you. I have a Windows 7 desktop running iTunes 11 and an iPad2 running the latest remote app. I keep getting the message "could not be played because..." and with the "song" reference being actually an artist.

     

    I've tried various things and not yet found a way around it. I have no other devices connected to the desktop.

     

    I'm also VERY disappointed with the performance of iT11. Slow as mud - fast for a few seconds and then periods of long hangs. I'm not particularly enamoured with the new interface and I miss some of the features of old.

     

    I was really looking forward to this new rel of both iT and remote app. With this state of things i think it's time I look to other solutions, like J River.

  • 10. Re: remote app not working with iTunes 11
    steve_kn Level 1 Level 1 (0 points)

    Thank you for the replies, everyone. I'm glad to see I'm not the only one experiencing this bug. It gives me hope that Apple will issue an update to address this.

     

    I've checked the setting for wifi sync and it has never been enabled. I've ejected the remote, disabled/enabled sharing, re-installed the remote app, etc, everything I can think of, but the bug is still here. I still see the bug in iTunes 11.01 (12). Maybe Apple will issue a remote app update....

  • 11. Re: remote app not working with iTunes 11
    ahmetfrompoole Level 1 Level 1 (0 points)

    I too have a problem getting my 2010(early) Mac mini working with the remote app from my ipad4. It saw my iTunes 11 OK to start with. Then after I restarted my Mac mini it would not see it again. It keeps saying I need to set up home sharing on my computer.  I have tried everything it just will not work. Yet my late 2010 Mac mini which runs iTunes 10.7 is perfectly ok with my ipad 4 and the remote app. So I must conclude that it is a bug in the iTunes 11.  Mind you I never liked the iTunes 11 anyway. If there was an easy way to revert back to iTunes 10.7 I would do it.

  • 12. Re: remote app not working with iTunes 11
    topperdog Level 1 Level 1 (20 points)

    My remote app sort of works. When my iPad goes to sleep though after a few minutes, whe i open it up again the remote app freezes and displays a lock on top of the gui.  Then it crashes out after about 45 seconds of being frozen. Not ever an issue on 10.7. Only difference is the installation of the 11.0.1 software.  One of many bugs i have found. 

  • 13. Re: remote app not working with iTunes 11
    bluefieldarts Level 1 Level 1 (0 points)

    Thanks for your post Steve. I tried searching for this issue, couldn't find anything and thought it was just me. I had already tried most of the mentioned "fixes" and they haven't worked for me, accept temporarily. There are clearly bugs here. The whole iTunes 11 update is a mess for me.

     

    It is not necessary to delete the app to establish a new connection - just delete the airplay connection, and establish a new one. Voila, the remote works again, but as I said it is temporary for me. Comes right back if you haven't used the app in a while.

     

    Also found that different methods of going directly into iTunes to reset things or kickstart things also works, but also is a temporary fix, and as mentioned, defeats the whole purpose of the remote app.

     

    I seem to remember more varied methods for sorting or displaying ones music library via the app in previous versions, but all I'm seeing is a long list of my 2000 albums viewed alphabetically when I view by Genre (my preferred method for searching), even though I have set the preference to view by artist (this only seems to work under the Songs view, or Album view, but not Genre - but still a long list). And why does it say "Songs" at the top of a list of albums? More bugs?

     

    Message was edited by: bluefieldarts

  • 14. Re: remote app not working with iTunes 11
    icerabbit Level 3 Level 3 (765 points)

    I've seen the same "The song "x" could not be played because the original file could not be found." as well since the new iTunes 6 & Remote app.

     

    I'm rebuilding my library with higher encoded imports, adding art work as I go. I rerip albums in batches, they show up in Remote on the iPad 1 ( - not on the iPad 3, that one only shows 24 random albums - ), it will list all the songs, but then when I tap to play one, it says the song cannot be found??


    Play something else. Wait ten minutes. Then it plays fine.

1 2 3 4 Previous Next