Previous 1 2 Next 24 Replies Latest reply: May 6, 2014 10:09 AM by Urthwise Branched to a new discussion.
MatthijsDB Level 1 (0 points)



I just recently got a Iphone 3G but in the market i can't buy anything because i don't have IOS 4.3 or 5.0 or it says "This app doesn't work at Iphone"???

Please help me out how i can upgrade it to a higher IOS or give me another app market where i can download them asswell... tnx.

iPhone 3G, iOS 4.2
Previous 1 2 Next