1 Reply Latest reply: Dec 6, 2012 10:30 AM by Barry
DoctorFresh Level 1 Level 1 (20 points)

Has anyone else suffered with the Autocorrect feature in Pages inserting nonsense?

 

In particular, if I use names - rather than mark the name as an unknown word (i.e. red underline), these are regularly turned into complete nonsense.  I have just, for example, created a document in which one of the parties is called Chell, which Pages is determined to turn into 'hCell'.

 

This is commonplace, in my experience.

 

The pseudo-words inserted are complete rubbish, often with capitals in the wrong place etc.

 

Is there some way of editing the .plist of autocorrect entries or eliminating the rubbish entries (I know that what constitutes a 'rubbish' entry is a matter of judgment, but there are lots of pseudowords that Pages tries to impose on my text like the example given above)

 

Or is there somewhere from which I can download and install a more 'normal' autotext .plist?

 

Thanks

 

Dr F


iMac, OS X Mountain Lion (10.8.2), iMac, MBA, new iPad, iPhone 5 & TV
  • 1. Re: autocorrect - odd corrections
    Barry Level 7 Level 7 (29,180 points)

    Simplest solution currently is probably to allow the spellchecker to flag words, but to turn off 'automatically use spellchecker suggestions.'

     

    Leaving that feature turned on forces the application to replace any unrecognized 'word' (such as 'Chell') with its suggestion in any case where there is only one suggestion available. "hcell," is a legitimate word, and the spellchecker preserves your capitalization of the C.

     

    An alternate, should you wish to continue using 'automatically use...' is to make the spellchecker 'learn' 'Chell' as an acceptable word not needing correction.

     

    Regards,

    Barry