7 Replies Latest reply: Dec 6, 2012 11:12 AM by VNHH
VNHH Level 1 (0 points)

We have started allowing employees to use their personal iPhones for work.  To ensure proper setup and to prevent tinkering with settings, we are using the iPhone Configuration Utility to load profiles onto the devices that setup the Exchange account(s) and enforce some security settings and restrictions.

 

Here's where we're running into an issue:

 

After loading the profile and setting up the Exchange email, the only option available under "Settings>Mail, Contacts, Calendars>Default Account" is the employee's personal email account.  The Exchange account(s) don't appear as an option.

 

Now,

 

If we setup the Exchange accounts manually on the device (meaning, without using a profile and the iPhone Configuration Utility) all the accounts are available to select from under the "Default Account" setting. 

 

I tried contacting Apple support about the issue- in short, I talked to a second level support tech who I could barely understand and communicate with and all he did was run through the standard "clear all settings, reboot and set it up again.  After about 3 or 4 settings resets and full device erases with the same issue occuring each time I setup the profile again, I gave up trying.

 

I have confirmed that it is an issue on the iPhone 4, 4S and 5 running iOS 5.1 and iOS 6

 

Is there anyone who's encountered this and/or might know enough about the software innerworkings to help determine a cause and/or solution?

 

Thanks for your time,

 

~Mark


iPhone 4, iOS 6
  • Bonesaw1962 Level 4 (1,255 points)

    Mark, I just tried this on the new iPad mini I have and wasn't able to repeat it.   I'm using the Windows version of IPCU 3.6.0.295.  After adding the Exchange account with IPCU ( I always give the account a logical name in        setup to distinguish it from any other device accounts), under calendars, default, I got the device calendar and the Exchange Calendar.  I then removed the profile, setup exchange manually and found that the default calendar choice was no longer available.  Is this the issue you are seeing? 

  • VNHH Level 1 (0 points)

    Thank you for the reply Bonesaw- you're making me feel like there is a glimmer of hope!

     

    I'm using the Windows version of IPCU 3.6.1.296. 

     

    The issue we're having is with choosing the default email account.  I checked the calendar settings and I can choose from all the accounts, just as you reported.  Not sure why the same options aren't showing up in the email settings.

  • Bonesaw1962 Level 4 (1,255 points)

    In your IPCU payload category Exchange Active Sync, what are the settings for "Allow Move" and "Use only in Mail"?

  • VNHH Level 1 (0 points)

    The check boxes for both are checked.

     

    Hmm.....you may be on to something.

  • VNHH Level 1 (0 points)

    It worked!

     

    I unchecked the "Use only in Mail" setting and it allows the other account to be selected.

     

    I owe you BIG time!

  • Bonesaw1962 Level 4 (1,255 points)

    I'm glad it worked

  • VNHH Level 1 (0 points)

    Thanks again!