Previous 1 2 3 Next 39 Replies Latest reply: Jul 15, 2015 4:57 AM by ckeilah
webalias rex Level 1 Level 1

My Mac Mini's four USB 3.0 ports work fine with my four USB Seagate GoFlex 3.0 hard drives. The drives mount at startup, and perform at expected USB 3.0 speeds. But, when I connect the drives to a USB 3.0 HUB to free up the Mac's USB ports for other devices, typically two of the USB Seagate drives will mount at startup, but two won't. There's a fix for this: after startup, I simply disconnect AC power from the drives that didn't mount, and reconnect the power a few seconds later. Now all my drives are mounted, they perform properly, and other USB devices connected to other Mac Mini USB ports (a mouse, a USB midi interface) work just fine as well. It's annoying, though, to have to perform this extra disconnect-reconnect step every time. I've tried two different USB 3.0 HUBs -- one from Uspeed and one from Satechi -- and I have exactly the same problem with both. Question: Is anybody else experiencing the same thing with a late 2012 Mac Mini and a USB 3.0 Hub? Has anybody found a 3.0 Hub that doesn't have this issue with the Mac Mini?

Mac mini (Late 2012), OS X Mountain Lion (10.8.2)
  • BDAqua Level 10 Level 10

    Hi, just asking, are these USB3 Hubs AC powered, or Bus Powered?

  • woodmeister50 Level 5 Level 5
    Servers Enterprise

    Since your Mini is new, have you tried contacting Apple

    support directly?  You do get 90 day free phone support,

    3 years if you bought Applecare.  Make them aware of the

    issue directly.


    There seems to be some random odd issues with USB 3

    stuff, drives in particular.  At least this point in time there

    aren't any patterns.

  • webalias rex Level 1 Level 1

    Both HUBs are AC powered (though I think one may be able to run at least one of them on bus-power, haven't tried).

  • BDAqua Level 10 Level 10

    So, how many ports on these hubs?


    And what mA output on the PSU?

  • webalias rex Level 1 Level 1

    I went ahead and contacted Apple support, and must have spent an hour on the phone with two different Apple techs. They tried to be helpful, but my issue isn't resolved. One of them sent me a link to an Apple doc I'd already read, which says, "Hubs that conform to what is commonly referred to as the '2008 version 1 USB 3.0 specification' are supported.


    The problem is, nobody at Apple (or anybody else I can find) seems to know which of the currently available USB 3.0 Hubs -- if any -- conforms to this 2008 version 1 USB 3.0 specification. The technical information supplied with the two USB 3.0 Hubs I own (one from Satechi and one from USpeed) don't mention the 2008 spec issue in any of their documentation. In fact, I can't find any 3.0 Hub that references this spec, and Googling it doesn't turn up much either, mainly references to that same Apple doc. The Apple tech kept stressing that USB 3.0 is a new standard, which apparently makes figuring out what works and what doesn't, and why, problematic. Perhaps it's no coincidence that there are no USB 3.0 Hubs for sale at Apple's online store, despite 3.0 being available on new Macs.


    In the meantime, last night I discovered something weird by accident: If I don't connect the Satechi Hub to AC Power, but let it be bus-powered by the Mac Mini, mysteriously the four Seagate 3.0 drives connected to the HUB all mount at startup. Every time. I'd say that solves the problem, but I'm not sure that enough power is being supplied, and I fear I may end up with some other issues. Also mysteriously, a couple of times when I tried connecting the Hub to its AC adapter after that successful boot, at least one of the hard drives temporarily unmounted --producing the typical "This disk was not ejected properly" type error message for just a second -- then the drive magically remounted.



  • webalias rex Level 1 Level 1

    Four ports on each of the HUBs. The power supply for the Satechi Hub is 5V, 3A. For the USpeed, 12V, 2.0A

  • BDAqua Level 10 Level 10

    How much mA do the drives use on startup?

  • emilcar Level 1 Level 1

    Maybe here is a solution:

  • buffett0462 Level 1 Level 1

    You have to plug in the hub unit to the computer FIRST, to establish 3.0 connection.


    Try this and see if it works.



  • AWMarine Level 1 Level 1

    Regarding your commment: "In the meantime, last night I discovered something weird by accident: If I don't connect the Satechi Hub to AC Power, but let it be bus-powered by the Mac Mini, mysteriously the four Seagate 3.0 drives connected to the HUB all mount at startup. Every time. I'd say that solves the problem, but I'm not sure that enough power is being supplied, and I fear I may end up with some other issues. Also mysteriously, a couple of times when I tried connecting the Hub to its AC adapter after that successful boot, at least one of the hard drives temporarily unmounted --producing the typical "This disk was not ejected properly" type error message for just a second -- then the drive magically remounted."



    Question: Did you check to see if the drives connected to the unpowered hub were mounting at USB 3.0 (5 GB/sec). Curiously enough, I plugging my Uspeed 7-port hub into my MacBook Pro Retina to show the attached screen shot on where to verify this information and found that all 5 or my physical drives (2 desktop and 3 portable USB 3.0) had mounted at 12 Mb/sec or USB 2.0 speed. The hub is powered at this time. Note that mounting at USB 2.0, or even USB 1.1, is infrequent, but it does happen.


    I made a screenshot of the above and annotated it to clariby that the drives were at "Hi-Speed" rather than USB 3.0 "SuperSpeed" but this board would not let me attach the image. Sorry about that.


    Your posting of the Satechi hub drew me as I'd just learned of the hub being an option to the Uspeed. I was disappointed to find that it performed the same as the Uspeed. A friend with Windows 7 has a 7-Port Uspeed hub that has worked "like a dream" for him. I've learned that in using 15 distinctly different brands and models of USB 3.0  hubs that there is not one that's workable on hubs used with the Mac USB 3.0. With that many hubs it's clear to me that the problem is with Apple not communicating effectively with the USB 3.0 hubs. I've had my rMBPro since June and have been searching unsuccessfully for a workable solution. I've worked extensively with AppleCare and with Genius' with no progress. I'm told that Apple is ignoring the problem since drives connected directly to the Macs' work fine. It's only when the hub is connected. Don't forget, it works like a dream on Windows. I suspect that Apple has been putting all their resources into iPhones and iPads and letting the Macs hang out there. Don't forget, this problem has been out there since June! Windoze is beginning to look good again.

  • doug gosciak Level 1 Level 1
    Mac App Store

    I have a Mac Mini (Late 2012) that is experiencing USB 3.0 problems using a HooToo HT-UH006 USB 3.0 hub.


    The symptoms I am seeing  are that sometimes external HDD will mount and sometimes not. In assition, I have some 16GB USB 2.0 flash drives (Lexar LJDTT16G-000-117Q) that also exhibit intermittent mounting issues.


    I tried this hub because on their web site they only warned about the 2012 June MacBook Air and MacBook Pro, so I thought I was safe to buy one for my Mac Mini.


    I sent an email to HooToo tech support and got a very promt reply back to my questions which I will post here:


    (1) Do I dare use the HT-UH006 with my Mac Mini (Late 2102)?


    Yes, you can have a try on your Mac Mini. The problem between USB 3.0 hub and Mac Mini is only data transfer stability. USB 3.0 hub might not be sync by Mac or be unstable when transferring data. It will not cause any big disaster such as power shortage or ruin of your Mac Mini.


    (2) If I use the HT-UH006 what kinds of problems might I encounter?


    You might encounter unstable data transfer or the hub will not be recognized by Mac Mini at all.


    (3) Are there fixes to this problem available? If so, how do I go about getting them applied to my hub?


    Not yet. You can see other Mac users' experiences with different USB 3.0 hubs on MacBook Pro and Mac Mini:

    Apple is still researching on this issue and we might need to wait for their updates. However, no exact date is given.


    (4) If no fix is currently available, when might I expect a fix to this issue?


    It depends on Apple, we are sorry.


    (5) Should I abandon all hope and return this product to Amazon and go seeking a USB 3.0 hub that works with my Mac Mini (Late 2012)?


    If after trying the hub on Mac Mini and it fails to work, I am afraid that you need to return the hub to us. We will be responsible for all fees caused and issue you a full refund on the order. You could go seeking a compatible hub but according to the experiences of other Mac users, it seems that most USB 3.0 hubs in the market now have conflict issues with Mac Mini and MacBook Pro.


    You can provide me your order ID and I can help process refund on this unit. Also, you don't need to return the hub to us if you are willing to keep it so that if future workarounds are released by Apple, we can contact you and you can give it a try.


    So, I am continuing to research this hub and will pass on anything more that I find out.


    Furthermore, based upon the comments I read in the 2 URL pointers from HooToo, I yesterday ordered yet another hub from Amazon. It is not the one recommended in the MBP Retina discussion, but is from the  same vendor and supposedly with a later chipset and later firmware. I figured what the heck go with the latest rev and hope more issues were resolved. The Amaxon URL to the hub I ordered is:



    Currently it is scheduled for delivery 11/14-11/15. I hope I have good luck with this one and will update here with the results.

  • tbirdvet Level 4 Level 4

    I have a USB3 hub by kdlinks (AC powered).  It is a 4 port hub and works with no issues.  I have used several different USB 2 and USB3 drives and all work at the correct speeds and no disconnects.

  • AWMarine Level 1 Level 1

    The USB 3.0 hub instability problems extend beyond the Mac-Mini, as addressed below.


    At long last we're seeing progress in getting 2012 Macs to work with USB 3.0 hubs. As discussed on this and other discussion groups I've had a horrible time with my MacBook Pro Retina  being unstable with USB 3.0 hubs. I know many of you have also or you wouldn't be reading this posting. 


    In June 2012 I bought one of the first 2012 MacBook Pro's with a Retina display. It's been a battle since with Apple selling what appears to be an incompatible or unstable system to effectively communicate with the USB 3.0 hubs. You'll see vendors now making comments that Apple is the source of the problem.


    I've been through USB 3.0 issues with two MacBook Pro Retina laptops. I've also tested a Uspeed hub, with 3 portable USB 3.0 drives connected, at the Apple Store. This was on a newer model MacBook Pro Retina, and also on a 27" iMac. All had instances where drives failed to mount during the short period allowed for testing. (Because of time constraints, we were unable to test at the Store for spontaneous and unprovoked unmounting of drives connected to the hub. These problems have existed since the beginning on my rMBP.)


    I am now on my 20th hub that has been purchased, or provided for testing. They varied from 4-Port to 10-Port powered hubs and involved 11 brand names. Comments were posted on Amazon, Tiger, and others for most of the ones purchased, and some that were tested. Some, like the HooToo specifically warned against use with Macs in the manufacturer's manual and, as I learned, for good reason. That was reflected in my comments for the drive on Amazon.

    The Plugable 7-Port USB 3.0 powered aluminum-finish hub that I have been testing since October 13 was provided  by Plugable after the first one, purchased through Amazon, was returned as unreliable. This 3rd, and newer generation Plugable hub uses the VIA VL812 chipset with the new version 90.81 firmware. My experience over the last 4+ weeks with this hub has been solid. While there have been problems with Eject errors, none were traced to the hub electronics. (Problems with intermittent connections at the cable connectors  appeared to be the cause of the disconnect errors. Almost all of the failures were traced to intermittent Micro-B connectors, but that's another story.)


    In addition to the greatly improved reliability of this hub, I find several features of this Plugable to be a plus including:


    • The plug engages fully to the "hilt" when plugged into the hub giving a solid connection, as occurs on the MacBook Pro Retina USB 3.0 ports. Others hubs typically had a gap between the "hilt" of the connecting end, and the hub allowing for lateral movement. With some hubs this allowed for intermittent connections if the cable was disturbed.


    • The on/off switch on the hub allows the hub to be powered down when not in use.


    • The full size Type-B connectors on the cable at the hub end engage solidly. Hubs with Micro-B connectors have presented intermittent connections in the cable connector.


    • The aluminum case looks attractive with Macs, IMO, but not a reason to buy.

    Overall, Plugable's support is the best I've encountered. I've found their response to questions to be prompt and thorough. This, coupled with their online support articles has put them at the top of my list. They provide news and information that I've not found with other hub vendors.

    The article titled "Plugable USB 3.0 7 Port Hub Firmware History" at the below link gives insight into the history of the problems that we've been having with the USB 3.0 hubs on Macs and the firmware updates, regardless of the brand of hub you have.  Apparently, if you have the VIA VL 812 chipset, firmware version 85.81, you're in safe territory.


    (One of the Plugable hubs appears identical to the black 7-Port Uspeed hub, and both use the VIA VL 812 chipset. They appear to be from the same manufacturer with the real difference appearing to be in the VL812 version of the firmware in the hub.)


    Some of the firmware can be upgraded, and some can't. Contact Plugable or Anker if you're affected.

    Uspeed has made improvements, but they were still unstable as of the last one I received for testing. In her last reply on 10/13/13 Sunnie with AnkerDirect Customer Support stated:


    Unfortunately, the new Firmware version (908x) does not work with the model "68UNHUB-B7U" you have. The hub bellow has much less complaints about Mac issue. We suggest that you order this one.

    AnkerDirect Customer Support


    Note that the above hub recommended by Anker has an 8th port just for charging iOS devices. Some will see this as a plus. However, the lack of such a port is not seen as a big problem. It's easy and relatively inexpensive to purchase extra 5V power adapters for charging, which is my preference. Plugging and unplugging devices on a hub that is powered "On" presents the potential for movement of the cables. This could interrupt a cable connection  and disconnect a drive during data transfer resulting in corrupted files. With 7 and 10 port hubs, and all the cables needed, this gets risky.

    I believe the USB 3.0 hub issues we're having are the result of poor design of the Mac's USB 3.0 implementation at the start. Unstable hubs that I've had a friend with Windows 7 test, said they "performed like a dream" on his PCs. This indicates the problem is with Macs, not the (twenty) hubs I've used.

    A statement from a support person dealing with USB 3.0 hubs tells what's I've long suspected: " -- the evidence is pointing to something specific to the Apple design (perhaps external to the chipset, like the signal re-driver….."

    If you're having USB 3.0 problems, be sure to let Apple know by sending in a Feedback comment to Apple at: 

    I'm told they read and treat the feedback seriously (although the duration of this USB 3.0  problem makes me wonder if Mavericks and iOS 7 haven't had a higher priority and distracted from this. Microsoft got USB 3.0 right, how about it Apple?)

  • Sherbertdibdab Level 1 Level 1

    I have been using that Anker hub mentioned with the additional charging port for many months now and have had no unmounting or disconnect issues. The only issue I have had is when power is removed to both my late 2012 Mini and the hub due to power outages or removing the plugs from the sockets. One of my WD MY Passport 2TB external drives does not remount itself. The one that does is the specific Mac version, the other mounts itself if you disconnect and then reconnect the USB cable either at the disc end or the at the hub. Unless you are in the habit of unplugging your kit from the mains regularly this is a rare and very minor inconvenience. I have yet to use the charging hub since my iPod Nano and iPad Mini seem to charge just fine through the other ports.


    The solution to disturbing connections is to secure the hub with a couple of blobs of BluTac, works a treat, makes plugging and unplugging drives a doddle.


Previous 1 2 3 Next