1 Reply Latest reply: Dec 6, 2012 9:57 PM by donald0124
donald0124 Level 1 Level 1

I am trying to down load book readers but I keep being told my system is not up to date but when I plug into the Mac and Itunes and try to update I am told I have the latest update??


iOS 4.2, cant update operating system
Reply by donald0124 on Dec 6, 2012 9:57 PM Helpful

all reading the boards I hae an Gen 2 so am at max release . Is there a way to get booke readers for this release?

All replies