Previous 1 2 3 Next 32 Replies Latest reply: Jun 6, 2015 2:50 PM by McChelsea510
richvid Level 1 (90 points)

Have a strange problem with my MacBook wifi connection in that everytime I connect my MacBook Pro to the wifi router it requires a WPA2 password. I type in the password to join only to be told it is an invalid password, however, if I keep repeatedly clicking on the submit button (between 3 and 11 times) it eventually accepts the password and connects to the wifi - I've tried deleting the network and then adding, have deleted the password and reentered it in the keychain.


If I put the MacBook to sleep for any length of time then restart it, once again it forgets the password and I have to go through the whole ritual again.


I'm not having any problems with my iPad, iPhone and recently purchased Nexus 7 (sorry Apple but I need StreetView & YouTube) which all automatically connect.


This issue has been going on for months now. As for OS Lion, well it was running 10.7.4 but I updated it today to 10.7.5 to see if that fixes the problem but it's had no effect.


The MacBook connects flawlessly at home so am not sure what is causing the grief.


Anyone have a clue what is causing this and how to fix it.

  • ethanfromne Level 1 (5 points)

    You could have typed 1 thing for the pasward when changing it then keep typing some thing else example THEDOG for your correct pas ward and you type in thedog.


    <Edited by Host>

  • richvid Level 1 (90 points)

    ethanfromne thanks for your comment, and to answer, I only typed the wifi password in once, then clicked on the submit button several times until it was accepted which is somewhat strange!!!


    Anyone else receiving the 'invalid password' message might want to try this.


    Also...What's with the host 'thought police' editing posts - aren't we even allowed to consider any other options

  • richvid Level 1 (90 points)

    ds store thank you for your reply with the links to hopefully resolve this wifi invalid connection problem with my MacBook Pro which has been annoying me for months.


    Will let you know how I get on and whether I succeed in automatically connecting my MacBook Pro to the wifi router - surely it can't be that difficult when even 'inferior' products have no problems in connecting whatsoever - last comment said in jest

  • CMCSK Level 6 (10,717 points)

    richvid wrote:


    Also...What's with the host 'thought police' editing posts - aren't we even allowed to consider any other options


    Not if it goes against Apple Support Communities Use Agreement













  • richvid Level 1 (90 points)

    The post by ethanfromne was edited by <Host> because he suggested to me that I get my MacBook hacked if all else fails. What was wrong with his suggestion. As a grown adult I think I can make up my own mind.


    If we really want to nitpick then I would say that you have taken this thread off-topic which is generally in violation of most forum rules, will your post be edited or deleted?


    And if you really do want to get embroiled in terms and conditions then the UK Sale of Goods Act 1979 might be a good start for you to read up on because Apple automatically accepted these terms and conditions by continuing to trade in the UK.


    I'm not looking for a fight over smallprint, all I want is for my MacBook Pro to connect automatically to the router, which incidentally connects flawlessly with every other device I own.


    As an Apple customer I expect my MacBook Pro to connect to my router without any problems and in this instance this simply isn't the case, I don't care about tech stuff, I want it fixed, no ifs no buts...

  • ethanfromne Level 1 (5 points)

    I am sorry but I am a little confused  first you were thanking me now you are mad at me. I was not suggesting that you have it hacked I was just trying to be helpful and suggesting that to make sure you had your pasward correct. If you tell me how to take it down I happily will do so.

  • richvid Level 1 (90 points)

    ethanfromne, my reply was a reply to CMCSK and not to you - look at the top info in response to info.

    Re: Macbook Pro wifi invalid password problem

    Dec 8, 2012 12:10 AM (in response to CMCSK)



    Everything you said was correct as I mentioned in my post.

  • ethanfromne Level 1 (5 points)

    Sorry I saw my username and assumed it was for me

  • richvid Level 1 (90 points)

    Update to the problem, this morning at work I awakened my MacBook Pro from its weekend sleepover and it connected to the wifi straight away so I thought fantastic. Put it to sleep several times over the morning  then reawakened it and it still reconnected. Went for lunch so put it to sleep, came back from lunch, awakened it - and it wouldn't connect!!! Restarted the MacBook and it connected instantally to the wifi network - what is going on

  • ds store Level 7 (30,325 points)

    richvid wrote:


    what is going on


    It's working.



    Another trick is to delete all Wifi connections in Network >Airport, then reboot and connect manually and save it in Keychain, this has worked for others.

  • AleCarval Level 1 (0 points)

    I have exactly the same problem!!!!

    I don't know what to do!

    I see you posted this on 2012, and now is another OS (Mavericks) and I have the same problem with my macbook air!!


    Help me please!!!

  • trixie_5uk Level 1 (0 points)

    I too am having the smae problem. wifi was working fine until i downlaoded mavericks onto the macbook pro.  Now my wifi doesnt work at all, keeps saying invail password, yet my other apple devices (iphone, ipad) are working fine through wifi, i have tried everything to no avail. anyone can help would be most apreaicated! P.s Interent works fine through ethernet cable   only wifi troubles

  • rockymac Level 1 (0 points)

    I recently had this problem – new Mac Book Pro would log onto other networks, but not either of my home BT hub wireless networks. Ethernet Cable worked fine, and it would log onto my iPhone hotspot fine.

    I changed my router's wireless setting from 2.4 GHz to 5GHz and that fixed it.

    Shorter range but more bandwidth and less prone to interference.

Previous 1 2 3 Next