6 Replies Latest reply: Jan 13, 2013 8:00 AM by Bill Rising
Bill Rising Level 2 Level 2 (240 points)

I made the mistake of impatiently hitting the escape key (or function key or whatever) often enough to pop up the little round speech feedback window. I cannot for the life of me get the window to close now.

 

According to Apple's support page

   http://support.apple.com/kb/PH10705?viewlocale=en_US

if I "Turn off Speakable Items in Accessibility preferences", the window should close. It does not.

 

I tried making sure that Speakable Items was shut off, and then rebooted my computer. The pesky window appeared again.

 

Anyone have a clue how to get rid of the little monster? Minimizing it to the dock doesn't count---I want it closed.


MacBook Pro (15-inch Mid 2009), OS X Mountain Lion (10.8.2)
  • Bill Rising Level 2 Level 2 (240 points)

    OK, I tried all the following, to no avail:

     

    I opened the Activity Monitor, and quit

      Speech Recognition Server

      Speech Feedback Server

    and then rebooted. The pesky speech feedback window opened.

     

    I then moved

      com.apple.speech.recognition.AppleSpeechRecognition.prefs.plist

      com.apple.speech.recognition.feedback.prefs.plist

      com.apple.speech.recognition.recognizer.prefs.plist

    to another folder, opened the Activity Monitory, and quit

     

      Speech Recognition Server

      Speech Feedback Server

    and force-quit

       com.apple.speech.synthesis.activityd

    I then went to the Accessibility prefpane and turned off 'Enable access for assistive devices'

    and rebooted.

     

    All to no avail. The speech feedback window opened up again. Oddly enough, the icons on my desktop decided they should move themselves to new locations, though I didn't touch any of the prefpanes for the Finder.

     

    What, oh what do I have to do to get rid of this annoying little floating window (and not have its servers hogging RAM)?

  • Eric Root Level 7 Level 7 (24,925 points)

    Maybe this will help:

     

    https://discussions.apple.com/message/9039934#9039934

     

    https://discussions.apple.com/message/3113371#3113371

     

    If you monitor the "More Like This" box, other solved threads appear. Opening them usually displays other threads.

  • Bill Rising Level 2 Level 2 (240 points)

    I had seen both of these before posting---one had a special speech command that fixed things, the other had hardware problems (kernel panics). Thanks, though.

  • Eric Root Level 7 Level 7 (24,925 points)

    You are welcome. Sorry it didn't help.

  • Bill Rising Level 2 Level 2 (240 points)

    For what it is worth, the window stopped popping up on its own, through some mysterious process.

     

    All I did after my second set of tests was to quit the

      Speech Recognition Server

      Speech Feedback Server

    again, and then forget about the problem.

     

    Today, I've been fighting with the migration assistant (for a change of pace), and I noticed that despite several logout-login cycles, I've not seen the window pop up.

     

    So the problem might be solved, but the solution remains unknown.

  • Bill Rising Level 2 Level 2 (240 points)

    For what it is worth, I noticed today that switching input methods from US keyboard to Spell Catcher (10.4.1) was causing the Speech Feedback window to open. Clicking on Input Menu > Use Speech Commands closed the window. [The Input Menu is the menu which Spell Catcher shows in the menubar; it also appears if there are multiple lanuages/keyboards set up in the Input Sources tab of the Language & Text preference pane.]

     

    This appears to solve the problem I was having.