0 Replies Latest reply: Dec 7, 2012 10:52 AM by Vekz
Vekz Level 1 Level 1 (0 points)

Hi, hoping someone might be able to shed some light on our problem. (=

 

We have a OS X 10.6.8 server (server 1) that is our OD master as well as it housing home folders for students and staff at one of our schools (school 1).

The server OS and apps are on a single 2tb drive. The home folders are on a mirrored RAID made of two 2tb drives.

We have been running quotas on the home folders since the server was rebuilt on new drives about 1.5yrs ago without any issues.

 

We have another OS X 10.6.8 server (server 2) that houses home folders for another school (school 2) that is tied to the OD in the first server.

 

We have always used Workgroup Manager to update home folder quotas. I started noticing about a week ago that increasing quotas in WM were not taking effect on server 1 home folders BUT they were still changing fine on server 2 home folders. It does show the correct limit iun WM I verified this through attempting to copy data while logged into the account, through server admin showing the old quota still and through edquota.

 

Things I have tried.

1. Deleting the .quota.user and .quota.ops.user files on the offending volume of server 1. I then restarted the server and re-enabled quotas in Server Admin. All of the accounts show up and show how much data they are using as well as the total amount of space left on the drive but the limit stays at 0 (unlimited).

Logging into the accounts seems to update the new .quota.user file with the amount used but the limit never updates. I have tried going back into WM and changing it there again but it doesn't change the limit in the .quota.user file it seems. Using edquota still shows a limit of 0 as well. I have tried changing it in edquota as well through terminal but it doesn't stick.

 

2. Turned off services, unmounted volume and ran verify disk in disk utility which came back with errors, so I ran repair disk. It said it couldn't be repaired. I booted up Disk Warrior and ran it (had tons of luck with it repairing disk problems in the past) it said it repaired the problems but checked again with disk utility and still showed errors and again after running Disk Warrior it showed the errors back. Although I wasn't experiencing any other problems besides quota. I remounted the drive turned everything back on and still same problem with quotas.

 

3. I deleted the RAID, reformatted and recreated the RAID, moved all the home folders back and still same results.

 

 

Any thoughts? I am running out of ideas. Thanks!


Xserve, OS X Server, OS X server 10.6.8