10 Replies Latest reply: Jan 27, 2014 6:44 PM by connerfrombloomington
lookermd Level 1 Level 1 (0 points)

I just got my MacBook Air, been using a PC up until now.  Earlier this morning I plugged in my external hard drive and transfered some music onto my MacBook Air.  When I removed my external hard drive I didn't not eject it, now when I plug it in my MacBook does not even see it.  I tried different hard drives and I can see them. I even tried using that hard drive on my old PC and it works. How do I get my MacBook to recognize the hard drive again?  Still new to the whole MacBook experience.


MacBook Air, OS X Mountain Lion (10.8.2)
  • Shootist007 Level 6 Level 6 (16,645 points)

    Have you Re-Booted the Air? If not give that a try first.

     

    Oh and if you didn't know Apple has a 14 day No Questions Asked Return policy for full refund. So If you find the Apple Mac computers are no better then Windows you should return it for full refund and buy a Win PC. I say stick with the Winners. The World Runs on Windows.

  • lookermd Level 1 Level 1 (0 points)

    Tried that it didn't work.

  • Shootist007 Level 6 Level 6 (16,645 points)

    And this same drive still works fine on a PC? If so you have run into the Apple Mac Black hole. Something just don't work on a Mac. Even if at one point they did.

     

    Try connecting the drive then Open Disk Utility and see if the drive shows up there. If it does then for whatever reason the Mac just can't see that it is actually formatted in a way the Mac can read it.

     

    Also if this a USB powered drive you may have to Reset the SMC. Mac's have a real problem with USB powered drives. And they tend to Turn Off the USB port, or ports, if it senses a device drawing to much power.

  • lookermd Level 1 Level 1 (0 points)

    I just got my Mac the other day.  When I first turned it on it used my external HD and copy my music on to my Mac, then I disconnect the HD without ejecting it properly.  Never had a problem with doing that on a PC.  Later I updated all the apps/software on my Mac.  Then I tried to connect the same HD and it was not there.  Tried my PC, it was there.  Used a different HD, same brand and capacity, it was there.  I think this is happening because I failed to eject the HD correctly.  Is there some reset method that I should do or am I at a lost?  I really don't want to go the Apple store if I don't have to.

  • Shootist007 Level 6 Level 6 (16,645 points)

    Well in all honesty even on a PC you are supposed to properly Eject an external before you disconnect it. Even if you think the drive is not being accessed anymore it still may be by the OS. Just unplugging it can corrupt the drive.

     

    Try doing a complete Power down of the Air then a Restart. Power down the drive if it has its own AC power source and then power it back up and connect it. If it still doesn't show up then it is the Air that has the problem.

     

    By the way how is that drive formatted? NTFS or FAT32?

  • lookermd Level 1 Level 1 (0 points)

    It is NTFS and it does not have an external power source.  I did the restart already and no dice on that either.  I also tried the Option+Command+P+F try to reset the something or other.  I read that you are suppose to release those keys once you hear the start chime the second time.  I held them down for a good two minutes and never heard the chime.

     

    Thanks for the advice thus far.

  • Shootist007 Level 6 Level 6 (16,645 points)

    Having the drive formatted NTFS should not have any effect on whether the drive shows up or not. OS X can Read NTFS formatted drives, it just can't write to that format.

     

    Well you do know that Apple Mac's are not immune to problems, just read these forums. So if this is a New MBA you may want to return it for another that works correctly or something else. Apple has a 14 day No Questions Asked Return Policy.

     

    Good Luck.

  • lookermd Level 1 Level 1 (0 points)

    I brought my Air to the Apple store and they could not figure out the problem.  So finally they decided to replace the logic board.  Hope this fixes the issue.

  • revazi Level 1 Level 1 (0 points)

    I don't know what is happening with hard drives but I had a very same issue. I tried restart and everything else the HDD was visible from Disk Utility(without information about owner, and space on the disk) but in finder I couldn't find it. I tried to connect other operating systems with the same HDD and Linux couldn't also see the drive than I connected it to the windows there everything was fine after connecting to windows I reconnected to my macbook air and woalaa it works.

     

    I don't know if this will be helpful for someone but for me it worked.

  • connerfrombloomington Level 1 Level 1 (0 points)

    You didn't eject it and just pulled it out, it can cause the drive to become corrupt,

     

    what you have to do it open disk utility, and under first aid tell it to repair disk.

    Always Eject Hard Drives or you could loose everything!