Previous 1 2 Next 22 Replies Latest reply: Jan 5, 2013 9:07 AM by dmartin336
jimboclark Level 1 (0 points)

I have been looking through threads and have not found a solution to my problem, so here is what I know.


I am running  Mountain Lion 10.8.2 and IPhoto 9.4.2.


When I try to import a photo, the system crashes.


I tried logging in to a new user account and it crashes there too.


Here is the beginning of my crash report.  I am trying to make a Christmas present in IPhoto, and it won't happen if I can't import and export photos...


Process:         iPhoto [3613]

Path:            /Applications/


Version:         9.4.2 (9.4.2)

Build Info:      iPhotoProject-710042000000000~1

Code Type:       X86 (Native)

Parent Process:  launchd [144]

User ID:         501



Date/Time:       2012-12-08 20:33:20.163 +0800

OS Version:      Mac OS X 10.8.2 (12C60)

Report Version:  10



Interval Since Last Report:          5790 sec

Crashes Since Last Report:           2

Per-App Interval Since Last Report:  4152 sec

Per-App Crashes Since Last Report:   2

Anonymous UUID:                      AB94BC75-272F-DD16-7A04-155FA627C26A



Crashed Thread:  19  Import thread 0




Exception Codes: 0x0000000000000002, 0x0000000000000000



Application Specific Information:

*** Terminating app due to uncaught exception 'NSUnknownKeyException', reason: '[<__NSDictionaryM 0x86dcd840> valueForUndefinedKey:]: this class is not key value coding-compliant for the key DLP(R).'



Application Specific Backtrace 1:

0   CoreFoundation                      0x96f5f12b __raiseError + 219

1   libobjc.A.dylib                     0x96d2652e objc_exception_throw + 230

2   CoreFoundation                      0x96f5efc1 -[NSException raise] + 17

3   Foundation                          0x9787dfad -[NSObject(NSKeyValueCoding) valueForUndefinedKey:] + 282

4   Foundation                          0x977b5ed0 _NSGetUsingKeyValueGetter + 40

5   Foundation                          0x977b5583 -[NSObject(NSKeyValueCoding) valueForKey:] + 415

6   Foundation                          0x977d4d7b -[NSDictionary(NSKeyValueCoding) valueForKey:] + 163

7   Geode                               0x01110ea6 +[DGColorSyncProfile addProfile:] + 141

8   Geode                               0x01110e11 DGCMProfileIterator + 40

9   ColorSyncDeprecated.dylib           0x15818b8b profileIterateCallback + 1171

10  ColorSync                           0x92f83664 ColorSyncProfileCacheIterateProfiles + 2353

11  ColorSync                           0x92f7f9d3 ColorSyncIterateInstalledProfiles + 39

12  ColorSyncDeprecated.dylib           0x158186e3 CMIterateColorSyncFolder + 86

13  Geode                               0x01110d20 +[DGColorSyncProfile synchronizeProfiles] + 326

14  Geode                               0x01110b6c +[DGColorSyncProfile newProfileWithName:] + 35

15  RedRock                             0x0272938d -[RKMetadata _digestedExifAttributesFromRawAttributes:] + 7925

16  RedRock                             0x02727450 -[RKMetadata setRawImageAttributes:] + 82

17  RedRock                             0x027c1b86 -[RKMetadata initWithPath:cgImageSource:options:sidecar:] + 1015

18  RedRock                             0x02727237 -[RKMetadata initWithPath:cgImageSource:options:] + 62

19  iPhoto                              0x00709083 iPhoto + 6406275

20  iPhoto                              0x00705ed9 iPhoto + 6393561

21  iPhoto                              0x0020b7fd iPhoto + 1173501

22  iPhoto                              0x0020aead iPhoto + 1171117

23  libsystem_c.dylib                   0x92dec557 _pthread_start + 344

24  libsystem_c.dylib                   0x92dd6cee thread_start + 34


Any help is greatly appreciated.



MacBook Pro, OS X Mountain Lion (10.8.2)
  • léonie Level 10 (90,795 points)

    Are you importing from your camera or from a folder on your disk? Raw images?

    when exactly does it crash? When you start to select photos to import, or do s soon as you use the import command?


    Your crash report say "crashed thread 19" in the lo. It might help, to see the crashed tread part for thread 19 too.




  • jimboclark Level 1 (0 points)

    Thanks for your speedy reply.


    It crashes from camera, and from photos on my disk.  Jpg.  It crashes about 2 seconds after I select the import command.  When I restart, it says that some photos weren't uploaded, and asks if I'd like to import them. If I do, it crashes again. If I don't it puts them in a folder called iPhoto Library Recovered Photos_5 in the pictures directory.


    Here is the thread for 19




    Thread 19 Crashed:: Import thread 0

    0                0x96f5f947 ___TERMINATING_DUE_TO_UNCAUGHT_EXCEPTION___ + 7

    1   libobjc.A.dylib                         0x96d2652e objc_exception_throw + 230

    2                0x96f5efc1 -[NSException raise] + 17

    3                    0x9787dfad -[NSObject(NSKeyValueCoding) valueForUndefinedKey:] + 282

    4                    0x977b5ed0 _NSGetUsingKeyValueGetter + 40

    5                    0x977b5583 -[NSObject(NSKeyValueCoding) valueForKey:] + 415

    6                    0x977d4d7b -[NSDictionary(NSKeyValueCoding) valueForKey:] + 163

    7                         0x01110ea6 +[DGColorSyncProfile addProfile:] + 141

    8                         0x01110e11 DGCMProfileIterator + 40

    9   ColorSyncDeprecated.dylib               0x15818b8b profileIterateCallback + 1171

    10                     0x92f83664 ColorSyncProfileCacheIterateProfiles + 2353

    11                     0x92f7f9d3 ColorSyncIterateInstalledProfiles + 39

    12  ColorSyncDeprecated.dylib               0x158186e3 CMIterateColorSyncFolder + 86

    13                         0x01110d20 +[DGColorSyncProfile synchronizeProfiles] + 326

    14                         0x01110b6c +[DGColorSyncProfile newProfileWithName:] + 35

    15                       0x0272938d -[RKMetadata _digestedExifAttributesFromRawAttributes:] + 7925

    16                       0x02727450 -[RKMetadata setRawImageAttributes:] + 82

    17                       0x027c1b86 -[RKMetadata initWithPath:cgImageSource:options:sidecar:] + 1015

    18                       0x02727237 -[RKMetadata initWithPath:cgImageSource:options:] + 62

    19                        0x00709083 0xed000 + 6406275

    20                        0x00705ed9 0xed000 + 6393561

    21                        0x0020b7fd 0xed000 + 1173501

    22                        0x0020aead 0xed000 + 1171117

    23  libsystem_c.dylib                       0x92dec557 _pthread_start + 344

    24  libsystem_c.dylib                       0x92dd6cee thread_start + 34


    I can past the whole report in, but find them to be obnoxiously long for those of us who don't know what we are looking for.



  • Ray_NSE Level 1 (0 points)

    Having exactly the same issue here.


    Have tried all the fixes quoted such as fixing permissions, launching iPhoto with Option&Control and attempting to fix things in order.. downloading iPhoto Library Manager and rebuilding, reinstalling iPhoto etc.


    Nothing works.

  • gerard marchais Level 1 (10 points)

    Hello fm france

    same for me since yesterday

    iphoto crashed just when he finish to "read" the photo from my appar photo connected via usb port and just before to show them on the screeen.

    I get this : ( but do not understand !!!)


    when I import from a folder on desktop, no problem.

    I have repair permission, verify disk , restart... etc etc ..

    always the problem


    thank's for help




    Process:         iPhoto [1543]

    Path:            /Applications/


    Version:         9.4.2 (9.4.2)

    Build Info:      iPhotoProject-710042000000000~1

    Code Type:       X86 (Native)

    Parent Process:  launchd [380]

    User ID:         501


    Date/Time:       2012-12-08 15:06:41.691 +0100

    OS Version:      Mac OS X 10.8.2 (12C60)

    Report Version:  10


    Interval Since Last Report:          4158767 sec

    Crashes Since Last Report:           2277

    Per-App Interval Since Last Report:  27612 sec

    Per-App Crashes Since Last Report:   10

    Anonymous UUID:                      9A0AABF8-A476-6A3C-A0B5-1BFC5FE8E1F5


    Crashed Thread:  0  Dispatch queue:


    Exception Type:  EXC_BAD_ACCESS (SIGBUS)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x000000008a263a84


    VM Regions Near 0x8a263a84:

        MALLOC_TINY            0000000085000000-000000008a200000 [ 82.0M] rw-/rwx SM=PRV 

    --> MALLOC_TINY            000000008a200000-000000008a300000 [ 1024K] rw-/rwx SM=COW 

        MALLOC_TINY            000000008a300000-000000008a400000 [ 1024K] rw-/rwx SM=PRV 


    Thread 0 Crashed:: Dispatch queue:

    0   ???                                     0x8a263a84 0 + 2317761156

    1          0x7000afac AUHAL::AUHAL(ComponentInstanceRecord*, unsigned long, bool) + 990

    2          0x700301bc APFactory<AUOutputLookup, DefaultOutputAU>::Construct(void*, ComponentInstanceRecord*) + 56

    3          0x7003139b ComponentBase::AP_Open(void*, ComponentInstanceRecord*) + 93

    4          0x97844bcb APComponent::NewInstance(ComponentInstanceRecord*&) + 183

    5          0x97844992 _AT_AudioComponentInstanceNew + 100

    6                   0x1b4d5230 CoreAudioPlaybackDevice::OpenCoreAudioGraph(long, long, unsigned char) + 128

    7                   0x1b4d3cec CoreAudioPlaybackDevice::OpenCoreAudio(long, long, unsigned char) + 60

    8                   0x1b4d3b3c CoreAudioPlaybackDevice::CoreAudioPlaybackDevice(GenericProfile*, GenericProfile*, int, int) + 1116

    9                   0x1b4e2275 MultiTypeCoreAudioPlaybackDevice::MultiTypeCoreAudioPlaybackDevice(GenericProfi le*, GenericProfile*, int, int) + 53

    10                   0x1b963fff Board::InitializeAudio(bool, bool) + 351

    11                   0x1b96e6d6 Cin_OpenUnits(Board*&, int, bool, bool, bool, VDR*&) + 262

    12                   0x1b4e637d VDR_OpenUnits(VDRHandleClass*, int, bool, bool, bool, VDR*&) + 77

    13                   0x1b75e28d CDVDManager::Initialize() + 301

    14                   0x1b4a5831 DVDInitialize + 49

    15                   0x1b49cf20 AVCHDInitialize + 16

    16                   0x1b451dd8 -[AVCHD initialize] + 36

    17                   0x037d214d 0x37b2000 + 131405

    18                   0x037cddc9 0x37b2000 + 114121

    19                       0x026fffe6 -[RADConverter initWithWindow:delegate:] + 301

    20                       0x026fe293 -[AVCHDConverter initWithWindow:] + 365

    21                       0x026fe2cb __33-[AVCHDConverter initWithWindow:]_block_invoke_0 + 43

    22  libdispatch.dylib                       0x91999cb1 _dispatch_barrier_sync_f_slow_invoke + 80

    23  libdispatch.dylib                       0x91993c82 _dispatch_client_callout + 46

    24  libdispatch.dylib                       0x919992e3 _dispatch_main_queue_callback_4CF + 223

    25                0x917e11d5 __CFRunLoopRun + 1845

    26                0x917e063a CFRunLoopRunSpecific + 378

    27                0x917e04ab CFRunLoopRunInMode + 123

    28                     0x95c3415a RunCurrentEventLoopInMode + 242

    29                     0x95c33ec9 ReceiveNextEventCommon + 374

    30                     0x95c33d44 BlockUntilNextEventMatchingListInMode + 88

    31                        0x94e60a3a _DPSNextEvent + 724

    32                        0x94e6026c -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 119

    33                        0x94e566cc -[NSApplication run] + 855

    34                        0x94df96f6 NSApplicationMain + 1053

    35                        0x00092c99 0x83000 + 64665

    36                        0x000922e5 0x83000 + 6

  • gerard marchais Level 1 (10 points)

    thank's for your help

    greetings from france

  • léonie Level 10 (90,795 points)


    your crash is completely different. As far as I can see, iPhoto crashes, when it is accessing AVCHD videos. Have you videos on your card? You better start a separate thred, so the video experts can see it.



  • léonie Level 10 (90,795 points)

    Jim, can you import any photos at all? What happens, if you import older image files again, that you previously imported successfully? I am just trying to figure out, if there is something wrong with your new image files, or if iPhoto is corrupted.


    The error message in the crash log:

    Application Specific Information:

    *** Terminating app due to uncaught exception 'NSUnknownKeyException', reason: '[<__NSDictionaryM 0x86dcd840> valueForUndefinedKey:]: this class is not key value coding-compliant for the key DLP(R).'

    is raised, after iPhoto tries to access properties of an image file (to assign a color sync profile) and it crashes, because it cannot find the necessary data in its dictionaries. Either the jpegs have a problem or iPhoto. The framework, that is crashing is part of the iPhoto application. If you cannot even open older photos, I'd reinstall iPhoto.


    When did the crashes start? DId you install something else lately? Any plug-ins, helper applications? Did you run any cleaner applications, that empty caches or something?


    I have looked through the older discussions, and all threads that I found with exactly the same type of crash report have not been marked as solved.

  • gerard marchais Level 1 (10 points)

    thank's for your quick answer. On the card of the photo app there is no mov, only .jpeg file.

    and when I import them " by hand" on the desktop and after in iphoto, no problem,


    The crash is when the app photo is connected ( I use this Sony since two years without problem

    to import, it was a plesure, now it is a problem !!! )

    thank's for help or idea

    excuse my english

  • jimboclark Level 1 (0 points)

    to the best of knowlege, this started when I upgraded to Mountain Lion.  I have tried images from three different sources, including older images that were able to upload before, and none of them are successful.


    I had the probalem with iPhoto 9.4.1 and was hoping that 9.4.2 would heal it.


    A little depressing that no one has solved this issue in the forums in the past.


    Am I correct in assuming the next step is to try to find my install discs and reinstall iphoto?


    Thanks for your help on this. Like many people in the threads I've read here, after 7 years of being in the OSX universe, this is the first time I feel like I'm hitting a dead end. Having your guidance is helpful.



  • léonie Level 10 (90,795 points)

    When I try to import a photo, the system crashes.


    I tried logging in to a new user account and it crashes there too.


    When you are testing from a different user account, did you test with a new iPhoto Library or with your current iPhoto Library? If you can import successfully into a new iPhoto Library, I'd try to repair/rebuild your current iPhoto Library first:


    • Back up your iPhoto library,
    • Depress both the keys option/alt⌥ and command⌘ firmly at the same time and hold them down, while you  launch iPhoto by double clicking. Select "Rebuild database" from the panel to rebuild your iPhoto library


    But if you cannot even import into a new library, and since iPhoto also crashes for a new user account. go ahead and reinstall iPhoto.

    Re: iPhoto '11 crashes on startup

  • jimboclark Level 1 (0 points)

    I tried with a new iphoto library and no dice.


    Now my problem is I can't find the disk with iLife on it.  We moved house recently and I found my OSX install disc, but no iLife... IS the disc necessary to reinstall?

  • léonie Level 10 (90,795 points)

    Yes, you need your disks.

    Have you looked at your Mac OS install disks? On some later versions was a second CD with bundled iLife applications. If there are, then use those to reinstall the bundled applications only - select custom install and check only the apps you need to reinstall.

  • Ray_NSE Level 1 (0 points)

    I tried a reinstall - same issue afterwards.  I hope it works for you!

  • léonie Level 10 (90,795 points)

    Ray, do you have exactly the same system version, iPhoto version, and error message in the crash log as Jim? If yes, how did you install iPhoto? Is it the recent AppStore version, or an update from the iLife instlla CDs?

    Did you install anything else, after you installed Mt. Lion and upgraded iPhoto, that might have added incompatible frameworks? Little helpers, like utilities to open the coorect application, after connecting a camera or something, plug-ins, device drivers?




Previous 1 2 Next