14 Replies Latest reply: Dec 10, 2012 7:07 PM by RT11 guru
Anthony Pucca Level 1 Level 1 (15 points)

I've noticed lately (via Activity Monitor) that my Virtual Memory is constantly getting sucked up by "mds" and "md worker" constantly running, nonstop. I checked the inspector to find the culprit file and it seems to be "AddressBook-v22.abcddb."

 

Why is Spotlight hanging on scanning my address book and how do I stop this operation to get my virtual memory back?? I understand the file in question above is one that shouldn't be messed with... so deleting it doesn't seem to be an option.


Mac Pro, Mac OS X (10.6.8), Quad Core, Intel Xeon
  • ds store Level 7 Level 7 (30,315 points)

    It apparently is corrupted somehow, you will need to manually copy and paste the information in it out of it.

     

    After making sure there is no other issues with your machine. (1-12)

     

    Step by Step to fix your Mac

     

     

    You can test if the above steps worked by using OnyX and it's Rebuild Spotlight option, after rebooting using OnyX, Spotlight will start all over again to rebuild and if the above steps worked to fix it then you won't have to continue further here.

     

     

    If not and having adequate backups of your machine and data off the computer

     

    Most commonly used backup methods

     

     

    your going to need to recreate your user account to make a new addressbook.database.

     

    I don't use AddresBook ever since Apple a long time ago decided to allow it to connect to the Internet, which I consider a serious privacy and personal security breach, but Apple puts ease of use ahead of that, then people wonder why they lost a contract because the competition hired a hacker.

     

    But enough of that, once your user files (alone) are also backed up on a external storage drive (in addititon to other backups), you create another Admin account and log into it, delete the original one, reboot and recreate it and log back in, then import your data from the storage drive and reset User Permissions (see Step by Step)

     

    This will rebuild the Addrebook dabase file in your user account name again and you import the data manually to eliminate the corruption, making sure there is no odd characters etc. that might be also causing your issues.

  • Anthony Pucca Level 1 Level 1 (15 points)

    I have Onyx. Will try that.

     

    If that doesn't do it then... ugh...I'm hoping recreating the User Acct isn't the route I have to take. Cutting and pasting 900+ contacts is out of the question as well.

     

    I was thinking of installing Lion sometime soon. Will that rebuild the Addressbook file?

     

    I wonder what can corrupt the Addressbook file-- I rarely use it. I do have an iPad and iPhone that are both putting Contacts in iCloud- maybe when I sync those to a snow leopard (non iCloud) environment there's some corruption involved...

  • Anthony Pucca Level 1 Level 1 (15 points)

    p.s. Would any of the components of Tech Tool Pro repair the corrupted file?

  • Anthony Pucca Level 1 Level 1 (15 points)

    Also- would just quitting the process in Activity Monitor do the trick?

  • Anthony Pucca Level 1 Level 1 (15 points)

    Sorry to add on again but as a test I eliminated the address book library from being run by Spotlight (Privacy setting).  Now md worker is scanning the .ds store files on my desktop and in Spotlight itself. So maybe the problem isn't just the Addressbook db. Md worker is still sucking up more than 1 GB virtual memory.  Any further advice appreciated.

  • RT11 guru Level 2 Level 2 (175 points)

    Generally, for me at least, Spotlight is invisible but I have had similar problems where it is constantly running. What has worked for me is to completely rebuild the Spotlight database for the volume. It can take a long time but if you let it run overnight it is not as intrusive. You might be able to do this with one of the utilities mentioned (I used SL Cache Cleaner) but you can also do this by adding your volume (hard drive) to the Spotlight Privacy panel and then removing it. You may have to quit and then relaunch System Preferences in between (the add and remove steps) but the mdworker process should fire up.

    Quitting the Spotlight processes generally won't work; they will be automatically relaunced after a time.

  • Anthony Pucca Level 1 Level 1 (15 points)

    I did rebuild Spotlight using OnyX and let it index again. No luck..."md worker" started to index itself (Spotlight) and then the ".ds_store" file. Then just recently it went back to the Address book file mentioned above.

     

    I don't think so much that this is a corruption of the Addressbook file as much as some type of bug or runaway process that will only stop if I exclude my whole system from Spotlight.

     

    As I write this, it's still clocking away at 1.23 GB of virtual memory... like Terminator... it can't be stopped....

  • RT11 guru Level 2 Level 2 (175 points)

    Good analogy. Any chance you have some rogue Spotlight plugins (in /Library/Spotlight/, both in the root directory and your home user directory)? They have been known to cause problems.

  • Anthony Pucca Level 1 Level 1 (15 points)

    Nothing in the User /Library/Spotlight directory (not even a Spotlight folder.)

     

    However, in the root Library/Spotlight directory, I have:

     

    Appleworks.mdimporter

    iWeb.mdimporter

    iWork.mdimporter

    Microsoft Entourage.mdimporter

    Microsoft Office.mdimporter

     

    The only applications of the above that I ever use are iWeb and Microsoft Office.

  • RT11 guru Level 2 Level 2 (175 points)

    These are standard. I have all of them except iWeb (which I don't have installed). I don't think the Spotlight directory in your user folder gets created unless you installed something that uses a custom plugin.

    Okay, just to be sure, you have let the mdworker work away for a sufficiently long time (which can be hours)? Also, are you getting errors about these files in the Console? I looked just now and I also have a couple of recent "Error, could not create MachMessagePort for com.apple.AddressBook.abd" messages but Spotlight seems fine. Finally, Onyx probably can clear out all of the .DS_Store files. You will only lose window positions and sizes. As for the address book, you seem to have eliminated it, but you could try exporting your contacts (File->Export->Address Book Archive), deleting the contacts in Address Book, and then reimporting (File->Import). I am not sure that would clear out any corrupted entries. There are more aggressive means of rebuilding your address book, as pointed out by the other poster. You can also look here for some related information (although this note pertains to syncing): http://support.apple.com/kb/TS2481?viewlocale=en_US&locale=en_US. And one last stab, do you have anything in ~/library/caches/com.apple.addressbook/MetaData/)? You could delete that (metadata) and it should get rebuilt.

  • Anthony Pucca Level 1 Level 1 (15 points)

    Since I excluded my entire hard drive from Spotlight (in Privacy) "mds" has "calmed down" a bit -- only using about 800MB of virtual memory (vs. 1.23GB as before) and 0% CPU. "md worker" is no longer seen in Activity Monitor so that's maybe as good as it will get, I guess. Although, not having Spotlight at all for my startup directory isn't a great option.

     

    Even "idle" I wonder if mds should be using that much vm.

     

    No error messages in Console, and no metadata in the Addressbook cache folder.

     

    I take it if I add my drive back to Spotlight and let it index again, I'll be back to the same problem...maybe the .ds store cleaning with OnyX will help. (Kind of nervous about using OnyX again because when I did yesterday, I cleaned out some log files and my Mac wouldn't reboot from the startup drive after that. Problem solved, but not a scare I needed at the time!)

  • RT11 guru Level 2 Level 2 (175 points)

    Deleting log files shouldn't cause a Mac to not boot. I wonder if there isn't some other issues here. I am sure you have rebooted a bunch of times but have you tried a safeboot: http://support.apple.com/kb/HT1455. Easy to do. This will do some directory checking and toss a few caches and disable startup and login items and only loads necessary kernel extesnsions. Spotlight should still be enabled (for Snow Leopard) and you can see what the processes are doing. For me (not in Safe Boot), the mds and mdsworker processes are using less than 100 MB of real memory but over 2.2 GB of virtual memory (but virtually no CPU cycles).

    I can't vouch for Onyx but don't worry about the "DS_Store" files.

    Leaving Spotlight disabled is not ideal. It is a great feature of OS X (just try doing a search on Windows to see how good Spotlight can be).

  • Anthony Pucca Level 1 Level 1 (15 points)

    Yep-- the safe boot is what got me up and running again... and then a regular boot after that. Maybe I'm mistaken about having deleted log files. I may have done a cache file cleaning as well. (Boot cache?)

     

    If mds and mdworker are using over 2.2 GB of vm for you, then I don't feel so bad about my own issue at 1.23 GB. I'm down to about 750 MB of vm now so I guess that's not that bad.

     

    Thanks a bunch... I'll keep experimenting...

  • RT11 guru Level 2 Level 2 (175 points)

    In my case, I don't reboot very often so I am sure the virtual memory usage creeps up.

    Spotlight is a great help (when it is working properly).

    Happy computing.