11 Replies Latest reply: Dec 20, 2012 1:36 PM by Kappy
OGELTHORPE Level 7 Level 7 (25,790 points)

I attempted to copy the Lion OS from a HDD to a 32 Gb USB thumb drive.  Both drives are properly formatted.  It failed with the error message 'Restore Failure  Not enough space on / dev / disk 3s2  to restore'.  The attempt was made using the Disk Utility in the restore partition.

 

There is 24.18 Gb of data on the HDD.

 

The USB drive has 31.56 Gb of available space.

 

This suggests that there is enough space available but the error message indicates otherwise.

 

Can any one provide a definitive answer to this puzzle?

 

Thanks.

 

Ciao.


MacBook Pro, Mac OS X (10.6.8), 2006 17" 2.16GZ 2GB RAM 500GB HDD
  • 1. Re: Cannot Restore Lion on USB
    Kappy Level 10 Level 10 (226,805 points)

    Exactly how did you do this - via manual copy or Disk Utility or Carbon Copy Cloner.

     

    One possible reason for the error is a difference in block sizes during the transfer from one medium to a different type of medium. In other words files take up more space on the flash drive or the flash drive's partition scheme is MBR instead of GUID and the format scheme also different than HFS+.

  • 2. Re: Cannot Restore Lion on USB
    OGELTHORPE Level 7 Level 7 (25,790 points)

    Kappy, greetings:

     

    As suggested above I booted on the restore partition of an external HDD which has Lion on it and the USB drive obviously was inserted in the MBP.  The MBP was just the transfer medium.  (It was not the one shown in my post.)

     

    It appears that the USB drive is the same partition map scheme as the HDD.  See the attached DU display.:Screen shot 2012-12-08 at 4.44.49 PM.png

    What I did not mention in the post that the transfer was successful to an old 160 Gb Toshiba.

     

    Your further thoughts are most welcome.

     

    Ciao.

  • 3. Re: Cannot Restore Lion on USB
    Kappy Level 10 Level 10 (226,805 points)

    How much space did it take up on the Toshiba drive?

     

    Have you tried the transfer using CCC instead of DU? It isn't the first time I've seen a problem like this having run into similar ones with 8 or 16 GB flash drives claiming not enough space for what should have fit without a problem.

     

    You can also give a try transferring from the Toshiba to the flash drive instead.

  • 4. Re: Cannot Restore Lion on USB
    OGELTHORPE Level 7 Level 7 (25,790 points)

    Kappy, greetings:

     

    All drives, thumb and HDDs are Mac OS extended (Journaled).

     

    Using the Toshiba as a source produces the same result as before with the same error message.

     

    I tried a 'new' 32 Gb Thumb with the same result on the late 2011 MBP. 

     

    Both the original source HDD and the Toshiba can be booted on the 2010 and late 2011 MBPs and will allow for entry into the recovery partition. 

     

    I employed CCC per your suggestion and it transferred only 8.79 Gb of data.  I did this on both MBPs.  See the CCC verifications below:

    (The only difference was that it took 8 minutes less on the newer MBP.  Probably a reflection of the CPU differences)

     

    Screen shot 2012-12-09 at 8.40.48 AM.png

    Screen Shot 2012-12-09 at 10.13.47 AM.png

     

    It is my understanding that CCC should copy everything, including the OS.  This raises a new question: Why not?  Is this unique to this situation?

     

    I employed OmniDiskSweeper to find the precise differences and ther results are posted below:

     

    The original source HDD:

    Screen Shot 2012-12-09 at 10.28.14 AM.png

    The Toshiba HDD:

    Screen Shot 2012-12-09 at 10.39.03 AM.png

    The 32 Gb thumb drive:

     

    Screen Shot 2012-12-09 at 10.31.02 AM.png

    Note that the 32 Gb thumb drive ommited the PRIVATE files.  That I assume is where the OS resides.

     

    Any additional thoughts or suggestions you may have would be most welcome.  Your time and effort is much appreciated.  At this point the only path that I can think of in pursuing this question is to contact SanDisk and see if they can enlighten me (Those are the thumb drives I am using).

     

    Ciao.

  • 5. Re: Cannot Restore Lion on USB
    Kappy Level 10 Level 10 (226,805 points)

    Well, that is a puzzle. It suggests that the source itself may be corrupt in some way. Both DU and CCC will copy everything on the source to the destination with the exception of those temporary files such as caches that are not needed for a bootable clone. I do see some shrinkage but nothing as substantial as going from 25 GBs to 9.

     

    Have you done this only with SanDisk flash drives? If so then you might try a different manufacturer such as PNY or Lexar. I've never had good luck with SanDisk flash drives despite their popularity.

     

    I like PNY flash drives, but recently bought five of them to use. They were current versions of the older model of which I have quite a few. Well, not a single one would work on my iMacs of which we have four - two in Vancouver and two here in Tampa. However, they work fine in my notebooks and Mac Pro. Seems like they won't insert far enough or something, but they simply won't mount or appear on the Desktop. But in the other computers they work just fine. Right now my favorites are the Lexars.

  • 6. Re: Cannot Restore Lion on USB
    OGELTHORPE Level 7 Level 7 (25,790 points)

    Kappy greetings:  I expect to be back on this adventure tomorrow or Friday.

     

    I recently bought a 17" late 2011 refurbished MBP and am in the process of moving into it.  It took me several phone calls and emails to get the 'free' Mt Lion upgrade (to go into all of the details, it would be equivalent to a Russian novel) and I downloaded it and due to my slow wireless Internet connection, it took eight hours.  As I write this I am transferring data from my 2010 MBP (about 730 GB).  After this comes the new Time Machine Disk load.

     

    I did some additional experimentation a couple of days ago but I want to repeat it.  I foolishly did not document some error messages which may be germane.

     

    I very much appreciate you interest and your far more extensive knowledge base may well prove to be very useful.  In that respect I am a tyro compared to you and need and want all the assistance and direction I can get.

     

    Best regards.

     

    Ciao.

  • 7. Re: Cannot Restore Lion on USB
    OGELTHORPE Level 7 Level 7 (25,790 points)

    I am back and I apologize for failing to meet my self imposed deadline.  I had to get the redemption codes for the iLife applications that were supposed to be on my 'new' MBP, but weren't.  That and other things interfered in trying to bring this misadventure to a close.

     

    From the Sandisk website I followed this procedure:

     

    I clicked on the HDD icon, the I did a COMMAND C.

     

    I clicked on the USB icon and then a COMMAND V.

     

    It then generated and administrative message:

    Screen Shot 2012-12-19 at 5.00.37 PM.png

    This the initiated the HDD to download onto the desktop a file folder of it's contents.

    Screen Shot 2012-12-19 at 5.05.32 PM.png

     

     

    After this was completed I dragged the folder to the USB thumb drive.  I got an administrative password request:

    Screen Shot 2012-12-19 at 5.28.53 PM.png

    It took about two hours for this part of the process to complete:

    Screen Shot 2012-12-19 at 5.57.31 PM.png

    As you know, these estimates are often wrong, but not in this case.

     

    I checked both drives to see if they both contained the same data.  The only difference was that the HDD had the four files in a folder, whereas the USB thumb drive had the four files displayed individually.  The size of the respective files were the same.

     

    Again I tested the HDD and the USB thumb drive to see if they would function as a Lion restore HDD.

     

    The source HDD displays the volume and the restore icon when I boot holding the OPTION KEY (The MBP icons also appear, total of 4 icons).

     

    The USB does not.  When I boot the MBP holding the OPTION key, only the Icons for the MBP appear. 

     

    I have two 32 Gb Sandisk USB thumb drives and have done this with both of them. 

     

    I find it difficult to believe that there is some thing peculiar with Sanddisk USB drives, but I suppose that cannot be dismissed.  One thing I found to most curious is when I would trash these files it would take an inordinate amount of time to empty Trash.  A good hour plus!  I normally would expect Trash to be deleted in a minute or two for files of this size.

     

    Unless you can come up with some stimulating recommendations to pursue this further, I am now tired beating my head against this wall and at least temporarily, if not for ever, closing this project. 

     

    I do thank you for your thoughts on this matter and I wish you the best of holiday seasons.

     

    Ciao.

  • 8. Re: Cannot Restore Lion on USB
    baltwo Level 9 Level 9 (60,125 points)

    If you're trying to make the USB thumb drive a bootable installer disk, then all you need to do is mount the InstallESD.dmg inside the Install Mac OS X Lion.app and use Disk Utility to restore it to the thumb drive. Details in http://www.macworld.com/article/1161069/make_a_bootable_lion_installer.html

  • 9. Re: Cannot Restore Lion on USB
    OGELTHORPE Level 7 Level 7 (25,790 points)

    baltwo, greetings;  Thank you for your input on this item.  In fact I have already done what you suggest, both for Lion and Mt. Lion. 

     

    The question I was trying to resolve is why I initially could not transfer the Lion OS onto the Sandisk USB drive, which appears I now can, but it does not function as an installation drive.  The source drive, the HDD, does perform as an installation drive.

     

    This has now become moot since I have raised the white flag, for now.

     

    Please have a good holiday season.

  • 10. Re: Cannot Restore Lion on USB
    baltwo Level 9 Level 9 (60,125 points)

    AFAIK, if you use DU to restore the image to the thumb drive, it should be bootable and usable as an installer drive. I do know that the three on my int HD as separate volumes work that way.

     

    Happy holidays!

  • 11. Re: Cannot Restore Lion on USB
    Kappy Level 10 Level 10 (226,805 points)

    All I can think of is that trying to install the OS (not the installer) required slightly more space than the < 8 GBs on the flash drive. But it should install on a larger flash drive. However, an 8 GB flash drive should work fine to make a system installer for Mountain Lion. Beyond that I'd say there's a problem with SanDisk's flash drives.