0 Replies Latest reply: Dec 9, 2012 6:36 AM by doneesap
doneesap Level 1 Level 1 (0 points)

My ipod touch 3rd gen has an "activation required" error and the slider won`t work, what should I do?


iPod touch