9 Replies Latest reply: Dec 10, 2012 12:36 PM by Neville Hillyer
bendts Level 1 Level 1 (0 points)

So i seem to be having the same issue of the Self Assigned IP problem like many others here.

 

System - MAC G5 Quad 2.5, 10 gigs of ram - 10.5.8

 

I did remove 2 sticks of ram that were failing the diagnostics on boot up, while it seemed to help the system run better, nothing for the networking.

Everything else is working great - fans are normal, boots fine, no error lights, al the dust is out

 

I do not have a Airport Card - only connecting via ethernet to a ZOOM wireless router set-up in Ethernet Client Mode so that i can connect to the wireless service.

 

The wireless internet that i connect to is working fine - my thinkpad conncts just fine -it how i am loged on here now.

 

The ZOOM Router is connecting fine ot he wirless network too - 90-100% signal.

 

I have followed as many of the remides that are listed here - with about 5% success.

 

Deleting the Firewall Plist

Changed the Firewall PLIST to the one i found here that was modified - nada

Deleting the com.apple.network.ID.Plist / NetworkInterfaces.Plist / preferences.Plist ( I have looked at these Plists and see that they show the Correct IP to get out to the internet as provided by the wireless service 10.100.xxx.xx - but the G5 still shows the Self Assigned one in Sys Prefs/Network).

PRAM reset

New PRAm Battery

Loaded 10.5 Server to see if they put a better set of network "Stuff" in that - Nope

Re-Installed a fresh 10.5 to no avail

Updated to 10.5.8 - still nothing.

 

It seems to be stuck in the Self Assigned IP "loop" if thats possable.

 

Its not the Nic's as i can plug the cat5 into the LAN port of the router and i get a good 192.168.x.x ip & 255.255.255.0 subnet right away

 

When i plug it back into the WAN Port to use the Client Mode - it goes back to Self Assigned 169.x.x.x with a 255.255.0.0 subnet

 

When it has worked right - it last for about 4 to 5 hours and then gets kicked to self assigned ip.

 

This is driving me nuts - Any info would be helpfull - Thanks.

 

Geting ready to load Fedora 17 on next to see if they have there act together better than Apple does.

 

I did see a command to bring down the Ethernet ports and then bring them up again - but i cant find it now - if anyone has that command to use in terminal i will give that a try next.

  • 1. Re: Ethernet in Self assigned IP mode - Quad G5
    BDAqua Level 10 Level 10 (116,475 points)

    Hi, I don't understand plugging it into the WAN port, that would make the G5 have to be the source of Internet... but from where? What Interface?

  • 2. Re: Ethernet in Self assigned IP mode - Quad G5
    bendts Level 1 Level 1 (0 points)

    When the router is put into Client Mode - the Computer ethernet port connects to the Routers WAN port - the router acts as a "Wireless Card/Airport Card" and connects the computer to the wireless service.

     

    Best as i can explain it.

  • 3. Re: Ethernet in Self assigned IP mode - Quad G5
    BDAqua Level 10 Level 10 (116,475 points)

    Normaly the Router's Wan Port would be connected to a Modem, devices wishing to use that Modem for Internet would connect to the LAN ports.

  • 4. Re: Ethernet in Self assigned IP mode - Quad G5
    Neville Hillyer Level 4 Level 4 (1,855 points)

    This appears unnecessarily complex. You do not say if you have cable or ADSL. I assume that by self assigned you are referring to DHCP.

     

    I use a Netgear DG834PN modem/wireless router which I bought secondhand for £20. I also use DGTeam firmware with many extra options but that is another story. I never use the free modems supplied by ISPs as they normally have limited functionality.

     

    The DG834PN has:

    an ADSL modem - I get about 14 Mbps downline and 700kbps upline

    a powerful (longer distance for larger buildings) 108 MHz wireless

    a 4 port 10/100 M bits per second wired router

    an excellent firewall

    a web interface which is relatively easy to setup

     

    I normally have a public G3 web server, two G4+ towers and a 16/600 PS printer wired to the router. From time to time various Mac laptops connect wirelessly.

     

    I add another router when I use Ubuntu on my Celsius R630.

     

    It took me a while to realise that (in my opinion) it is slightly more secure to use default DHCP settings for most connections. I reserve IPs for the server and printer only.

     

    I never use the OS X firewall.

     

    There is another thread where the OP has unresolved wired Ethernet problems with his duel boot OS X / Linux Mac. I prefer to use separate (much cheaper) hardware for Linux.

  • 5. Re: Ethernet in Self assigned IP mode - Quad G5
    BobHarris Level 6 Level 6 (13,120 points)

    So it sounds like you are using the Zoom as and external WiFi card, and you have another WiFi base station acting as your router.  Is this correct?

     

    You are getting a Self Assigned IP address because the router handing DHCP services and your Mac have not negioated a valid address.

     

    Try using a LAN port on the Zoom.  Plug your ThinkPad ethernet port into the Zoom and turn off the ThinkPad's WiFi.  Does that work?  All assuming the Zoom is not your home router.

     

    If you use the Web interface on the Zoom, does it have a valid IP address from your router?

     

    Have you diabled your Zoom's routing functions?  It is not good to have 2 functioning routers in your home.  Any additional WiFi base stations should be put into bridge mode, which is generally done by disabling the 2nd WiFi base station's DHCP server and if it is an option the NAT server.

     

    If I'm guessing wrong, then please correct me.

     

    Also if it is a matter of getting ethernet from your real router to your G5, you could look into PowerLine Ethernet adaptors, and avoid the headaches of WiFi bridging.

  • 6. Re: Ethernet in Self assigned IP mode - Quad G5
    Neville Hillyer Level 4 Level 4 (1,855 points)

    It is not good to have 2 functioning routers in your home.

    Why?

  • 7. Re: Ethernet in Self assigned IP mode - Quad G5
    BobHarris Level 6 Level 6 (13,120 points)

    It is not good to have 2 functioning routers in your home.

    Why?

    Several problems can occur.

     

    If done wrong, you can have multiple DHCP servers on the same subnet.  That would be bad as you could then start to get duplicate IP address assignements.

     

    If you have cascaded the units, you can have multiple layers of NAT to get through.  Sometimes causes problems for Back-to-My-Mac (or similar services).

     

    When you have multiple NAT layers, you have 2 subnets, and Bonjour will not cross between the 2 subnets, so auto-discovery will not occur between the 2 subnets.  Very confusing to users that want to do file sharing/screen sharing/printer sharing, but cannot see the other systems in their home.

     

    And in this situation, if bendts is using the Zoom as an external WiFi card, then if routing is enabled, AND the G5 is connected to the WAN port then it would be on the other side of a subnet boundary, and would not see the home's router DHCP server.

     

    Or if the Zoom routing is still enabled, and the G5 is connected to a LAN port, then which DHCP server will the G5 gets its IP address from?  The home router, or the Zoom?

  • 8. Re: Ethernet in Self assigned IP mode - Quad G5
    bendts Level 1 Level 1 (0 points)

    "So it sounds like you are using the Zoom as and external WiFi card, and you have another WiFi base station acting as your router.  Is this correct?"

     

    Yes - its set up the same way you can set up Apple's Airport Express/Extreem's.

     

    And i have no way to run ethernet or powerline ehternet - in a RV

     

    When set up in Client Mode (Ethernet Bridge) the WAN port is where you connect your ethernet cable from your computer (just like on a Airport Express) - the whole thing then connects to and passes the correct (hopfully) info between you comp and the WiFi/Internet device

     

    The LAN Ports are only useed to acsess the web interface to set up the router into Client/Bridge mode - you then need to re-connect to the WAN Port to make it work as a Client/Bridge to the WiFi.

     

    This is what gamers have to do for there x-boxes etc that have only a ethernet port.

     

    When set into Client/Bridge Mode - the LAN ports can not be used and the "Wireless' only connects to the WIFI service you selected in set up.

     

    I got the Zoom router as i can connect my external antenna to it - can not with the apple's.

     

    I am traveling in an RV - so i need to have an External Antenna to get any type of signal at most RV Parks.  This Park happens to have a very excelent sinal/WiFi set up.

     

    Now - Last nigt after i wrote the OP - I did do another reset and reset-up of the router itself. 10th time i think.  And it worked - connected as it should and gave a good IP even after rebooting the computer.

     

    Go Figure.

     

    So i turned off Sleep in sys pref's and left it on/connected all night - and its still going today.  Maybe  the issue is in the sleep software interaction - no idea, theats beyond my pay grade.  Seems to me if i remeber correctly, the sleep in osx 10.5.x had some issues.

     

    Will up date this if it happens again - or if you have any other info i would be glad to here it.

     

    Thanks

  • 9. Re: Ethernet in Self assigned IP mode - Quad G5
    Neville Hillyer Level 4 Level 4 (1,855 points)

    BobHarris wrote:

     

    Several problems can occur.

     

     

    Sorry Bob - brain malfunction. I read and wrote router but was thinking switch/hub. The same malfunction also affected my earlier remark about my R630.