Previous 1 2 Next 26 Replies Latest reply: Dec 13, 2012 10:10 PM by Ausdaz Go to original post
  • Michael Wasley Level 5 Level 5 (6,810 points)

    Ausdaz wrote:

     

    Habit I guess...plus to be sure I'm saving it to the right place … I don't want to use command-s in case it saves to another client's folder.

    I think you have that the wrong way round.

     

    Save (Command-S) will overwrite the document and leave it in the same location. There is no risk of it being saved elsewhere.

     

    Save As (Shift-Command-S) will save in the last defined location. Unless you check the location carefully there is a risk of saving the file in the wrong folder.

  • Ausdaz Level 1 Level 1 (0 points)

    So Save finds the file and saves over it in the correct location?  I can't believe I've been using Appleworks for all these years and never twigged to that. I've always used Save As to be sure I'm saving in the right place; as I said, I also often save a file on more than one HDD as backup.  Thanks for letting me know.

     

    Still doesn't solve the problem as to why Save As is creating multiple copies of some files and doesn't seem to on others tho.  Really weird.

  • Ausdaz Level 1 Level 1 (0 points)

    Hmm, hit another snag...grrr   I CAN'T USE Save (Command-S).   When I make changes to the document and go to save it, in the menu it gives me ONLY the option Save As (Shift-Command-S) as SAVE is not highlighted.  (And even if I could use Save, what happens when it's the first time saving the file?  Where will it save it to if it's not defined using Save As?)

     

    So I'm back in my original place, saving multiple copies of the file...it won't let me over-write it!

     

    Please, if anyone can solve my problem it would be the best Christmas present ever as it's soooo frustrating!

     

    Thanks...

    Take care

    Marianne

  • Munas Level 4 Level 4 (1,260 points)

    Save (Cmd+S) command is available to use only on files that are already saved (have name and are saved somewhere on a disk).

     

    If you create a new file - you Save As it to some place on a disk, later when you change something - you can use Save (Cmd+S) to save changes to the file and it saves the file to the location of the latest file save.

     

    i.e. you create a file and Save As it to ~/Documents giving it a name MyInfo.pages

    Then you continue editing file and after you press cmd+s it is saved to ~/Documents/MyInfo.pages

    However, if for some reason you will Save As it later to ~/Documents/My Files/MyInfo.pages all the following Cmd+S (Save) will save file to  ~/Documents/My Files/MyInfo.pages and not the ~/Documents/MyInfo.pages

     

    If you want to store the file in several different locations, the best and easiest way would be to save file to single location during its editing and when it is finished and the last time cmd+s is pressed - Save As it to the another locations you want the file to be or use Finder to copy file to these additional locations.

  • Roger Wilmut1 Level 9 Level 9 (69,535 points)

    When you hit command-S on a new file it asks you where to save it. Thereafter it simply saves over the original wherever it's located (provided you don't move it while it's open).

     

    Not being able to save usually means that the file can't be overwritten, either because it's locked or because it's located on a non-writable location such as a CD - obviously not the case here, but perhaps you have a permissions issue? Check the file by hitting command-i and seeing whether the permissions are set correctly.

     

    permissions.jpgYou can see in this example that the permissions are set to write only for me as user 'roger'. There are other user accounts on the Mac, and if one of them tried to access it then they wouldn't be able to overwrite it.

  • Ausdaz Level 1 Level 1 (0 points)

    Hi Roger, I checked and I have permission to Read & Write, everyone else Read only so it doesn't appear to be a pemission issue.

     

    perm.jpg

     

    The main problem I seem to be having is that some files will behave perfectly when I use Save As - ask me if I want to replace the original and overwrite it.  Other files just keep adding new copies.  And then sometimes as I said, when I go to save, even when it's not the first time of saving, I ONLY get Save As, Save isn't highlighted in the menu.

     

    I don't want to have to reinstall Appleworks and it's always worked perfectly on Leopard; it just doesn't seem to like Snow Leopard.

  • Roger Wilmut1 Level 9 Level 9 (69,535 points)

    There's no inherent problem between AppleWorks and Snow Leopard - it works fine for me - so there must be something specific to your setup which is causing the problem. You say 'some file' - are the files in question sourced from someone else or does this happen with files you've created yourself?

  • fruhulda Level 6 Level 6 (15,120 points)

    It could be that you are using a template, a template with the specific name that you think is a document but is a template. Is it untitles or has it a name when you open the "document"?

  • Ausdaz Level 1 Level 1 (0 points)

    Roger, these are all files I've created myself.  For example, the file is an 'old' file I created previously, maybe last year, I update it, rename it (by changing the number at the end, e.g GA.1259. changes to GA.2234.) and save it as a new file.

     

    Fruhulda, the files are not templates.  They are word processing documents I created myself and they all have names.  See above for explanation.

     

    I just created a new file, saved it to the desktop as Save As and it saved ok.  When I changed the file, went to Save As, it saved it with 2 full stops after it as a new file.  When I took the full stop off the end of the file name and saved it with Save As, it added a full stop.

     

    Then I tried a new file I created, left the full stop off the name, used Save As to save it, no problem. Used Save after I changed it, it saved in the same location, didn't add a full stop. 

     

    Sorry that sounds a bit incoherent...but seems as if I leave off the full stop, use Save only, it works.  Which doesn't solve my problem with OLD files.  What I can't figure out is why it worked with no problem on Leopard but is throwing up this problem with Snow Leopard.

     

    If you can make sense out of this, you're all geniuses...

     

    Thanks for all the help....

    Marianne

  • Ausdaz Level 1 Level 1 (0 points)

    Further to my post above:  I just did some work - opened an old file as usual, corrected it, used Save As to save the first time and it saved fine, with just one full stop.  After that I used Save and it saved in the same location without any problems and NO extra full stops.

     

    However, when I tried to save the backups (one to the external HDD and one to zip disc), it did the same thing as before: added an extra full stop each time.  It's not the end of the world, but it's still very frustrating.

     

    I can't understand why I've lost my very helpful "Do you want to replace this file" window...

     

    Thanks yet again, you're all being very patient with me.

     

    Marianne

  • fruhulda Level 6 Level 6 (15,120 points)

    I am curious why you use full stops in the name? It doesn't make sense to me. If it works without the full stop at the end don't use it.

  • Ausdaz Level 1 Level 1 (0 points)

    The full stop at the end doesn't seem to make much difference; if I save the file using Save As (to change the save location) with a full stop it adds another one; if I leave it off, it adds one and then more each time I save it. 

    If it made a difference I'd leave the full stop off all my files, but it doesn't seem to.

     

    (I've always used full stops with this particular client, as with variations on the same file I end up with 1. then 1.1. then 1.1.2. etc.)

Previous 1 2 Next