Skip navigation

Facebook and Twitter integration not working

2252 Views 20 Replies Latest reply: Aug 8, 2013 4:59 PM by ThunderBow RSS
1 2 Previous Next
DaryxFox Calculating status...
Currently Being Moderated
Dec 9, 2012 11:30 PM

I'm have trouble using Facebook and Twitter integration in Mountain Lion. When I click 'Click to Tweet', or 'Click to Post', nothing happens; I don't get the notecard looking thig, and it's like I never clicked the button. Same thing with sharing from an app, except for Twitter. I receive notifications from both just fine, but I'm unable to post. I can tweet something from the sharing menu (link to a webpage with Safari, for example), but I cannot send a tweet using the 'Click to Tweet' button in Notification Center. Also, I cannot post to Facebook by neither sharing nor the 'Click to Post' button. So far I have tried sharing with Safari, Finder, and Preview, all with the same results. (Facebook sharing with iPhoto does work, but I don't believe that is integrated with OS X.)

I have also tried the following, with no luck:

  • Checked my settings on the Facebook and Twitter sites.
  • Removed my acounts and re-added them.
  • Obviously, my internet connection is working.
  • Added my Facebook account to the 'Guest User' account, and another administrator account.
  • Had a friend add his Facebook account to his own (limited) account on my computer--he could not post to Facebook either.

I believe the last two things I tried indicate that this is a system-wide problem. A couple more things to note: 1) there is no kind of error message; it just sits there, like nothing happend, no 'spinning wheel' or anything. 2) It DID work before. Twitter worked when I first upgraded to Mountain Lion, and Facebook worked when I installed the 10.8.2 update. I don't use either often enough to know when exactly they stopped.

 

Here is a video illistrating my problem.

 

It's been driving myself crazy with this over the past few days, and can't seem to find an answer anywhere. I also seem to be the only one with this problem.

iMac (21.5-inch Mid 2011), OS X Mountain Lion (10.8.2)
  • jlopez.chicago Calculating status...
    Currently Being Moderated
    Dec 11, 2012 4:27 PM (in response to DaryxFox)

    I am having the exact same problem.  I don't know when it started but I know it has to have been within the last 2 weeks.

     

    I am using Mac OS 10.8.2 and Safari 6.0.2.  I did all your steps as well.  Nothing seemed to fix it.

  • matracy68 Calculating status...
    Currently Being Moderated
    Dec 13, 2012 2:27 PM (in response to jlopez.chicago)

    Same issue here. I can get notifications from my Facebook page but when I click to do a new post from the Notification Center, I get nothing. My computer keeps making the "swoosh" sound like it's trying to send something too. I am not sure it's related but it could be.

  • groovyf Calculating status...
    Currently Being Moderated
    Dec 15, 2012 2:25 AM (in response to DaryxFox)

    Same here also. Removed the twitter and facebook accounts via Settings, readded, rebooted. No luck getting it to work.

  • matracy68 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 15, 2012 4:18 AM (in response to DaryxFox)

    I was able to fix my Facebook problems by installing the 10.8.2 Supplement update. Once I did that, it fixed the problem. I did everything like you did, deleted the account, added it back. Disk Utility then Verified and Repaired permissions, and nothing worked. I even reset the PRAM and SMC to see if that was it and nothing. Installing the Supplement worked for me.

  • matracy68 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 15, 2012 4:34 AM (in response to DaryxFox)

    I reinstalled the update on top of what I all ready had. There was another post in the communities that had the same issue and that is how they fixed their problem. It was a 28MB file. I did that and my problem was fixed.

  • groovyf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 15, 2012 5:22 AM (in response to DaryxFox)

    Thanks guys. Reapplying that Update has worked for me also.

  • lufor7 Calculating status...
    Currently Being Moderated
    Jan 6, 2013 5:40 AM (in response to DaryxFox)

    guys i've got the same problem since two weeks ago and i'm driving my self literally crazy, and i'vr got already buy the computer...i'm trying to reinstalled the update but i cannot. it says that my volume is not able to do it..any idea?

  • Thno Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2013 5:48 AM (in response to DaryxFox)

    I am trying to re apply the update but I am getting stuck at this screen. Same issue. Any help?

    Screen Shot 2013-01-06 at 7.17.30 PM.png

  • lufor7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2013 1:57 PM (in response to Thno)

    please i don't know what can I do to solve it. I did the same of thno but at this point i can't carry on...someone who did it could please help us

  • matracy68 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 7, 2013 2:09 PM (in response to lufor7)

    I used this link to get the supplement: http://support.apple.com/kb/DL1611?viewlocale=en_US&locale=en_US

     

    I am not sure what you have downloaded there. This file is about 28MB. I installed it and it worked just fine. I would make sure to verify permissions and then fix any issues found using the Disk Utility.

     

    This worked for me. If it doesn't work, I am lost as to what your problem could be.

  • lufor7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2013 2:13 PM (in response to matracy68)

    it says that the system doesn't support this software! what i'm supposed to do in the disk utility? i'm new in mac and i'm still learning

  • matracy68 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 7, 2013 2:23 PM (in response to lufor7)

    First, I would eject whatever it is that you downloaded. Go to Finder and eject it that way or depending how you have your system set up, do the two finger tap and Eject it. Download the link above. Once it downloads, double click it to install it. It should work. If it doesn't you need to use your Disk Utility to check for errors. Click your Finder again and then Applications. Scroll down to Utilities and then Disk Utility. Click on your hard drive and you will get a menu of items on the right side. Towards the bottom, you will see a button to Verify Disk Permissions. Click that and let it run. It may take a few minutes to finish. Once it's finished there may be a list of things wrong with your system. Click the Repair Permissions and let the computer do it's thing. Use Disk Utility at least once a month to make sure everything is in order on your system. If this doesn't fix it, I don't have any other suggestions. I'd hate to say do a fresh install but that might be the next step if this doesn't work.

     

    Something else to consider is that is if you use Time Machine and the system did work at one point, you could go back to the last known good point and reinstall that back-up. You would lose anything you have saved since that point (obviously). If you take steps to back up your information, that should not be an issue. (For me), Time Machine works as advertised. If you are not backing system up regularly, shame on you. You need to start ASAP backing up. It's an easy process and it's times like you are having now, that make the small preventive maintenance, worth extra time and effort.

     

    Good luck.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.