Previous 1 2 3 Next 34 Replies Latest reply: Nov 13, 2015 7:06 AM by BobH1.3.4.5 Go to original post
  • Level 1 Level 1

    I have simular Issue on my Mac Book Pro Retina OSX 10.8.2 NO UPGRADES new out of the box had it for over a month. Mail Pop's up every so Often asking for password. I Have run the first aid on the Keychain and it's comes back Fine I figured it would. Since here is the FUNNY PART. When it propts for the password my current password is already their as **************** So I just Click OK and it does it's thing.


    To Run Keychain

    from Search: type Keychain then click on Keychain Access then from Keychain Access Menu select Keychain First Aid and select repair and enter your password.



    I Suspect it's some time out setting if their is no reponce from mail server the mail app assumes it's a password issue. I know at one time you had to have a premium account to POP or IMAP your yahoo account. But with the wave of smartphones i.e. anddroid and iphone generation.



    Also checking Yahoo site only

    II. Examine the configuration of your security software

    Sometimes, a piece of software security (anti-virus, firewall, or anti-spy) on your PC, a piece of networking equipment (router, bridge, or firewall), or your Internet service provider (ISP) may be blocking access to the Yahoo! Mail POP and/or SMTP servers.

    Any failure to connect to the Yahoo! POP or SMTP server would normally indicate a network issue.

    Try temporarily disabling any security software (such as anti-virus, firewall, or anti-spy) you have installed, as some software security products will actually block the Yahoo! POP or SMTP server or ports. If you are unfamiliar with how to do this, please consult with the software vendor's online help or contact their support services directly.

    If you have any network equipment (such as a router, bridge, or hardware firewall), check to see if it is blocking the Yahoo! POP and SMTP servers or ports. If you are unfamiliar with how to do this, please consult the product documentation or the manufacturer's support services directly.

    You may also contact your ISP for assistance. Ask if the modem (if provided by your ISP) or software you are using has a firewall feature. It is also possible that the ISP has certain ports blocked on their end.


    I have Symantec EndPoint on my mac and the firewall is OFF so that is not the issue. Mostlikely the issue has to do with the Mail App and it's a text file were the time out or some paramater needs to be updated.

  • MillValleyiMacG5 Level 1 Level 1

    Here is what worked for me.


    I had initially entered a password for both Incoming Mail Server and Outgoing Mail Server.  When I updated my password, I only updated the password associated with the Incoming Mail Server. I had forgotten to update the Outgoing Mail Server password.


    What's confusing is that this password is not set in System Preferences, but under the Mail>Preferences.


    1. Open up Mail and Select Mail>Preferences... (or press command-comma). 

    2. Click on Accounts

    3. Click on the mail account that has been giving you the error

    4. Click on the Outgoing Mail Server (SMTP) entry and from the drop down menu select "Edit SMTP Server List"

    5. Select the Outgoing Mail Server that has been giving you the error

    6. Select Advanced

    7. Update the Password and click on OK.


    That's it.  My problem has not reoccurred since I did this.  Hope this works for you.

  • Cannot Level 1 Level 1

    Thanks for responding to my question. For some unknown reason the problem suddenly stopped and this mail account has been working just fine for the last several days. I'm going to save the precedures you sent because this will probably happen again.

  • CosmoPlavix Level 1 Level 1

    I have the same issue.  It is predominantl;y with Yahoo.

  • MillValleyiMacG5 Level 1 Level 1

    I take it back.  The problem has resurface after about two weeks! 

  • delageh Level 1 Level 1

    Has anyone found a solution with yahoo?

  • werner61 Level 1 Level 1

    Ok There seems to be a problem with Keychain and Yahoo Mail. Yahoo mail keeps wanting to verify the account password on IMAP accounts it seems and Mac mail asks for your password. What I noticed when you type in the password then Keychain creats another key. (crazy) soooo Keychain gets bloated and it doesn't know which PW to use. How I fix it for now is I deleted everything on mail the Account and recreated it. Deleted all the keychains for mail in keychain. Oh close mail right after you create the new account do not use it yet. Close keychain. Shut down and restart the computer, so far this seems to help as of 5/5/2013. So the problem is both Apple and yahoo nothing will get fixed on yahoo end I am sure but apple may be working on a keychain solution. This is for OSX 10.6.8 as I cannot up grade to the newer version of OSX. Hope this works for you, Gmail and Road runner do not seem to have this issue.

  • Lance Bellers1 Level 1 Level 1

    I'm getting the same problem over last few days and getting worse, just constant password requests and not able to send or receive emails. It comes back from time to time but is really stressing me out. Please think of something Apple with the Mail software if at all poss...

  • Cannot Level 1 Level 1

    It stopped doing this shortly after I posted and has only done it a couple of times since. I never changed anything. That makes me believe its on Yahoo's end.

  • Charles Hess Level 1 Level 1

    I am also thinking this is Yahoo.

    Never happens with Gmail.

    I also had no problem with using a browser

    to retrieve/send my Yahoo accounts.


    I have solved the issue (temporarily?) by using the above steps to repair Keychain

    and re-enter info under Advanced.


    I have encountered this issue previously, for no apparent reason.

    But this went on for several days this week and was quite consistent.


    I don't think Yahoo gives a $@#$!!, frankly!

  • Crystallm_52705 Level 1 Level 1

    Just repaired my issue after months of temorarily fixing it various ways... My Yahoo! server would go down and not send or receive mail and it would also ask for my password over&over&over&over&over...



    Going through this mail assistant should help you discover if anything is off. My server list had several types under it when it is only supposed to have one.


    Good luck!

  • Knoddix Level 2 Level 2

    I have come across this issue with various different macs running various different versions of os x many times and it's not always an issue associated with yahoo accounts I have had clients report this issue with all types of email accounts and there are generally 3 causes of the issue


    1 there is an issue with the mail server or connection to the mail server so it's worth trying a different Internet connection to test the issue if the issue is constant and also try contacting your email service provider as it may be a widespread issue and they may have to fix something at their end making further trouble shooting redundant



    2 there is an issue with the settings your using in mail therefore the Mac cant authenticate with the server and asks for the password again in error for instance a common scenario would be mail asks for a password for an smtp server that doesnt require a password because the authentication is not set to none as it should be Here are 2 helpful links in regards to mail settings  &


    3 there is an issue with the keychain now 9 times out of 10 keychain first aide either won't fix the issue or will only temporarily fix the issue so the last but probably the most effective step is to reset the default keychain which you can do by following the instructions in the following link NOTE: by resetting the default keychain you will clear out all passwords previously saved by you in your user account so if you don't know all your passwords it's probably not the best thing to try but again it's very effective I hope all this help good luck with fixing your mail password issues

  • CT Level 6 Level 6
  • Quagmeyer Level 1 Level 1

    Unfortunately, this did not help.  It's really odd-only one of two email accounts is affected, both are .me accounts.  I am not having trouble with this account on other devices.

  • Quagmeyer Level 1 Level 1

    Now it's working.  Why??? Magic, apparently.