7 Replies Latest reply: Dec 12, 2012 3:01 AM by roam
hannaaase Level 1 (0 points)

My Mac is telling me I don´t have Java and also my online bank who needs Java sais I don´t have it but when I check for updates on my Mac it´s all updated. And whey I go to the Java settings it sais I have Java. What can I do?

MacBook Pro, iOS 6.0.1
  • roam Level 6 (13,565 points)

    three points.


    1. you are in the wrong forum, This is for Mac software circa 2003


    2. In OS 10.6 Snow Leopard /Applications/Utilities/Java Preferences > select Java

    Check your web browser preferences to enable Java.

    In Safari it is under Preferences > Security. select it.

    In Firefox it is under Tools > Add ons > Java plug ins: Enable it.


    3. Java is not a secure protocol and for any bank that uses it I would question their security in general. I have used several online bank accounts and none require Java.

    I think you should change banks. Not joking

  • hannaaase Level 1 (0 points)

    Trust me, it´s a Norwegian Bank thing. Even the number one Norwegian bank that is one of the worlds biggest companies in the world use Java.. Haha. (I have that bank and also another big one and they all use Java)


    My browser allready accepts java as it´s hucked off allready. When I google it i see a ton of people having problem with chrome and java but few have a solution so think I will have to live with it :/


    Thank you for responding!

  • roam Level 6 (13,565 points)

    In general it is helpful to state which Mac OS you have. 10.7 10.8?

    I think in the latest OS release Apple does not install Java, as it considers it a potential vulnerability, but it can be installed if needed.


    If your problem is just with Chrome, don't use it for banking. Use another like Safari or Firefox.


    Open Safari and go to this site to see if Java is installed.


  • hannaaase Level 1 (0 points)

    I have the OS X 10.6.8.

    Then Java version 1.6.0 from Apple.


    As you point out it´s probably an Apple thing since it does not work on Chrome or Firefox. I had to switch to Windows on my Mac, then I got the same error message there but tried another browser in Windows called Flock and it worked on that one. Witch is super wired when it wont work in the normal Explorer. So at least I can log in to Windows. It´s more hassle so hoping for an Apple update or something.

  • roam Level 6 (13,565 points)

    10.6.8 Thanks. It is the same as I use. Here is a screen shot of Safari Preferences panel with Java enabled, sitting on top of the web page I linked to earlier.



    I wonder if your version of Safari is the difference. If you don't have it, here is the download;

    Safari 5.1.7 for Snow Leopard

  • hannaaase Level 1 (0 points)

    I haden´t even thought about trying Safaria, had even forgot that Safari excisted! So yeah, there it worked! At least now I only have to switch browser witch is much easier than changing to Windows. Thank you!

  • roam Level 6 (13,565 points)

    Good to hear it is now working.

    I also use different web browsers for different purposes. It saves me from altering settings.