Previous 1 2 3 Next 36 Replies Latest reply: Feb 3, 2016 9:30 PM by GabrielHay Go to original post
  • jayskull Level 1 (0 points)

    I'm having the same problem. I reset my network and still no phone number listed on the computer. It dissapeared two days ago and I feel like i've tried everything.

  • littlekelli Level 1 (10 points)

    Hmmm that always seems to do the trick!!!!! After you reset the network settings. Go back into iMessage and make sure that your phone number is checked. If not you may have toggle with Turning iMessage on and on, and resetting network settings again. I know how frustrating this is!!!!!!  This trick has always worked. Keep playing with it.

  • jayskull Level 1 (0 points)

    yup i did all that. And what's even more strange is my phone keeps promting me for my apple id password. I'll put it in hit ok and it lists my phone numbers and email addresses in the messages app and then about a min later it asks for it again. And if i don't put it signs me out in messages. Same thing for Facetime.

  • littlekelli Level 1 (10 points)

    Yeah mine did that too. I just kep doing it and it eventually did what I wanted. Try logging out of both rebooting both devices and try again.  If not call or go in. I wish I could be of better assistance. Do you have apple care? You could call or take them into the store and see if they can get it to work.

  • jayskull Level 1 (0 points)

    Ok so i read on another thread that the location sometimes messes with the imessage feature and causes it to fail. So I did what they said and changed my locaiton to manual and then quickly back to automatic. Then turned imessages off as well as facetime. Reset my network settings. Restarted everything. Went back in and turned everything on and WA-LA It worked!!!


    thanks for your help littlekelli.

  • littlekelli Level 1 (10 points)

    That's go to know, my guess to why the "reset network setting" worked for me.  I belived it was a network issue, but again, I can see it beling related to location as well!!! 


    Thanks for the update!

  • Braveswin95 Level 1 (0 points)

    Hi, I've read through this entire thread, and am hoping you can help me.  My phone number has "disapeared" from my ipad.  I'm able to send imessages as normal from my iphone 4s, but my ipad (which is up to date with OS 6.1.2) all of a sudden last night stopped receiving imessages. 


    On my phone, under Send & receive, I have that I can be reached at both my phone number and the two emails that I have assoicated with my Apple ID.  This has been the case on my ipad as well for months.  But I noticed last night i stopped receiving iMessages to my phone.  A check of the setting >> messages on my ipad shows that under "send and receive" i only have my 2 email phone number, so it was synced with my phone is no longer there. 


    How do I get my phone number back on my ipad so that'll it continue to sync my imessages with my phone?




  • littlekelli Level 1 (10 points)

    There seems to be a couple ways to do this ( maybe more).  What has worked for me, is resetting the network settings.


    On your phone, go to, Settings> General> Reset>Reset NetworkSettings......


    It seems to trigger something in the os, to get the number back on the other i devices......


    Try toggling ( resetting) imessage, off and back on the device thats not working... try rebooting your device.


    Another person  above suggested "location sometimes messes with the imessage feature and causes it to fail. So I did what they said and changed my locaiton to manual and then quickly back to automatic. Then turned imessages off as well as facetime. Reset my network settings. Restarted everything. Went back in and turned everything on and WA-LA It worked!!!"


    good luck....


  • Ralph Johns (UK) Level 9 (71,158 points)



    When mine iPhone Number disappeared from the Mac version of Messages I checked the iPhone and found it was not showing the iPhone number as selected.


    From there I deleted the Apple ID to make the iPhone number appear as selected.

    This took putting in to Airplane mode.


    Once I could see the iPhone Number as active I added the Apple ID back.


    My Mac version showed the alert messages as to what the iPhone was using only after I restarted it.

    My iPad also had the same message after that point without a restart.


    EDIT 9:36 PM

    As has been said there seems to be variations on the way to do this.




    9:35 PM      Sunday; March 17, 2013


      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously


    Message was edited by: Ralph Johns (UK) 9:36 PM

  • Braveswin95 Level 1 (0 points)

    Thanks for your reply - I reset the network settings on both the phone and the ipad and it didn't change anything.  I also took off location services and it didn't help.  I've attached screenshots of both my iphone (showing the 3 addresses, 2 for email and 1 for the phone - which i want) and my ipad which isnt showing the phone number.  I hope this helps!



    Andrewphoto.PNGphoto (1).PNG

  • littlekelli Level 1 (10 points)

    Try turning iMessage off on your ipad..... reboot  and turn it back on....... see if it shows again!!

  • Braveswin95 Level 1 (0 points)

    tried that...nothing.  thanks for the suggestion though!


    so weird this would happen.  i've been texting freely between the two since downloading iOS 5 however many months ago.  And I noticed last night around 7pm that it just had stopped working, and I haven't received any of my texts (iMessages) to my ipad since last night, going into today.  This is obviously the definition of First World Problems, but its annoying nonetheless!

  • littlekelli Level 1 (10 points)

    Yes, its strange....... these are the same steps Apple tech support had be do.  Spent 2 hours on the phone with them and they just had me keep doing this until it worked. 



    I think it has something to do with a glitch in the ios.  Try doing the steps on your iphone, turnng i message off and then back on..... for some reason imessage is getting the number. 


    is the number checked and greyed out on your Phone?  it is on mine. 

  • Braveswin95 Level 1 (0 points)

    yes, checked and greyed out on the phone - that's how it's supposed to be, right?

  • littlekelli Level 1 (10 points)

    Yes.... but do me a favor, and reset your imessage using your phone.  see if that makes a difference turn off, reboot, turn back on