8 Replies Latest reply: Dec 12, 2012 7:48 PM by BobHarris
Joe Sixpack Level 1 Level 1 (65 points)

Here's the setup:

 

- Lion iMac connected with ethernet cable to Snow Leopard tower without screen.

 

- File sharing is enabled on the SL and I can connect from the Lion.

 

- The connection from Lion uses a SL admin user/pwd.

 

- Screen sharing was enabled on SL and was working (i.e. I could work the SL machine from the Lion iMac), but I accidently turned it off (!@#$%^&*).

 

How can I re-enable screen sharing on SL? (No, I don't have an extra screen lying about.)

 

I was going to try something like this:

 

http://hints.macworld.com/article.php?story=20080318190503111

 

But couldn't get SSH to work from terminal without having the SL IP address which I can't figure out how to get.

  • BobHarris Level 6 Level 6 (15,960 points)

    Do you have System Preferences -> Sharing -> Remote Login enabled on the headless Mac?  That is essential in order to ssh into it.

     

    To get the IP address I would download one (or both) of the following apps:

     

    WakeOnLan gives local network IP and MAC addresses

    <http://www.macupdate.com/info.php/id/15779/wakeonlan>

     

    Bonjour Browser

    <http://www.macupdate.com/app/mac/13388/bonjour-browser>

     

    Both of these utilities will give you a list of every IP address is sees on your local network.  WakeOnLan has another purpose, but it also has a wonderful ability to find and display every IP address it can see on the local network.

     

    Bonjour Browser will show all the advertised services on the local network, including SSH services.  From either of these apps you should be able to find the IP address of the headless Mac.

     

    NOTE:  If you do not have Remote Login enabled, then you are going to have to find a monitor to attach to the Mac for a few minutes until you get it configured.  Maybe a neighbor has a monitor you could borrow for an hour, or even an HDTV with VGA connector on the back (assumes you have or can get a cable/adaptor for monitor/HDTV).

  • Joe Sixpack Level 1 Level 1 (65 points)

    Bonjour Browser works great.

     

    BB showed an IP and port # for Apple Remote Desktop, but nothing for Remote Login. I assume that means Remote Login is not enabled, which would, as you pointed out, would explain why I couldn't get SSH to work.

     

    Actually didn't need ssh to try the technique mentioned in the article I linked to (just used file sharing), but screen sharing still didn't work. Comments for the article mentioned putting a file in /private/etc/ but OS X won't let me do anything in /private/etc/, at least via file sharing.

     

    Since Apple Remote Desktop is apparently turned on (?), I tried using RealVNC Viewer (I don't have ARD), but got this message:

     

    To connect to Apple Remote Desktop (10.4) or Screen Sharing/Remote Management (10.5 onwards) built-in to Mac OS X, turn on the 'VNC viewers may control screen with password' option."

     

    In Lion, that's an option in the System Prefs > Sharing >  Remote Management > Computer Settings. Don't know what it is in SL, but I am wondering if there is a plist or something that I can edit via file sharing to change the ARD settings. Then use VNC to turn on regular screen sharing in the control panel.

  • BobHarris Level 6 Level 6 (15,960 points)

    If ARD is enabled (you would prefer Screen Sharing be enabled, but ARD is a more complex form of screen sharing, so the following might work):

     

    Finder -> Go -> Connect to server -> vnc://ip.address.of.mac

     

    This should start up the Screen Sharing client and attempt connecting to the headless Mac.

     

    In Bonjour Browser, you hopefully have an entry for "Remote Frame buffer" with your headless Mac listed, and an entry that has the headless Mac's IP address:5900.  This would indicate you should be able to connect via Screen Sharing (as indicated above).

  • Joe Sixpack Level 1 Level 1 (65 points)

    Finder -> Go -> Connect to server -> vnc://ip.address.of.mac

     

    just launches the Screen Sharing app, same as the normal way of trying to do screen sharing.

     

    I put in the same admin user/password as I use for file sharing and get an "Authentication Failed" error message. I assumed that meant screen sharing is turned off, but maybe not--"Remote Frame buffer" does show up in Bonjour Browser.

     

    --------------------

     

    Screen sharing worked fine until I started messing with System Prefs > Sharing. The way I remember it (not that reliably)  I was turning on additional sharing things and accidently unchecked screen sharing causing the connection to close (would that actually occur?). But maybe there was a crash or something else happened.

     

    Anyway, I guess I'll have to go find a monitor.

  • BobHarris Level 6 Level 6 (15,960 points)

    Bonjour Browser saying there is a "Remove Frame Buffer", and that you were prompted for a username/password says that the screen sharing server is running on the headless Mac.  However, that fact that you were denied access for a valid account and password is a strong indication that the System Preferences -> Sharing -> Remote Management (or Screen Sharing) -> Allow Access For: section is denying you access for the account you specified.

     

    I think you will have to find a monitor.

     

    Unless you have another Mac that can boot Snow Leopard.  If you have another Mac that can boot Snow Leopard, then assuming you can plug in a keyboard to the headless Mac, then you could boot the headless Mac into Target Mode (Boot holding Command-T).  In Target Mode the headless Mac becomes rather large external Firewire disk drive.  If you then connect a Firewire cable between the Headless Mac and another Mac, you should be able to boot the other Mac holding down the "Option" key to see the headless Mac's disk as a bootable disk.  You could then boot up the other Mac using the headless Mac's disk, and then configure your sharing prefs as you need.

  • Joe Sixpack Level 1 Level 1 (65 points)

    Didn't know target mode could be used that way. Great idea. I do have another Snow Leopard Mac. Just need to scrounge up a FW cable tomorrow. A lot easier than borrowing and lugging a monitor around.

  • Joe Sixpack Level 1 Level 1 (65 points)

    Halelujah, the Firewire method worked like gangbusters. Thank you very much. BTW, Screen Sharing gets turned off automatically when Remote Management is checked in Sharing preferences. That's what started this mess.

  • BobHarris Level 6 Level 6 (15,960 points)

    I'm glad Target Mode worked for you.  It doesn't work for everyone, especially if there are no other Macs, or the other Mac is so new that it requires Lion or Mountain Lion when you needed to be able to boot Snow Leopard, or worse doesn't have Firewire (think Macbook Air).

     

    As for Remote Management and Apple Remote Desktop, they are really intended for managing a classroom full of Macs, or a small business or department of Mac.  For home use, keep Remote Management off, and just use Screen Sharing.  I guess if you had a house full of kids, each with their own Mac, then that might be a case for buying Apple Remote Desktop.

     

    You might also want to enable "Remote Login" which will give you the ssh login ability, as another way to make a connection if Screen Sharing should go away again