Skip navigation

Wiki Service error message (continuous) in OS X Server (ML) 2.2

9012 Views 56 Replies Latest reply: Aug 9, 2013 3:01 PM by Peter Graves1 RSS
  • aptmxLS Calculating status...

    Type this in terminal:


    sudo lsof -Ri | grep krb524


    This displayed the problem:


    gs-server    81     1            root    7u  IPv4 0x1bbbdc1f95feb60b      0t0    TCP localhost:krb524 (LISTEN)

    ruby      25455     1    _teamsserver   16u  IPv4 0x1bbbdc1fb24df79b      0t0    TCP localhost:63194->localhost:krb524 (CLOSE_WAIT)

    ruby      25455     1    _teamsserver   17u  IPv4 0x1bbbdc1fad21860b      0t0    TCP localhost:52346->localhost:krb524 (CLOSE_WAIT)


    You can tell that _teamsserver (Wiki) is listed as (CLOSE_WAIT) and gs-server is listed as (LISTEN).  That is the problem right there.  Essentially the Wiki service is being overridden by the gs-server process.  If Wiki is succesfully running, _teamsserver will be listed as (LISTEN). 

  • krw Level 2 Level 2 (175 points)

    I have been trying to sort out the same problem on my ML server too. I do not seem to have good sync (gs-server) issue, but i to have a lot of (CLOSE_WAIT) messages.


    [kirkw@truffula]~$ sudo lsof -Ri | grep krb524

    ruby      87218     1   _teamsserver   15u  IPv6 0xc978a827454501d9      0t0  TCP localhost:50958->localhost:krb524 (CLOSE_WAIT)

    ruby      87218     1   _teamsserver   16u  IPv6 0xc978a8274f8221d9      0t0  TCP localhost:50959->localhost:krb524 (CLOSE_WAIT)

    ruby      87218     1   _teamsserver   17u  IPv6 0xc978a827544a8df9      0t0  TCP localhost:55509->localhost:krb524 (CLOSE_WAIT)

    ruby      87218     1   _teamsserver   18u  IPv6 0xc978a8272338edf9      0t0  TCP localhost:55510->localhost:krb524 (CLOSE_WAIT)

    ruby      87221     1   _teamsserver   15u  IPv6 0xc978a82743fd1a19      0t0  TCP localhost:50964->localhost:krb524 (CLOSE_WAIT)

    ruby      87221     1   _teamsserver   16u  IPv6 0xc978a827454505b9      0t0  TCP localhost:50965->localhost:krb524 (CLOSE_WAIT)

    ruby      87224     1   _teamsserver   15u  IPv6 0xc978a8271eb37a19      0t0  TCP localhost:50970->localhost:krb524 (CLOSE_WAIT)

    ruby      87224     1   _teamsserver   16u  IPv6 0xc978a8272338c5b9      0t0  TCP localhost:50971->localhost:krb524 (CLOSE_WAIT)

    collabd   87231     1   _teamsserver    6u  IPv4 0xc978a827549ebbe1      0t0  TCP localhost:krb524 (LISTEN)

    collabd   87231     1   _teamsserver    7u  IPv6 0xc978a8271ac891d9      0t0  TCP localhost:krb524 (LISTEN)



    I suspect however, that my problem is with global_settings in pg. When I connect with psql as collab, i get:


    [kirkw@truffula]var$ sudo psql -U collab -h "/Library/Server/PostgreSQL For Server Services/Socket"


    psql (9.1.4, server 9.2.1)

    WARNING: psql version 9.1, server version 9.2.

             Some psql features might not work.

    Type "help" for help.


    And then do a select all from global_settings:


    collab=# select * from global_settings;

    ERROR:  relation "global_settings" does not exist

    LINE 1: select * from global_settings;




    As you can see, "global_settings" does not exist is probably not good.


    Any ideas how how to re-creat global settings? Thanks.

  • aptmxLS Level 1 Level 1 (0 points)

    Well you would only have gs-server if you have installed a program called GoodSync.  If you don't have that program on your Server, that would not apply to you.  Not sure about PostgreSQL, but after much frustration, PostgreSQL was fine in my case.  

  • krw Level 2 Level 2 (175 points)

    Thanks. I suspect that my problem is with postgresql.

  • sibr Calculating status...



    I wonder if you might be seeing messages like this:

    Feb  2 11:18:58 sandboxd[97751] ([97749]): collabpp(97749) deny file-read-data /Library/Preferences/.GlobalPreferences.plist

    However, that is a .plist file, so may not be relevant. If it is though, as mentioned elsewhere I've been able to fix this by editing the file at /Applications/



  • warrenkerrigan Calculating status...

    aptmxLS wrote:


    Turns out it was an issue with a program running on the Server called GoodSync.  Worked with Apple Enterprise support and we finally figured out that a service was running called gs-server.  This process was listening on port krb524, essentially blocking the process teamserver (Wiki) from listening. The gs-server process would overtake the teamserver process which caused the Error Reading Settings just to appear in the Wiki service.  Uninstalled GoodSync and made sure the process gs-server was not active.  All is working well now.  I would have never figured that out.  I knew it was something small like that.  Hope this can help everyone else out who happens to use that program and runs the



    I have a couple of different problems. However this solved the can't read settings error is server app 2.1.


    Good spot! How on earth did you find that. Well done.


    Right, no onto my profile manager issues.

  • jasonfz Calculating status...

    aptmxLS wrote:


    Well you would only have gs-server if you have installed a program called GoodSync.  If you don't have that program on your Server, that would not apply to you.  Not sure about PostgreSQL, but after much frustration, PostgreSQL was fine in my case.  


    GoodSync was my problem with this also.  Check /Library/Application Support/GoodSync 

    There was also a LaunchAgent in /Library/LaunchAgent


    My problem is that I actually do use this software.  I have logged a support ticket with the dev or GoodSync so if there is a workaround will advise.  Thanks to the poster that found this, I would have not thought to look at GS as the culprit.  And it does appear that this started in Server 2.x with ML 10.8.x -- in Lion Server 10.7.x I did not see this issue and had GS running.

  • jasonfz Level 1 Level 1 (0 points)

    I heard back from GoodSync support on this issue and there is a component of this software that uses port 4444 which conflicts with the Wiki service


    Ref: %203a1fff831475

    The collabd_url service uses port 4444


    This would explain why when gs-server running on 4444 (or anything else) would cause the wiki issue here since the collabd_url service cannot start.


    The workaround to the goodsync issue is strightforward if you use the GoodSync connect feature and not so straightforward if you don't.


    If you don't use GoodSync at all, then drag the app to the trash and trash /Library/Application Support/GoodSync and the agent in /Library/LaunchAgent


    If you use GoodSync connect then login to the UI at localhost:4444 with your goodsync username and password and in server settings change the port 4444 to another unused port (and bookmark or remember that for future UI connections)


    If you don't use GoodSync connect but you do use the application (which was my scenario) and you have not configured GoodSync connect then this presents a challenge because the gs-server service runs and listens on port 4444 but you cannot connect directly to it.  You have to go into the application, file menu, and select configure goodsync connect.  From there, you need to select the option to use if to configure it, setup a username and password, then once that is done then you can connect to the UI on localhost:4444, go into server settings and change the port or disable the UI.


    Once this is done (gs-server gone or not listeneing on port 4444) then the wiki config in server will work if this was your issue.


    I suggested to the goodsync developer that they do not configure and run the gs-server service when the user has not chosen that option -- and also that they should consider changing the port to something that os x server does not use.


    Hope this helps someone else as this was a very odd issue...

  • andywill132 Calculating status...


  • Wim M Calculating status...

    Jan Lukens wrote:


    What I did to resolve these errors: I trashed the, causing the OS to stop all server services. After that, I trashed the entire /Library/Server folder, after which I retrieved from the trash and reinstalled it in the Applications folder. This will cause the Server to reinstall with a new, fresh PostgreSQL database, and the errors are gone.


    So, at least on my system, it wasn't necessary to reinstall completely from scratch.

    Simply Briliant

    Followed your procedure and the server reinstalled with all settings except for the Wiki and Profile manager errors. That's a great relief after lots of sudo's

  • Peter Graves1 Calculating status...

    aptmxLS wrote:


    Turns out it was an issue with a program running on the Server called GoodSync.  


    Thank you!


    This was my issue - after many hours of searching turns out GoodSync was the culprit.  Now Wikis load and ServerManager is not complaining.


    Happy days.

1 2 3 4 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.