6 Replies Latest reply: Dec 13, 2012 10:02 AM by Malignance
SheltieHenryMom Level 1 Level 1

There is a glitch in the DND software: I have set up Do Not Disturb. It's set to ON and in the notifications, I set the time from 10PM to 7AM.  I also selected to allow notifications from my Favorites.  Well with that feature ON, ALL text messages are silenced, even for the people in the Favorites group and even during the day (times not in the 10PM to 7PM range).  This defeats the purpose for me. I want to be able to receive text alerts as well as phone calls from people in my Favorites even when phone is on DND. 


iPhone 5, iOS 6.0.1
Reply by Malignance on Dec 12, 2012 7:17 AM Helpful

I believe there are two settings for DND. Do you have them both set?

 

Settings > Do Not Disturd. This one is 24/7

Settings > Notifications > Do Not Distub. This one is for a schedule

 

Try to shut off the first one and see if that fixes the issue.

 

Hope that helps

All replies

  • Malignance Level 4 Level 4
    expertise.iphone
    iPhone

    I believe there are two settings for DND. Do you have them both set?

     

    Settings > Do Not Disturd. This one is 24/7

    Settings > Notifications > Do Not Distub. This one is for a schedule

     

    Try to shut off the first one and see if that fixes the issue.

     

    Hope that helps

  • KiltedTim Level 9 Level 9

    It's working exactly as intended. It does not allow text message notifications to come through. Or e-mail notifications, or any other notifications. It will only allow calls through from the group you designate as allowed.

  • needleman_mark Level 3 Level 3
    expertise.wireless
    Wireless

    the post about the 2 settings is correct - one sets DND on or off at all times - the other is for scheduling - its a bit counter intuitive and the ios 6 manual is not very helpful in explaining how it works - i had the same problem until i figured out how it works

  • SheltieHenryMom Level 1 Level 1

    Thanks,  that helped with it only stopping calls from 10pm-7am, but text messages were also silenced during the dnd time .  I believe that is a flaw because it should allow communication from people in your favorites whether they contact you via phone or text. 

  • KiltedTim Level 9 Level 9

    It is working as designed. You can make suggestions to Apple using the Contact us link at the bottom of the page.

     

    Message was edited by: KiltedTim

  • Malignance Level 4 Level 4
    expertise.iphone
    iPhone

    Sorry that didn't fix your problem and after I re-read your OP I saw this

    SheltieHenryMom wrote:


    I also selected to allow notifications from my Favorites.  Well with that feature ON, ALL text messages are silenced, even for the people in the Favorites group and even during the day (times not in the 10PM to 7PM range).

    That's not the setting. The setting is Allow Calls From. See here > iOS 6: Using Do Not Disturb

     

    It may be a flaw. You can always give Apple feedback > Apple - Feedback

     

    Regards