1 2 3 4 Previous Next 53 Replies Latest reply: Jul 19, 2013 5:09 PM by Pierre H.A. C. Go to original post
  • 15. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    gospyro Level 1 Level 1 (0 points)

    I have the exact same problem.  Everything was fine until suddenly one day iPhoto would not let me sort Albums (same as stated above... it kept trying to force me to create a new File, and no 'line' ever appeared between the Albums.  I have several iPhoto libraries, and all the others are working just fine.

     

    Has anyone tried deleting the caches and preferences as suggested?  Did it work?

  • 16. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    Littlerockeagle Level 1 Level 1 (0 points)

    I've followed the thread and created a new user with multiple albums and the can be moved as they should be.  In my personal account, I cannot.  I deleted all the files that Preludio suggested except ~.ibrary/caches/com.apple.iphoto which does not exist on my system.  Is that the issue?  If yes how can I have the mountain lion/iphoto create the caches/com.apple.com file?

  • 17. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    gospyro Level 1 Level 1 (0 points)

    @ Littlerockeagle... yeah, I had the same problem... deleted all the files, except the one you said did not exsist on your system, because it did not exsist on mine as either.  No change.  If I create a new iPhoto library it works fine, as to all the other Libraries I have.  The problem is only with this one library.  Just wanted to let you know that what ever the problem is, you are not the only one having to deal with it.

  • 18. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    Littlerockeagle Level 1 Level 1 (0 points)

    Hi gospyro, thanks for the reply, hope that Preludio will come back with an update especially regarding the NO CACHE file.  Is that the issue?  I just checked another macbookpro running mountain lion and it does not have the CACHE file either.  However, I can move the albums around on the other macbook pro.  Any ideas on how to reload iphoto?

  • 19. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    preludio Level 2 Level 2 (205 points)

    I doubt that the "missing" cache file is the problem. Cache files are temporary files use by programs to make things run faster. While I don't know the rules for when iPhoto creates this file, I don't think this is the culprit.

  • 20. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    preludio Level 2 Level 2 (205 points)

    Looks like we have another clue. If I understand Littlerockeagle correctly, a new iPhoto library made under the same user account does not have the problem.

     

    That suggests that the problem is a damaged library. That sounds odd to me, but, again, iPhoto is a complex database program, and it's possible that damaged data (the iPhoto library) could affect how the data is displayed in the program.


    If others can confirm that a new library under the same user account seems to work fine, then there some new things to try.


    First, the problem could be traced back to a damaged image, or even a damaged thumbnail. I'd run through all the repair options for rebuilding the photo library:

     

    http://support.apple.com/kb/HT2638

     

    But plese: BACK UP YOUR PHOTOS before you do this.

     

    If none of these solve the problem, then I'd suggest the more drastic step of exporting and re-importing the images to a new library. However, you can lose metadata (tags, dates, albums, etc.) if you don't do this properly. So try the rebuild options and report back.

     

    Fingers crossed!

  • 21. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    Littlerockeagle Level 1 Level 1 (0 points)

    Hi preludio, one slight correction, I have another account on my macbook pro so I opened that account, created multiple albums in iphoto with at least one pic in each and then manually rearranged the order of the albums.  It worked as designed.

    I tried this on another macbook pro (wife's) and I was able to manually rearrange her albums.  Problem seems to be on my account.

    I ran repair permissions under disk utility = no change.

    I deleted the previously discussed files from my library = no change

    I already have iphoto library manager so I'm in process of rebuilding the entire iphoto library.  This has been running for nine hours and is just over 1/2 way through.

    I do not like that my slide shows, books etc. will disappear but I also need to be able to rearrange the albums.

    Once the rebuild is complete I'll then closely review to determine to keep the new library or live with the old one and all my slide shows, books and calendars.

    I'll keep all posted with the results.

  • 22. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    gospyro Level 1 Level 1 (0 points)

    Litttlerockeagle... I did pretty much the same, with the same results. 
    When I did a full rebuild of the iPhoto Library... it took about 12 hours, and I lost all my 'smart albums' were converted into plan old 'albums'.  To be honest, I can't remember if even with all that, if I could sort the new albums like you should be able to.  I'd rather live with the hassle of having to work around the 'sorting problem' then loose all the work that went into sorting, and setting up the Library.

     

    I also tried to use iPhoto Library Manager... but even it stripped too much information from my library when it moved the photos and albums over to a new Library.

     

    So far, anything that might 'correct' the problem, also strips the library of everything that makes it a 'library'

     

    I hope someone comes up with a real fix soon.  As for now... I'm just working around the problem... which is a pain... but not as much of a pain as re-doing all the work that went into setting up the intial Library that currently has the problem. 

     

    My only hope now, is that it doesn't spread to my other Libraries!!

  • 23. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    Littlerockeagle Level 1 Level 1 (0 points)

    Reply to gospyro, preludio et.al, guys thanks for all the helpful tips over last several days.  Problem solved as described below:

    Problem:  could not sort albums manually in my account but could in a newly created test acount so issue was with my account.

     

    Attempts to resolution:

    1. Ran all Option + Command +iphoto options to repair and/or rebuild.  No positive results

    2.  Deleted all Library info shown below:

    Here are the files to delete:

     

    ~/Library/Caches/com.apple.iPhoto

    ~/Library/Preferences/com.apple.iPhoto.plist.lockfile

    ~/Library/Preferences/com.apple.iPhoto.LSSharedFileList.plist.lockfile

    ~/Library/Preferences/com.apple.iPhoto.LSSharedFileList.plist

    ~/Library/Preferences/com.apple.iPhoto.plist

    NO positive results

     

    3.  Tried iphoto library manager rebuild using version 3.8.6 but it froze when 3/4 through and 1/2 way through rebuild.  NOTE:  version 3.8.6 reported being the latest version when I checked for updates but I checked the Fat Cat website and behold there is a version 4.0.4 which in the release notes describes the crash/freezes that I was experiencing with version 3.8.6

     

    4.  Purchased new upgrade and then ran rebuild again.  This time was successful and I can now manually re-order the albums.

     

    5.  Per the forum info, the rebuild did delete the slideshows and projects I had build but I had also exported and then saved these to an external drive so nothing lost.

     

    6.  Rebuild and moving of albums is now successful.

     

    Whew!!!!

     

    Thanks again to all who helped resolve this.  Iphoto library manager (version 4.0.4) saved the day!

  • 24. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    gospyro Level 1 Level 1 (0 points)

    Thank you Littlerockeagle!!!

     

    I haven't tried it yet, but I most definitely will!

  • 25. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    gospyro Level 1 Level 1 (0 points)

    Hi again Littlerockeagle... I've downloaded the newest version of iPhotomanager... but I'm would like to know which type of 'rebuild' you ran in order to fix the album/sort problem.

     

    thanks again

  • 26. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    Littlerockeagle Level 1 Level 1 (0 points)

    Hi Gospyro, first be sure you have exported your slide shows in the format you desire to another drive and/or into itunes.  Next I have the originial iphoto library backed up on time machine or another drive.  Quit iphoto.

    I then open iphoto library manager, select the library to be rebuilt in the left column and then under "library" at the top click 'rebuild library'.  You then have option of giving new library a different name and saved to another location, in my case to an external drive.

     

    Please note this does create a new library and deletes your slide shows and projects like books, calendar's etc.

     

    My iphoto library is about 230 gig and took 4-6 hours for the rebuild.  I then tested the new library, confirmed it did manually move albums.  Next I moved the old iphoto libary to an external drive, added 'old' to the original version.  This took several hours.  Finally, I moved the new rebuilt library from the external drive to my picture folder under my account.

     

    It was almost an all day process but was running in the background while doing other work.

     

    During this process I turned off time capsule so the next step was to run time capsule and that took overnight to catch up and completed this morning.  Finally I had to resynch my iphone since all my photos were linked to the old library.  I reselected the albums I wanted from the rebuilt library and they copied back to the iphone.

     

    To adjust the time, it took about a 1 1/2 days to complete the process but it now works and I'm making new slide shows.

  • 27. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    gospyro Level 1 Level 1 (0 points)

    Thanks... I didn't see the 'rebuild library' option in iPhoto Library until I looked up in the VERY top menu bar.  Setting up all my back-ups now, which will take a while, then I'll run the 'rebuild'.

     

    Thanks for all the help... and why hasn't Apple dealt with this problem from their end?  It's their bug... and we have to use a 3rd party program to fix!!?!!

     

    I'll get back with how things turned out, for the good or the bad... hopefully the good!!

  • 28. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    Littlerockeagle Level 1 Level 1 (0 points)

    From my understanding it is caused by a corrupt database not the overall program.  Why the iphoto rebuild did not solve the issue is a good question.  Since Apple does not monitor these forums unless it was a massive problem across the mac population I don't believe Apple will even become aware of the issue with their rebuild functionality.

    Hope your rebuild via iphoto library manager works.

  • 29. Re: My iPhoto '11 won't let me sort ALBUMS manually. How can I fix this?
    Old Toad Level 10 Level 10 (115,700 points)

    Try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

    home.PNG

    or with Mt. Lion from the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder

     

    iP11mtlioncache.png

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

    OT