Previous 1 2 Next 27 Replies Latest reply: Oct 16, 2014 5:23 AM by Merbius
TrackguyRH Level 1 Level 1 (0 points)

My MacBook Pro has been connected to the same network for over a year now, and today it can't find it. All of my other devices, and my wife's MacBook are on the network right now. I am sending this from my iPad which is having no issues. Please help. Thanks.


MacBook Pro (13-inch Late 2011), OS X Mountain Lion (10.8.2)
  • sanjampet Level 5 Level 5 (7,745 points)

    Try going to utilities>airport utilities, and recreate your airport.

  • TrackguyRH Level 1 Level 1 (0 points)

    I can see all of the other wireless networks from my neighbors, but mine does not show up on my MacBook, but it appears on my iPod, iPad, and my wife's MacBook.

  • sanjampet Level 5 Level 5 (7,745 points)

    Try rebooting modem and router then  go to sytem preferences>network, turn airport off then back on set location to automatic disconnect all peripherals, try going to network utilities, continue, and follow the prompts. See if that gets it. This has always worked for me. Here are some links, maybe some info here.

     

    http://support.apple.com/kb/VI25

     

    http://support.apple.com/kb/TS3549

     

    http://support.apple.com/kb/TS1398

     

    http://support.apple.com/kb/TS3727

  • jarleaax Level 1 Level 1 (0 points)

    I have the same problem.. Tried all of the obvious solutions.

     

    - Restart computer

    - Restart Router and modem (same device)

    - turn airport of and on

    - delete wifi device and add it again

    - delete all known connections

     

    For no reason my macbook Pro, late 2011 won't connect anymore. I was online yesterday, but today it won't even show my router on the list of available devices. It shows all other available connections in my neighbourhood.

     

    If my connection turns up, it does so after I restart the computer, and it only shows for 5 - 10 seconds. If I manage to hit it, and try to connect to it, it just says that there was a time out. then it disapears from the list again.

     

    All other devices in my house can still use the connection. One macbook Pro, late 2009, one iPhone 4, one iPhone 5 and a brand new iPad.

     

    The only one affectet is mine. And it has been working perfectly since october last year.

     

    I have osx 10.8.4

    How do I reset the airport device from the library? What files to delete and where?

     

    I haven't tried changeing the broadcast channel on the router, because no other device in my home has a problem with connecting to it.

  • jarleaax Level 1 Level 1 (0 points)

    When I say airport I mean the wifi card in the MBP, not an external device like A Timecapsule or a Router.

  • joakimgronli Level 1 Level 1 (0 points)

    This same exact thing is happening with my Retina MacBook Pro. It no long finds my wifi network at home.

     

    All other devices still find the network just fine. My iPad, iPhone, a windows computer etc. I still find all my neighbours wifi-networks, and can  connect to other networks. I can connect my iPone to the wifi and use it as a Personal hotspot,  I can acces the wifi on my Macbook via USB or Bluetooth.

     

    The first few times my wifi didn't show up on my Mac, I could reboot the machine, and it would sometimes find the network again. I would stay connected until the Mac went to sleep then I had to reboot a few times again. Rebooting no longer solves the issue. Turning off and on my Airport dosn't work.

     

    I'm runing OS X version 10.8.4 (latest at time of post)

  • rudeeeeeee Level 1 Level 1 (0 points)

    I have the same problem here After updating.

  • Extapa Level 1 Level 1 (0 points)

    dear

    i faced same issue, and i solve it by this

    try it :


    STEP 1: Restart your Mac and try once if you are able to resolve the problem as many times, the issue might get fixed. Just by simple restart.


    STEP 2: Backup all your data before trying to follow the next step so that you recover your data if it’s corrupted or so which is just for safety reasons.


    STEP 3: Now open keychain access application from Utilities -> Keychain Access.


    STEP 4: Enter the Wireless network name in the search box and delete the Airport network password items with the name but before doing that just make a note of it.

    STEP 5: Quit Keychain Access and restart your Wi-Fi.


    STEP 6: Try to connect to the network again from your Mac and now you shouldn’t be experiencing the problem as before.

  • Steve-O23 Level 1 Level 1 (0 points)

    I have the same issue on my MBA all of a sudden. Have tried every suggest solution, but to no avail. The most annoying part is that when I delete all network set ups & keychain info, the home wifi network will show for a split second when then recreating a new wifi network connection. So the MBA obviously sees it briefly, but then decides to dismiss/remove it.

     

    Any further suggestions anyone?

  • renatagames Level 1 Level 1 (0 points)

    I have the same problem on my macbook air, after 1yr of perfect wifi reception (coincidence?). The best approach right now has been to trash network preferences, but that only works until the next time MBA goes into sleep mode. It's been driving me crazy... Btw, that happened to me after I installed the 10.8.5 update.

  • PAJohnsy Level 1 Level 1 (0 points)

    Ok this worked for me...

     

    Some routers can broadcast on channels 1-13 or more, yet macs only see routers that are broadcasting on channels 1 - 11. I had the same problem and I changed my router to only broadcast on channel 5 and I can now see my wireless network again. Hope this helps.

  • alberto1978 Level 1 Level 1 (0 points)

    PAJohnsy, I had the same problem today, out of nowhere (it was working fine until yesterday), and your solution worked great. For whatever reason the router had changed to channel 13. I set it up to manual and channel 11 with my iPad, and then I was able to see the network again with the MB. Thanks!!

  • Y.B. Level 1 Level 1 (0 points)

    Thanks! It also worked on my machine. In my router the broadcast channel was set to be "automatic" and after I changed it to "5" it was found again.

  • benvoliotw Level 1 Level 1 (0 points)

    Sounding like a noob, here, but how exactly do I change my router channel? I'm having the same problem and went into my network settings, tried changing the "Location" to anything but Automatic and it screwed stuff up, so I went back, then tried doing manual DHCP with the settings my iPhone's wifi uses (IP Address, Subnet Mask, Router...) and like jarleaax, my router name will show up in the list at last, but only for a fleeting moment before disappearing when I try to connect to it.

     

    I'm running OS X Mavericks; this ****'s been happening ever since I upgraded to Mountain Lion right before Mavericks, and I've read thread after thread of people who've experienced the same thing, blaming the new OSes. Extremely tempted to wipe everything and revert back to Snow Leopard until an official fix has been announced.

Previous 1 2 Next