1 2 Previous Next 18 Replies Latest reply: Dec 18, 2012 10:21 PM by Moloy
Moloy Level 1 Level 1 (0 points)

Hello everybody !

 

So here we go, I am another user that has problems viewing web pages. To make a long story short I would like to add that though I am not a system administrator by any means, I am an experienced user. So if I say for example "I did nothing but the program stoped working correctly" DOES realy mean that I did nothing at all (therefore it doesnt mean that I occasionaly pushed few buttons while viewing complex settings and then forgot about it).

 

PROBLEM : Sometimes (randomly) I am not able to view web pages. The problem may disappear suddenly, but otherwise I have to reboot computer to solve the problem (untill it happens again. And it WILL happen withing ~30min...4 hours, so several times a day)

 

I USE : Macbook air 2012 (i7 8gb if it does matter). MacOS 10.8.2.   Everything is up to date, I frequently check the system for updates.

 

WHAT HAVE I TRIED TO DO TO SOLVE THE PROBLEM :

 

1) I have changed the wireless channel so that nobody around uses the same one

2) I have changed router and internet provider (well I did not change them, I just use my mba at office, at home and somewhere else. Each place has its own router (d-link at work and apple airport express at home) and its own provider)

3) I have changed mtu (maximum transmission unit) to 1453 from 1500 by default (System preferences -> network -> advanced )

4) I have tried different public DNS servers

5) I did try to request DHCP once again when the problem appears

6) The last but not least - I have tried different browsers (safari, opera, firefox)

 

The only thing that works yet - reboot.

 

MY STUPID THOUGHTS ON THAT :

 

- This is not a router problem, because I have already tried about 4-5 different models, including D-link, Airport and Asus

- This is not an internet connection problem generaly (I am able to use skype, teamviewer etc. while the problem occurs)

- This is not a macbook problem, because if I boot Windows (via bootcamp), it seems like I do not face that problem at all

 

As a result : this is a MacOS problem, and I have to look for fix inside it.

 

SOME ADDITIONAL INFO :

 

It realy happens suddenly: I am browsing webpages, everything is ok. Then bum - and the next page starts to load SLOWLY. Few more pages load SLOWLY (if there are pictures, I find "?" instead of them). And then pages stop loading at some moment. If I try to refresh the page, it might help sometimes. But then, finaly, I just lose opportunity to load web pages by any means.  

The problem may go away for some time, but it will return for sure. Rebooting every time is incomfortable for me, since I have a lot of stuff opened and rearranged between different spaces (desktops).

 

Thank you for your time in advance guys ! Hope some of you have already faced the problem and have found the solution.

 

 

Thank you for your time guys.


MacBook Air, Mac OS X (10.7.1)
  • 2. Re: Just another ANNOYING problem with internet
    Moloy Level 1 Level 1 (0 points)

    Unfortunately, this advice did not help me. I am not sure that this is a Safari app problem, since "6) The last but not least - I have tried different browsers (safari, opera, firefox)". So when this happens, none of browsers would open pages.

  • 3. Re: Just another ANNOYING problem with internet
    Linc Davis Level 10 Level 10 (118,430 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

     

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • 4. Re: Just another ANNOYING problem with internet
    VikingOSX Level 5 Level 5 (5,505 points)

    There are times in Safari 6 when it stalls on a link, even though I have a fast pipe. I also maintain the current version of Adobe Flash. When the stall happens, I visit System Preferences > Flash Player > Advanced > Delete All...

     

    By purging Flash detritus, the same website that was stalling now resumes normal link behavior. Sometimes, I also have to do a Reset Safari with all items selected. Between these two steps, it usually resolves the issue.

  • 5. Re: Just another ANNOYING problem with internet
    cbs20 Level 4 Level 4 (2,760 points)

    Has this always happened? Do you remember if you were having this problem before installing MacBook Air and MacBook Pro update 2.0 for Mid 2012 computers? This update has caused a lot of issues including what you are describing.

  • 6. Re: Just another ANNOYING problem with internet
    Moloy Level 1 Level 1 (0 points)

    Ty for detailed explanation!

    Step 1 (login as guest)

    As soon as I faced internet connection problem, i changed the user as you suggested to understand what is the problem connected with. As soon as I loged as a guest, the problem DID NOT go, webstie did not load.

     

    Step 2 (safe mode)

    My first safe mode on mac heh)) Everything looked the same, but it was extremely slow, and CPU usage was around 80-90%.

    The problem was gone, I was able to load webpages. BUT !!!! But what was the goal of this spep? As I have already mantioned "The only thing that works yet - reboot." SO yeaI rebooted to safe mode and internet connection is fina again, but it always happens after reboot.

  • 7. Re: Just another ANNOYING problem with internet
    Moloy Level 1 Level 1 (0 points)

    Unfortunately I can not answer you for sure. I DO remember, that MBA 2011 had also some problems with internet connection, but for some reason I was **** sure that D-link router was the problem. Then I changed both  MBA and router. U can imagine how frustrated I was to realise that the problem was not gone. But there is no way I can tell you if THIS has always happened. It might have been an another internet problem, not related to this one. I do remember that my Skype partners often said that I often disconnect, therefore I heard me badly.

     

    So generaly speaking, I do not think that the problem is connected ONLY with update 2.0 for Mid 2012 computers.

  • 8. Re: Just another ANNOYING problem with internet
    Linc Davis Level 10 Level 10 (118,430 points)

    I'm not sure I understand your response. I think you're saying you had the same problem in step 1. As for step 2, it's not clear whether you ran in safe mode long enough to have reproduced the problem. Your original message says that you have to be running for at least 30 minutes before web browsing stops working.

  • 9. Re: Just another ANNOYING problem with internet
    Moloy Level 1 Level 1 (0 points)

    Ow yes, sory, my bad. I DID NOT run safe mode long enaugh to test if I face the problem. I just booted -> opened safari -> realised everything is smooth and nice -> reloged

    I think it maight take some time for the test in safe mode, since it is not comfortable to work there. But I will post results ASAP, because the problem is a real pain in the --- for me right now.

  • 10. Re: Just another ANNOYING problem with internet
    Moloy Level 1 Level 1 (0 points)

    Ok I did my best Wasted half of my only weekend day - sunday - on stupid browsing in safe mode. I regret to say that an experiment was not 100% clear, since safe mode is EXTREMELY slow for browsing webpages. I waste about 30-60 sec to type the web page address, it takes about 30 sec to scroll the page down. So a lot of nerves and time was wasted, but without 4-hour of this slow browsing the problem did not happen.

     

    To tell the truth, in normal mode (not safe one) it would take about 20-30 min to open that many web sites, that I did open in safe mode within 4 hours. So you never know if the problem did not occur by luck or it is somehow connected to safe mode.

     

    But unfortunately I can not spend any more time on this experiment. I sincerely hope that Apple has some other way to test my device for the price we have to pay for their gadgets.

  • 11. Re: Just another ANNOYING problem with internet
    Moloy Level 1 Level 1 (0 points)

    One thing I would like to add (not sure if it is important at all) :

     

    As soon as I reboot MBA (for example because of this internet lag) and open Safari it takes some time to load websites. Usually safari has 8-12 web pages saved after last session. And I have to wait about 20-30 sec to load all the pages, though few minutes later if I try to open a new page - it loads instantly.

    Also, usualy few pages out of those 8-12 load (after opening safari) only partly. There can be found a lot of "?" instead of pictures, and the interface looks bulky. For example in gmail some buttons may not load, like "Inbox" or "Send". So I have to refresh some time later to view the correctly loaded page.

  • 12. Re: Just another ANNOYING problem with internet
    Linc Davis Level 10 Level 10 (118,430 points)

    Please read this whole message before doing anything.
      
    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
       
    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.

     

    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.

     

    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.

     

    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then either copy or drag it. The headings “Step 1” and so on are not part of the commands.

     

    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” and press return. You should then get a new line ending in a dollar sign.

     

    Step 1

     

    Copy or drag — do not type — the line below into the Terminal window, then press return:
    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'
     
    Post the lines of output (if any) that appear below what you just entered (the text, please, not a screenshot.) You can omit the final line ending in “$”.

     

    Step 2

     

    Repeat with this line:
    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'
     
    This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning.

     

    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.

     

    Step 3
    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'
     
    Step 4
    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null
      
    Important: If you formerly synchronized with a MobileMe account, your me.com email address may appear in the output of the above command. If so, anonymize it before posting.

     

    Step 5
    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null
     
    Remember, steps 1-5 are all drag-and-drop or copy-and-paste, whichever you prefer — no typing, except your password. Also remember to post the output.

     

    You can then quit Terminal.

  • 13. Re: Just another ANNOYING problem with internet
    Moloy Level 1 Level 1 (0 points)

    Thank you for detailed instructions ! Please find the logs below :

     

     

    Step 1 

    Last login: Mon Dec 17 10:59:37 on console

    MacBook-Air-Stas:~ Moloy$ kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'

    com.kaspersky.kext.klif (3.0.0d23)

    com.kaspersky.nke (1.0.0d33)

    com.kaspersky.kext.kimul.43 (43)

    MacBook-Air-Stas:~ Moloy$

    MacBook-Air-Stas:~ Moloy$

     

     

     

    Step 2 

     

    MacBook-Air-Stas:~ Moloy$ sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfi x|x)/{print $3}'

     

    WARNING: Improper use of the sudo command could lead to data loss

    or the deletion of important system files. Please double-check your

    typing when using sudo. Type "man sudo" for more information.

     

    To proceed, enter your password, or type Ctrl-C to abort.

     

    Password:

    org.macosforge.xquartz.privileged_startx

    com.microsoft.office.licensing.helper

    com.kaspersky.kav

    com.bjango.istatmenusdaemon

    com.adobe.fpsaud

    MacBook-Air-Stas:~ Moloy$

     

     

    Step 3

     

    MacBook-Air-Stas:~ Moloy$ launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'

    org.macosforge.xquartz.startx

    com.kaspersky.kav.gui

    com.bjango.istatmenusagent

    com.valvesoftware.steamclean

    MacBook-Air-Stas:~ Moloy$

     

     

    Step 4

     

    MacBook-Air-Stas:~ Moloy$ launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'

    org.macosforge.xquartz.startx

    com.kaspersky.kav.gui

    com.bjango.istatmenusagent

    com.valvesoftware.steamclean

    MacBook-Air-Stas:~ Moloy$

    MacBook-Air-Stas:~ Moloy$ ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta} * L*/Fonts 2> /dev/null

    /Library/Components:

     

    /Library/Extensions:

     

    /Library/Frameworks:

    AEProfiling.framework

    AERegistration.framework

    Adobe AIR.framework

    AudioMixEngine.framework

    NyxAudioAnalysis.framework

    PluginManager.framework

    TSLicense.framework

    iTunesLibrary.framework

     

    /Library/Input Methods:

     

    /Library/Internet Plug-Ins:

    Flash Player.plugin

    Flip4Mac WMV Plugin.plugin

    JavaAppletPlugin.plugin

    Quartz Composer.webplugin

    QuickTime Plugin.plugin

    SharePointBrowserPlugin.plugin

    SharePointWebKitPlugin.webplugin

    flashplayer.xpt

    nsIQTScriptablePlugin.xpt

     

    /Library/Keyboard Layouts:

     

    /Library/LaunchAgents:

    com.bjango.istatmenusagent.plist

    com.kaspersky.kav.gui.plist

    org.macosforge.xquartz.startx.plist

     

    /Library/LaunchDaemons:

    com.adobe.fpsaud.plist

    com.bjango.istatmenusdaemon.plist

    com.kaspersky.kav.plist

    com.microsoft.office.licensing.helper.plist

    org.macosforge.xquartz.privileged_startx.plist

     

    /Library/PreferencePanes:

    Flash Player.prefPane

    Flip4Mac WMV.prefPane

    Perian.prefPane

     

    /Library/PrivilegedHelperTools:

    com.microsoft.office.licensing.helper

     

    /Library/QuickLook:

    iBooksAuthor.qlgenerator

    iWork.qlgenerator

     

    /Library/QuickTime:

    AC3MovieImport.component

    AppleAVCIntraCodec.component

    AppleHDVCodec.component

    AppleIntermediateCodec.component

    AppleMPEG2Codec.component

    AppleProResCodec.component

    DVCPROHDCodec.component

    FCP Uncompressed 422.component

    Flip4Mac WMV Advanced.component

    Flip4Mac WMV Export.component

    Flip4Mac WMV Import.component

    IMXCodec.component

    Perian.component

     

    /Library/ScriptingAdditions:

     

    /Library/Spotlight:

    .CreationID

    Microsoft Office.mdimporter

    Wolfram Notebook.mdimporter

    iBooksAuthor.mdimporter

    iWork.mdimporter

     

    /Library/StartupItems:

     

    /etc/mach_init.d:

     

    /etc/mach_init_per_login_session.d:

     

    /etc/mach_init_per_user.d:

     

    Library/Address Book Plug-Ins:

    .DS_Store

    AdiumAddressBookAction_AIM.scpt

    AdiumAddressBookAction_ICQ.scpt

    AdiumAddressBookAction_Jabber.scpt

    AdiumAddressBookAction_MSN.scpt

    AdiumAddressBookAction_SMS.scpt

    AdiumAddressBookAction_Yahoo.scpt

    SkypeABDialer.bundle

    SkypeABSMS.bundle

     

    Library/Fonts:

     

    Library/Input Methods:

    .localized

     

    Library/Internet Plug-Ins:

    .DS_Store

     

    Library/Keyboard Layouts:

     

    Library/LaunchAgents:

    com.apple.AddressBook.ScheduledSync.PHXCardDAVSource.0E72D3F0-7D5F-41BC-9187-DE5 93D495280.plist

    com.apple.CSConfigDotMacCert-s.svirskiy@me.com-SharedServices.Agent.plist

    com.valvesoftware.steamclean.plist

     

    Library/PreferencePanes:

     

    Library/Services:

    AppDelete.workflow

    MacBook-Air-Stas:~ Moloy$

     

     

     

    Step 5

     

    MacBook-Air-Stas:~ Moloy$ osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null

    iTunesHelper, Quicksilver, Dropbox

    MacBook-Air-Stas:~ Moloy$

  • 14. Re: Just another ANNOYING problem with internet
    Linc Davis Level 10 Level 10 (118,430 points)

    Please read this whole message carefully, especially the warnings, before doing anything.

    1. The changes to your configuration suggested here should be considered provisional; they may not solve your problem, or they may remove functionality that you find useful. If a third-party system modification that you want to keep is causing the problem, seek help from its developer.

    2. WARNING: Back up all data now if you haven’t already done so. Before proceeding, you must be sure you can restore your system to its present state, even if it becomes unbootable. If you’re not sure you can do that, STOP — DON’T CHANGE ANYTHING. If you’re dissatisfied with the results of the procedure suggested below, restore from your backup. I will not be responsible for the consequences, and I will not be able to help, if you ignore this warning.

    3. You should either remove or update the following system modification(s), if an update is available from the developer:

    N/A

    and definitely remove at least the following:

    † Kaspersky

    4. Whatever you remove must be removed completely, and (unless otherwise specified in this message) the only way to do that is to use the uninstallation tool, if any, provided by the third-party developers, or to follow their instructions. If the software has been incompletely removed, you may have to re-download or even reinstall it in order to finish the job. I can't be more specific, because I don't install such things myself. Please do your own research.

    Here are some general guidelines to get you started. Suppose you want to remove something called “BrickYourMac.” First, consult the product's Help menu, if there is one, for instructions. Finding none there, look on the developer's website, say www.brickyourmac.com. (That may not be the actual name of the site; if necessary, search the web for the product name.) If you don’t find anything on the website or in your search, email the developer. While you're waiting for a response, download BrickYourMac.dmg and open it. There may be an application in there such as “Uninstall BrickYourMac.” If not, open “BrickYourMac.pkg” and look for an Uninstall button.

    Again, please don't ask me to do this research for you. You can do it better than I can, because I haven't installed the product and I may not even know what it is.

    If you can’t remove software in any other way, you’ll have to erase your boot volume and perform a clean reinstallation of OS X. Never install any third-party software unless you're sure you know how to uninstall it; otherwise you may create problems that are very hard to solve.

    WARNING: Trying to remove complex system modifications by hunting for files by name often will not work and may make the problem worse. The same goes for "utilities" that purport to remove software.

    5. I recommend that you never reinstall the modifications marked with a dagger (†) above, if any. If your problem is resolved after uninstalling all the above modifications and rebooting, but you still want to use some of those not marked with a dagger, you can experiment with putting them back, one at a time, testing carefully after each step. Keep in mind that system modifications may be incompatible with each other or with future OS X updates, so it may not be clear which one is at fault.

    6. If you still have problems after making the suggested changes and rebooting, post again. Remember: if you don’t like the results of this procedure, you can undo it by restoring from the last backup you made before you started.

1 2 Previous Next