6 Replies Latest reply: Jan 15, 2013 11:02 PM by Urs Gruetzner
Urs Gruetzner Level 1 Level 1 (0 points)

OSX.6.8 Server



Problem: Spotlight is not indexing. We deleted the index for reindexing and now its impossible to search anything.




Reason: the process mdworker which is normallly launched with the launchd pocess during booting and is used by _spotlight, is not running.


The process mds which is launched by launchd and used by root is running.


I restarted the server, still silence with mdworker.



With mdworker not running Spotlight simply does nothing.



Any help is appreciated.

MacBook Pro, Mac OS X (10.6.8)
  • baltwo Level 9 Level 9 (62,210 points)

    Reinstall the server OS.

  • Urs Gruetzner Level 1 Level 1 (0 points)

    Thanks for the help.


    However, four words which create a lot of work......



    No chance to restore a part of system files, where the mdworker stuff is located from a backup?


    Reinstallation is kind of a ultimo ratio, easy said, cumbersome to do, especially on a server, with all the setup, passwords etc....

  • baltwo Level 9 Level 9 (62,210 points)

    I'm not aware of any way to selectively install Spotlight's required components. Also, I don't do server stuff, so you'll have to await for one of those gurus to pop in. Good luck.

  • Matthias Ullrich Level 1 Level 1 (0 points)

    Hello. I found myself with the exact same problem. My solution which worked for the moment was to use onyx and for now it works again as expected. Maybe that could help you.



  • MrHoffman Level 6 Level 6 (13,540 points)

    TL;DR: Check the console logs for errors.


    Spotlight isn't specific to OS X Server. 


    Reinstalling OS X and OS X Server isn't a huge project and is a common solution for some variations of "weird" but wouldn't be my first choice here. 


    I'd start with a look at the console log files first and see what (if anything) is logged there around mdworker et al.


    I've seen cases where odd-ball or corrupted files can trip up Spotlight, though finding those files can sometimes be a little interesting.   If it's a user's file that's tripping Spotlight, reinstalling OS X Server doesn't help.


    Later versions of Spotlight tend to work a little better, though I'm guessing there's a reason you're still at 10.6.8.

  • Urs Gruetzner Level 1 Level 1 (0 points)

    Thanks for all replies.


    Meanwhile I tried the following:


    - I had a second hard disk HD2 with an older clone of HD1. I launched the server with this Volume and here mdworker was running

    - existing files where not indexed here, new ones or duplcated ones yes


    I was happy to see Spotlight working, but since some days again, mdworker died....


    I will give Onyx a try....