5 Replies Latest reply: Dec 13, 2012 9:47 AM by hlaj
hlaj Level 1 Level 1

How do I update or upgrade to 10.7?  I cannot use my iphone 5 on this old system.


iMac (24-inch Early 2008), Mac OS X (10.5.8)
Solved by Niel on Dec 13, 2012 9:14 AM Solved

1. Choose About this Mac from the Apple menu to check the RAM, and select the internal drive in the Finder and choose Get Info from the File menu to check the free drive space.

2. Yes.

3. Not if your only reason to upgrade is to sync the iPhone 5.

 

(72718)

Reply by Niel on Dec 13, 2012 8:44 AM Helpful

Click here, buy the software, and then run Software Update. You don't need to upgrade past 10.6.8.

 

(72711)

All replies

  • Niel Level 10 Level 10

    Click here, buy the software, and then run Software Update. You don't need to upgrade past 10.6.8.

     

    (72711)

  • hlaj Level 1 Level 1

    How can I check my PC to see if it has enough memory to complete this download?  Also it looks like from Snow Leopard I can then upgrade (If I want) to Mountain Lion---is that correct?  I understand that itunes 10.7, which is what I need for the iphone 5 will run off of either program.  Is there any benefit to upgrading to Mountain Lion?

  • Niel Level 10 Level 10

    1. Choose About this Mac from the Apple menu to check the RAM, and select the internal drive in the Finder and choose Get Info from the File menu to check the free drive space.

    2. Yes.

    3. Not if your only reason to upgrade is to sync the iPhone 5.

     

    (72718)

  • hlaj Level 1 Level 1

    Niel~thank you!  This has totally helped me.

  • hlaj Level 1 Level 1

    Apparently, I have enough memory to load Snow Leopard, but would really like to upgrade to Mountain Lion and do not have enough for that.  What type of external hard drive would you recommend for me to put my iphoto library on?  I have thousands of photos, which are using up my memory.