12 Replies Latest reply: Jan 27, 2014 2:02 PM by Huntersgate
Christopher Moultrie Level 1 (5 points)

When I turn on Photostream in Mac OS Preferences and then enable it from within Aperture, the program freezes and is unresponsive. I've tried:

1. Reinstalling Aperture

2. Deleting the caches

3. Creating a new library

4. Repairing Disk Permissions

5. Rebooting

6. Repairing the Disk (there were no errors found)


Anyone have any other suggestions?

iMac, OS X Mountain Lion (10.8.2)
  • léonie Level 10 (91,094 points)

    You said, you created a new library? Which library are you using now?

    Make sure, your library is o.k.: Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library


    Have you checked with iPhoto, if the Photo Stream works?

    If the Photo Stream does not work with iPhoto either, the Photo Stream may contain a corrupted image. Try, if deleting the Photo Stream Cache will help, if you have not already done so. The contents of the Photo Stream is stored in your User Library:

    ~/Library/Application Support/iLifeAssetManagement/assets/

    If you want to save the contents of the stream, copy it to a backup location, before deleting from the library.

    To reveal your hidden user library in the Finder, use the Finder's "GO" menu: Bring the Finder forward and use "Go > Go to folder", then hold down the "Options" key ⌥, until the library appears in the drop down menu.


    More general Photo Stream advice is here:

    iCloud: Photo Stream Troubleshooting

    iCloud: Using and troubleshooting Shared Photo Streams




  • heff_sf Level 1 (70 points)

    Hi Christopher-


    Some Photo Stream issues can be fixed by logging out of your iCloud account and logging back in, then turning on Photo Stream from within Aperture (not in System Preferences). Give this a try and see if it helps any:


    1. Quit Aperture if it's currently running.

      2. Open System Preferences and select iCloud. Turn off Photo Stream, then click Sign Out.

      3. Log back in to your iCloud account but do not enable Photo Stream.

      4. Launch Aperture and bring up Aperture > Preferences. Select the Photo Stream tab and enable My Photo Stream to turn on Photo Stream. (This will automatically turn it on in System Preferences too)


    WIth luck Photo Stream will run normally and return Aperture to a snappy state.

  • Christopher Moultrie Level 1 (5 points)

    I'm using the new library, and I've followed the steps to repair and rebuild my library. The photostream does not work with iPhoto either (just checked). I've also logged into icloud.com and deleted my entire photostream. That did not help either. Deleting the photostream cache also did not help.

    Thanks for the suggestions,


  • Christopher Moultrie Level 1 (5 points)

    After turning off iCloud, then going into Aperture and selecting My Photostream from the preferences pane, Aperture immediately froze after enabling the photostream. I now cannot close the preferences panel, nor Aperture. I had to force-quit it. Thanks for the suggestion.

  • léonie Level 10 (91,094 points)

    Does Photostream work, when you turn it on for a different Aperture librar?


    Or when you log into a different user acccount and turn it on? (create a ne user account from the "System Preferences" > "Usery & Groups" panel for testing.




  • Christopher Moultrie Level 1 (5 points)

    Nope, different user account with same icloud account does not resolve the issue. Nor does a different computer. I guess my iCloud Account is broken? Photostream works on iPad and iPhone using iOS 6, so it's not totally broken.

  • léonie Level 10 (91,094 points)

    What is your Aperture version? And is OS X Mountain Lion (10.8.2) in your profile signature correct?

  • Christopher Moultrie Level 1 (5 points)

    I'm running Aperture 3.4.3 and yes, ML 10.8.2 is correct.

  • Dirty Kauper Level 1 (10 points)

    I am having the same problem and pretty much have tried everything suggested in this post as well as what you have tried originally.  I also have Photo Stream on a PC.  The problem seemed to start out of the blue which is not helping with the troubleshooting.  I have disabled all third party apps with aperture like Flikr and Facebook.  As soon as I turn on Photo Stream either in System Prefs or just in Aperture, Aperture hangs.  I have deleted the Plist to Aperture and iLife. I have also deleted all plist and reinstalled Aperture which did not help. It appears it might be a problem with the library itself but I am not sure how to proceed from here.  Will let you know if I find a solution elsewhere but there is not much out there on this topic.

  • Dirty Kauper Level 1 (10 points)

    I may have stumbled upon the solution.  I thought I had tried this before with no success but it may have been a file and not the folder.  Try shutting down PhotoStream.  Go to Library folder and delete ILifeAssetManagement under Application Support  ~\Library\application support\.  Reboot and then restart Iphoto from within Aperture.  Mine hung for a second and then resumed normally.  It should be noted that I had deleted all photos from PhotoStream previously.  Hope that helps and that it holds.

  • Christopher Moultrie Level 1 (5 points)

    Looks like the key is

    1. Turn off Photostream

    2. Delete the ILifeAssetManagement Folder

    3. Secure Empty the trash to get rid of the folder

    4. Delete all photos in photostream from a device that can actually reach photostream.

    5. Turn on Photostream from within Aperture

  • Huntersgate Level 1 (0 points)

    Brilliant! This solved my issue. All I did was rename the ILifeAssetManagement Folder and a restart for good measure. On re-enabling photostream, the ILifeAssetManagement folder was recreated and is over 10x the size of the backed up version but that's because it's working and downloading my photos (which I didn't touch btw). Original backup folder was only 10MB.