11 Replies Latest reply: Apr 15, 2013 5:25 AM by Helen Muller
jayessemm Level 1 Level 1 (35 points)

I'm having some trouble getting my head around this new iTunes 11.

 

Never sure if I'm doing something wrong or if there is a bug in the program -- it certainly bugs me!

 

I just a search for an artist and iTunes told me there were three songs on three albums.  But I know I have more.  I went to the songs view and sorted by artist and there are six songs by that artist from six different albums.

 

It sure looks like the spelling is the same and matches my search.

 

Any thoughts?

 

I'm using iTunes 11.0 on an iMac running OS X 10.6.8

  • jayessemm Level 1 Level 1 (35 points)

    One thing I can figure is that while each song has the artist's name in the "Artist" field ... the three that don't show in search are part of compilations and so have "Various Artists" in the "Album Artist" field.  I always add this info because in previous versions of iTunes that was the only way to get around the cover artwork showing up for each song.  I guess a moot point now that Apple did away with that look but my library is full of tracks / compilations / albums like that.

     

    I sent this feedback to Apple too -- I'm never sure if they read these posts or not.

  • jayessemm Level 1 Level 1 (35 points)

    And while I continue to flog this dead horse ...

     

    I just did a search for "Various artists" and iTunes told me there were 83 songs on 8 albums.  Not only were none of those missing three songs (see above) there but the 83 songs listed have no information in the "get info" "Album Artist" field and certainly don't contain "Various Artists" anywhere in the info or the song or ablum title.

  • Jweebs86 Level 1 Level 1 (0 points)

    You're not alone, jayessemm.  There's definitely an issue when all of the songs you have by one artist appear on a compilation album where the artist is listed as "Various Artists."

  • Helen Muller Level 1 Level 1 (10 points)

    Try this, it worked for me:

     

     

    • First, for any of your albums that have 'Various Artists' as the album artist, select them all, right click > Get Info. Under the Info tab, delete the info in Album Artist. Go to the Options tab and under 'Part of a Compilation' select 'Yes'. Click OK. (This could take a while to update...)
    • From the menu icon in the top left corner select 'Show Menu Bar'.
    • Make sure you're in the 'Artists' view in your library for this bit.
    • From the menu bar go to View > View Options.
    • In the pop-up box, choose Sort Albums by: Title, and untick 'Group Compilations'.

     

    In the Albums view, any compilations will still be shown as one album, not 30 albums by 30 different artists, but the individual artists will now also show up under the Artist view. You should also now be able to search for these individual songs by title/artist.

     

    Good luck!

  • jayessemm Level 1 Level 1 (35 points)

    Thanks Helen,

     

    I just looked and have about 5,000 songs with "various" in the album artist.  Of course most of those "Various Artists" I added when we went from iTunes 9 to 10 because of the mess of that cover view (or whatver it is called).  Now that that option is gone I'm fixing things back.  I'll be some p*ssed if iTunes 12 comes and I have to edit back again :-)

     

    I've done as you suggest -- remove the "various artists" from the Album artist field and checked the compliations box.  Only have one question -- your last step of sort albums by "Title"  The options iTunes 11 offers me under sorting are as follows:

     

    Screen shot 2012-12-18 at 10.59.08 AM.png

     

    As you see I have nothing ticked now.  Which do you suggest?

     

    Many thanks for your advice.  Almost there!

  • Helen Muller Level 1 Level 1 (10 points)

    Hi Jayessem,

     

    I think those are the options you are seeing under sorting because you're in the Songs view of your music library. If you go to the Artists tab, and then View Options, you should get a different pop-up with 'Sort Albums By:' etc.

     

    Hope that helps!

  • jayessemm Level 1 Level 1 (35 points)

    Got it!

     

    Thanks Helen.

  • jayessemm Level 1 Level 1 (35 points)

    My challenges seem to continue.  I've started a new post at:

     

    https://discussions.apple.com/thread/4623323

     

    FYI

  • Chris CA Level 9 Level 9 (78,005 points)

    See this -> http://samsoft.org.uk/iTunes/grouping.asp

    (posted in your other thread also)

  • lizfromak Level 1 Level 1 (0 points)

    This did work.  Thanks!  However it seems that those changes did not sync to my iPod.  I still can't see all the artists in artist view.  Any suggestions?

  • Helen Muller Level 1 Level 1 (10 points)

    Hi,

     

    My iPod's an old school classic, so I don't know if it will work for you, but try this on your iPod...

     

    Main menu>Settings>Music menu, then untick Compilations.

     

    Hope that helps!