13 Replies Latest reply: May 8, 2013 9:37 AM by fillopastry
Lisa Herren Level 1 (0 points)

I am using a Lexmark Intuition S505 all-in-one.  I want to be able to scan  wirelessly from the all-in-one by pushing a button on that device, but the only way I can do that is by turning the firewall off.  Is there a way to give permission to allow this process so I don't have to do that every time?

 

Thank you.


Lisa


MacBookPro, Mac OS X (10.6.2)
  • sanjampet Level 5 (7,760 points)

    You can try clicking on the Airport icon in the tool bar, it will scan for networks, but not find hidden networks.  Dropping your firewall can be hazardous, unless you are connecting to a secure network you trust.  This is not a safe way to hijack a connection.

  • Lisa Herren Level 1 (0 points)

    Is there a way to allow the wireless printer/scanner through the firewall by noting it as an exception or something like that?  Otherwise, what is the point of creating a scanner with the capability to wirelessly send a scan to a computer if it is a really bad idea to do that?  It would seem like there would be a way to do this. 

  • sanjampet Level 5 (7,760 points)

    You can enable scan  sharing in system preferences, which will require disabling the firewall, send the scan then turn the firewall back on, if it is on your local network the risk is reduced. Just be cognizant of this. yYou should only do this with addresses you know and trust.   There is probably someone on yhr Community who knows much more than I do, but I would not want to be the cause of a catostosphic problem for you.  I wish you all the best, SJP

  • Lisa Herren Level 1 (0 points)

    Well, I would only be doing it on my local network, so the risk is reduced.  It just seems like there ought to be a way to allow this exception.  What is yhr Community?

    Thanks.

    Lisa

  • sanjampet Level 5 (7,760 points)

    Sorry, I meant the Apple Support Community. It was a typo, as I am not the best keyboard operator:)  Local network is usually OK.  All the best and hope this helped you,  SJP

  • noondaywitch Level 6 (8,135 points)

    If your router/modem connecting you to the internet has a hardware firewall (most do) set that up and turn off the software firewall. You don't need both.

     

    If you do need to use the OS X firewall, go to System Preferences > Security > Firewall > Advanced and try adding the IP address of the scanner to the white list in the box.

  • Lisa Herren Level 1 (0 points)

    THANKS SO MUCH!!!  This is exactly what I was looking for!!! 

    Lisa

  • noondaywitch Level 6 (8,135 points)

    Most welcome 

  • fillopastry Level 1 (0 points)

    Hi I'm trying to solve this problem with my new Epson printer. I can't seem to find this option in Firewall > Advanced.

     

    Screen Shot 2013-05-08 at 14.58.04.png

     

    Has this option to "add IP address" moved in Mountain Lion?

     

    Thanks in advance!

  • sanjampet Level 5 (7,760 points)

    Try going to syst prefs>firewall>firewall options, make sure that "block all incoming connections" is unchecked. You then can click the + and from the left under devices select your printer. Printer should be on to be discovered.

     

    Hope this helps.

  • fillopastry Level 1 (0 points)

    Hi,

     

    Thanks for the reply. I tried adding the printer but there is no option when clicking  +. It allows me to select an application, but not a device. Printer is on, but can't see it.. just the finder window showing folders and applications.

     

    Screen Shot 2013-05-08 at 16.24.05.png

     

    Any ideas?

  • sanjampet Level 5 (7,760 points)

    fillopastry,

    fillopastry wrote:

     

    Hi,

     

    Thanks for the reply. I tried adding the printer but there is no option when clicking  +. It allows me to select an application, but not a device. Printer is on, but can't see it.. just the finder window showing folders and applications.

     

    Screen Shot 2013-05-08 at 16.24.05.png

     

    Any ideas?

    fillopastry wrote:

     

    Hi,

     

    Thanks for the reply. I tried adding the printer but there is no option when clicking  +. It allows me to select an application, but not a device. Printer is on, but can't see it.. just the finder window showing folders and applications.

     

    Screen Shot 2013-05-08 at 16.24.05.png

     

    Any ideas?

    fillopastry wrote:

     

    Hi,

     

    Thanks for the reply. I tried adding the printer but there is no option when clicking  +. It allows me to select an application, but not a device. Printer is on, but can't see it.. just the finder window showing folders and applications.

     

    Screen Shot 2013-05-08 at 16.24.05.png

     

    Any ideas?

    On the bottom of the sidebar to the left you should see devices, and just to the right of the word  devices you can hover your cusor and  show shouls appear, click on that and see if you can then see your device and click on it to add to the "white" list.

     

    Screen Shot 2013-05-08 at 10.34.10 AM.png

  • fillopastry Level 1 (0 points)

    Hi again,

     

    The printer is on, but doesn't show under "devices" on the sidebar. I've looked into finder > preferences > sidebar to see if there was an option unchecked, and no such luck