Skip navigation

ATV3 Has Endless Buffering for non iTunes Movies over Ethernet

575 Views 10 Replies Latest reply: Jan 8, 2013 4:00 AM by Sports Billy RSS
DJChad Calculating status...
Currently Being Moderated
Dec 14, 2012 9:23 PM

I have an Apple TV 3 in my living room.  I updated to latest 5.1.1 release.  In order to get that update to go through successfully, I had to disconnect from ethernet network and use WiFi.  Occassionally, I will run into where I can not stream HD movies that are non iTunes Store files on my iMac.  These are Blu Ray rips to MKV, and converted to ATV3 mp4/m4v formats.  They play just fine on iTunes via my iMac.  I have tried restarting ATV3, iMac, unplugging ATV3 Power/wait, replug. 

 

I have only found 2 solutions that work:

1) RESET the ATV3 and set back up from scratch

 

OR

 

2) Unplug Ethernet and use my Airport Extreme WiFi.

 

What is even more odd is if I try to stream an HD movie that I have downloaded to my iMac from the iTunes store, it plays just fine over ethernet.  So I have to think the connectivity via Ethernet is fine.  Its very odd considering my ethernet network is completely gigabit.  Although my WiFi has full signal and no drops, I prefer to have anything that is stationary like my iMac, Xbox360, PS3, Apple TVs, etc... connected via ethernet.  That way my iPhone and iPad do not have any bandwidth competition while I am streaming.  Also when I output music throughout the house via iTunes Airplay to my Apple TVs from my iMac they tend to be in better time/sync with one another when all on ethernet network. 

 

My Ethernet network is setup like this:

Office: Cable Modem -> Airport Extreme -> Netgear gigabit Powerline -> electrical outlet in office

Living Room: electrical outlet -> Netgear gigabit Powerline -> Netgear 8 port gigabit switch -> devices (PS3, Xbox360, ATV3, DirectTV, Piorneer Receiver

Bedroom: electrical outlet -> Netgear gigabit Powerline -> Netgear 4 port 10/100 hub -> devices (xbox360 and ATV3)

 

I have connected my work Windows laptop top the living room ethernet gigabit Netgear switch and did several speed tests.  I am getting close to 30mps DL and 5mps UL.  I know that is internet speed.  But that should give a good indication that local network speed is more than sufficient if that is the sort of internet speed I am getting. 

 

I also ran the network tests on my Xbox360, PS3, and ATV3.  All 3 passed.  I figured if there was something terribly wrong, one of them would cry wolf. 

 

I scheduled an appointment with Apple tomorrow morning.  I think this is a hardware/driver issue with the ethernet or OS/software.  They want this to be a per incident support call or to purchase Apple Care.  I have Apple Care on everything BUT my Apple TVs.  So surely my iMac, iPhone 5, iPhone 4, and iPad 4 agreements will grant me some latitude to allow Apple to take a look into this issue.  I only decided to unplug the ethernet and use WiFi as the result of several Google searches for the issue. 

 

Anyone else able to profess this issue?  Share anything to help trend the issue? 

AppleTV 2, Other OS, Bedroom and Living Room
  • Flipitos Calculating status...

    Mam, I have the same problem. I purchased Airport Extreme and ATV3 stop playing 1080p movies not from iTunes... I had a Zyxel router before and it was playing just fine. Never hooked up to ethernet connection. All was done via wifi. I have no idea what to think... Don't want to buy a movie from iTunes, so maybe there was any proper answer from Apple?

  • don70 Calculating status...

    Same issues as well, 4 hours to wait to download for a movie dropping music i think i made a mistake.....

     

    Changed to 780...

    re set wireless router....

    tried this

    blah

    blah

     

    i bought it so i could wacth hd movies from Apple.........

     

    *** !

  • Flipitos Level 1 Level 1 (10 points)

    ***? Not helpful...

  • Flipitos Level 1 Level 1 (10 points)

    Still that is very weird... I think that there may be something in router. Zyxel does it ok. But why it plays 720p without problem?... I use ATV over wifi all the time...

  • don70 Level 1 Level 1 (0 points)

    2 movies last night, so to get ahead i restarting everything,N Series Router, ATV-3, the first mvoie was 1080p,no issues, by the second movie we are down to 780p and waiting to download.... in the middle of the movie, we go away for 10 minutes (who doesnt like leaving a movie at the good part part(s) then watch for 10 minutes more then wait again....repeat.....

     

    Now i spend a lot of money to go out and get a HD TV, Home Theater System and Apple has the nuts to tell me to turn it to 720p, urgh !!

     

    I am about ready to leave Apple out of my future.

  • Flipitos Level 1 Level 1 (10 points)

    Well, that seems to be the solution. Simply watch in 720p.... And try figure something out. Or use my old router that restarts by itself, but allows to use ATV at full....

  • Flipitos Level 1 Level 1 (10 points)

    Well it is said that Apple Airport Extreme works in both 2 and 5 Ghz and provides up to 450 mbits via wifi. So why the **** it doesn't play a movie? I'm thinking there's something blocking it in routers firmware. Could that be the case? My Zyxel works in only 2Ghz mode and provides 300 mbits via wifi, yet it starts the movie instantly...

  • Sports Billy Calculating status...

    I have a very similar problem and have just posted a question myself.

     

    All of your issues sound very similar, my setup used to work and I am heavily invested in Apple products then, after the firmware upgrade, I think it was to 5.1.1, i have been having performance issues. REstarts used to work (i lived in India for the last few years and therefore with power glitches everything got at least 2 or 3 restarts a week!).

     

    ANyway I can download/stream a purchased movie directly from the iTunes store faster than I can stream the same movie from my personal iTunes setup. Everything except my cable router is an Apple product starting with Airport Extreme......

     

    Have you had any further success in resolving your problem?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.