6 Replies Latest reply: Dec 17, 2012 7:41 AM by Bill Rising
Bill Rising Level 2 Level 2 (240 points)

I am trying to use the setup assistant to move my ten tons virtual stuff from my mid-2009 MBP to a brand new mid-2012 MBP. The mid-2009 MBP is running Mac OS X 10.8.2, and is up-to-date.

 

I first tried to do this over a network, as I had left my firewire-800 cable elsewhere. The setup would always hang at the same spot. This was documented here.

 

Now I have tried to use the setup assistant via FireWire 3 times, with miserable results all 3 times:

 

The /Applications folder gets horribly mangled every time. Nearly all of the applications (whether Apple or not) are marked out with the circle-slash, and say that they are damaged. Oddly enough, the set of mangled applications has not been the same from attempt to attempt.

 

None of my extra prefpanes get brought over. Perhaps this is normal (though bad) behavior.

 

To top things off, my new computer couldn't boot after every one of these misguided setups. Each time I restarted after the setup, it got into an endless loop of wait cursor, no wait cursor, wait cursor.

 

In case this is a help: After the setup assistant thinks it is done and Mountain Lion starts up, the partitions on computer-as-external-drive show up twice. (There are two partitions on my old MBP, say A and B. When Mountain Lion starts, it has two A's and two B's on the desktop.) This is odd.

 

As an aside, I had installed most of my applications were put in  /Applications/AAApplications, and none of these were brought over. According to the fantastically helpful Pondini site (http://pondini.org/OSX/SetupLion.html), this is normal, because only the top level of the folder will be brought over. This makes me wonder what use the setup assistant is in general.

 

I did try to use my time machine backup from an external drive, but gave up because the time machine backups are done wirelessly. Hence, the setup assistant cannot find them when the external drive is attached to the new computer. I have not yet tried hooking the new MBP and the backup drive to my router so that I can use the Time Machine backup. [ed: it seems insane to have wireless time machine backups treated so differently]

 

If anyone has any troubleshooting advice, I would be greatly obliged. This is more than a little frustrating.

 

Thanks,

 

Bill

  • Linc Davis Level 10 Level 10 (164,105 points)

    Your other post says you're using Migration Assistant. Now you say Setup Assistant. Which is correct?

  • Bill Rising Level 2 Level 2 (240 points)

    I used Migration Assistant once (when trying to migrate using an ethernet cable).

     

    For every subsequent attempt, both via network and via FireWire, I've erased the disk between attempts, reinstalled Mountain Lion and used the the Setup Assistant.

     

    Sorry for the confusion.

  • Linc Davis Level 10 Level 10 (164,105 points)

    If, as it seems, you're booting the old Mac in target disk mode and trying to transfer data from it in Setup Assistant to a freshly-installed system, then there's no explanation for your problems other than a hardware fault. There are many possible points of failure.

     

    I don't quite understand your description of your backups. If you've been backing up to a USB hard drive attached to an AirPort base station (not a Time Capsule), then your backups are invalid. Even if the network device is a Time Capsule, you can't attach that device locally and restore from it in Setup Assistant. The backups are in the wrong format.

     

    I suggest you back up the old Mac to a locally-attached external drive, then attach the drive to the new Mac and try to set up from it.

  • Bill Rising Level 2 Level 2 (240 points)

    Filling in background:

     

    Yes indeed, the FireWire failures came when booting the old Mac in target disk mode.

     

    The time-machine backups have been made by sharing a hard drive on a mac mini, and then backing up to it wirelessly in this fashion:  http://pondini.org/TM/22.html . The problem with the wireless version of the Time Machine backups is that they are on a disk image, whereas non-wireless backups are saved directly in a folder. This is outlined here:  the green box on http://pondini.org/TM/18.html [I know you already know this; I'm putting it here in case anyone else has problems and is curious.]

     

    I have a disk image of the old mac made with SuperDuper! . I would be tempted to use it to restore to the new Mac, but since the hardware on the two machines is quite different, this is likely a bad idea. In fact, the maker of SuperDuper! says it ia a bad idea: http://www.shirt-pocket.com/forums/showthread.php?t=5476 . [You already know this, too...just documenting]

     

    Continuing the discussion:

     

    So...is there a way to track the hardware failure down? If it is on the old computer, I'm not too worried, because it otherwise runs like a champ. If it is on the new computer, then I need to get ready to make a trip to the store.

     

    Do you know of any way to get the setup assistant to recognize and open a disk image? This would make life much easier, but since I've searched and read a lot, but have never seen this mentioned, I'm guessing it is a future feature.

  • Linc Davis Level 10 Level 10 (164,105 points)

    So...is there a way to track the hardware failure down?

     

    I already suggested one.

     

    Do you know of any way to get the setup assistant to recognize and open a disk image?


    No.

  • Bill Rising Level 2 Level 2 (240 points)

    My bad. I should've asked if there was a direct way to track down the hardware failure.

     

    So, here's what I did, suspecting that the hardware problem was with the old computer:

     

    Used Disk Utility to restore the backup from SuperDuper! to an unused partition on my new hard drive.

    Used the Setup Manager to install from this clone of my old computer.

     

    All went swimmingly. Unlike in previous problem-laded setups:

     

    • All the applications were restored properly, not just those at the top level of the /Applications folder.
    • All the prefpanes were restored properly.
    • All the endless symlinks I have for keeping things somewhat machine independent were copied.

     

    So... all is good again.

    Thanks for the help.