Previous 1 2 3 Next 39 Replies Latest reply: Jun 18, 2013 7:38 AM by Lupa1320
deathstarx Level 1 Level 1

Hi all,

 

RE: Applications problem: "You cannot update this software since you have not owned the major version of this software."

 

Until recently, I have not encountered this problem.  And I am facing this problem for both my iPad and iPhone. 

 

I only have 1 iTunes account and the most recent change was that I switched the location from Singapore to UK (I'm currently in the UK).  I also updated my applications a couple of times before since the change in location, so I doubt it's due to the location change.  I've tried signing out of the account in the iTunes accounts on the devices, then signing back in.  I've also tried restarting the devices (and for the iPad, I even updated the iOS). 

 

Any idea what else I can do to try to rectify this?

 

Thanks and regards,

Tammy


iPhone 4S, iPad 3 as well
  • Kaka Dongguan Level 3 Level 3

    Hi Friend,

     

    1. Did you update your devices with IOS 6.0.1? My girlfriend has the same problem, but just for one app that needs the latest IOS to be updated.

     

    2. Have you credited money in your Apple ID? If yes, maybe this is the problem. I have some money credited in my Apple account so that I cannot access other apps out of my location. This means, if you changed the location of your account, you will not able to access apps of other countries, because you have some money credited in another currency.

     

    Hope it will be helpful

  • deathstarx Level 1 Level 1

    Hi there!

     

    Thanks for replying!

     

    1.  Yup, my iOS is the latest (6.0.1), and I have 7 apps on my iPhone that apparently have updates.  But it's been 6.0.1 for quite some time and I've also been able to update the apps till just this week.

     

    2.  I don't have a credit card associated with my account anymore.  Ever since I changed the location, I removed the credit card details.  But I didn't have problems with any of my apps (updating or downloading new ones) until this week.  Also, all the apps I've downloaded since I came to the UK are free apps. 

     

    I still don't know what's wrong. 

  • Kaka Dongguan Level 3 Level 3

    Hi friend,

     

    I did mention credit card. I meant, if you have credited money in your Apple ID. Well, I believe you haven't to.

     

    Try to sign App Store out and sign in again. I think is all that I can advice you.

  • ivanyaco Level 1 Level 1

    I got the same problem since yesterday... but signing in & out doesn't help.

     

  • Swaza Level 1 Level 1

    Have the same issues, did move from Oz to Malayisa two years ago but same account name now for 12 years. This nonsense started since the new itunes update on both iphone and ipad

  • Ryan London Level 1 Level 1
    expertise.macosx
    Mac OS X

    I have a simaler problem, but not on an iPhone/iPad. I was setting up a new MacBook Pro for someone in our company (the boss' wife no less) and thought "I'll be a nice guy and do all of the Software Updates." I used the 'administrator' itunes account (that I had set up to do updates on my iMac and get apps for my company iPhone) to update the apps that needed an ID. Now it will only let the aps update with that account. In other words, the user can't put in her own iTunes account info because she gets the "You cannot update this software since you have not owned the major version of this software." message.

     

    Is there any way to erace the info about which account was used for updates? Basically making it think that it hadn't been updated so anyone who does an update after that will be alowed to use their iTunes account?

  • aadenyihongchen Level 1 Level 1

    I have the problem as well and it happens in both iPhone/iPad's App Store and Mac's App Store.

    The most critical for me is I have purchased the iTunes Match and it makes me not able to change the location of iTunes Store to get the Apps updated.

    Very disappointed at this rule by Apple, it should be authorised to use those apps which are existed in the purchased iTunes Store location and currently used iTunes Store location with no diffierence.

  • deathstarx Level 1 Level 1

    Thanks to all who shared.  I've tried signing in and out, and it doesn't work.  Still no idea how to resolve this.  I guess...just have to wait until Apple updates iTunes again?

  • mrihto Level 1 Level 1

    I got the same problem as well. I moved to the UK from Finland 4 months ago and all the updates have worked just fine until now. I figured that you can update the applications individually by searching for them which I have done for all my free applications.

     

    However, DO NOT DO THIS FOR THE PAID APPS! I made the mistake to update my paid Week Calendar application by searching for it. It even showed an 'update' icon instead of the price and 'buy'. So I clicked it and it updated the app normally. On the next day I receive a purchase confirmation to my email stating that my credit card has been charged with the price of the application.

     

    I will be contacting Apple about this directly. But I suggest to avoid updating paid apps for now.

  • gringosxm Level 1 Level 1

    Im having the same problem!! Apple should do something about, it had nothing to do with itunes is just the app store!... :/

  • ahpaja Level 1 Level 1

    I'm also having this problem with my iPhone 4S, when updating some, but not all, apps. It just started happening, maybe with the update of the new iTunes? I'm not sure

  • gringosxm Level 1 Level 1

    I found a solution, you need to update the app from outside the update tab! for exemple if you need to update instagram and it says that you can not because you dont own the major whatever, then go to search, enter instagram when you found it it gonna ask you to update it and not buy it or get it for free, so you click update and it should works!

  • ahpaja Level 1 Level 1

    Thanks! That worked for me!

Previous 1 2 3 Next