Previous 1 2 Next 26 Replies Latest reply: May 4, 2013 2:55 AM by hemmalho Branched to a new discussion.
v_v Level 1 Level 1

how to install Whatsapp in iOS 4.2.1?


iMac
  • mende1 Level 10 Level 10
    expertise.desktops
    Desktops

    WhatsApp isn't supported in iOS 4.2.1, so you must update the device

  • mackila Level 1 Level 1

    WhatsApp 2.8.3 version works perfect on iphone 3G 4.2.1

  • KiltedTim Level 9 Level 9

    Unfortunately, that version is no longer available. If you don't already have it, there is no way to get it.

  • misterkoog Level 1 Level 1

    I have an iPhone 3G with iOS 2.4.1. As of yesterday (12.26.12) Whatsapp asks me to verify my phone number. After I enter it, it asks for a 3 digit number that has supposedly been sent as an sms but I never get that. If I press either of the options 'Resend Code' or 'Call Me' I get a message that says my version of the app is too old and that I need to download the latest version from the App Store. But when I try to upgrade to the new version, it says the app requires iOS 4.3. The app worked perfectly fine and I have not actively upgraded it because I had already tried to do so but got the same message about iOS 4.3.  But then this phone number verification message popped up and now there seems to be no way out of this loop.

  • masua Level 1 Level 1

    I have the same issue - I have an iPhone 3 with iOS 4.2.1. since yesterday whatsapp has not been working. I assume that the Whatsapp version we have is no more available but once we purchased this app it should be working! Any ideas how to solve this problem?

  • marc.garcia Level 1 Level 1

    My wife has the very same problem. This is a mess.

  • Thiag Level 1 Level 1

    I have same problem.

     

    I can't use Skype in iOS 4.2.1 and now Whatsapp.

     

    Apple is officially leaving the iPhone 3G behind to run iOS 4.2.1 firmware forever. No more updates for the iPhone 3G will be forthcoming.

     

    And Now ?

     


  • KiltedTim Level 9 Level 9

    Blame the app developers. Not Apple. They made the decision to code their app so that it won't run on 4.2.1.

  • Justvw Level 1 Level 1

    It actually is Apple's fault, this is WhatsApp's reply when I ask them about iOS 4.2.1 support:

     

     

    Hi,

     

    Thanks for your message.

     

    In order to connect to WhatsApp, or activate your number, you will need the latest version of WhatsApp Messenger - v2.8.7 - available from the App Store on your iPhone. Please note that iPod and iPad are not supported devices.

     

    The latest version of WhatsApp for iPhone requires iOS 4.3 or later. Regretfully, Apple does not allow new app updates to be compatible with both iOS 6 and older versions of iOS, effectively ending support for the iPhone 3G. Because of Apple's decision to stop supporting these devices, we can no longer provide new app updates for iPhone 3G users.

     

    If you have an iPhone 3GS or newer device, please update to the latest version of iOS. Instructions for updating can be found at this Apple Support page: http://support.apple.com/kb/HT4972

  • KiltedTim Level 9 Level 9

    It's not Apple's "fault". The developers simply attempt to divert the blame from themselves.

  • Justvw Level 1 Level 1

    WhatsApp does not make something up about this, as you can also read here:

    http://stackoverflow.com/questions/14069384/what-is-the-lowest-ios-version-devel opers-can-create-an-app-for

    indirectly is Apple's fault.

     

    And funnykay, unfortunatelly your fix didn't work, I can only register with the newest version of WhatsApp, wich I can't install because it only works with iOS 4.3.x or newer, I get invalid API when I try to install WhatsApp 2.8.7

  • manu_ballo Level 1 Level 1

    That's really bad.

    All the Iphone 3g users cannot update the iOS (above the 4.2.1 version) and at the same time cannot use whatsapp 2.8.7

    I really do not mind if it is Apple's fault or whatsapp's fault the situation remain that all the iphone 3g users cannot use the service anymore.

     

    Some of the two should find a solution for that.

  • Justvw Level 1 Level 1

    Yea, you're right.

    Maybe WhatsApp could release a second app for older iOS versions...

  • KiltedTim Level 9 Level 9

    They already had an app that worked on iOS 4.2.1. They changed their service so that it would no longer allow you to use the older app.

Previous 1 2 Next