Skip navigation

turn off icloud.com send from mail

331 Views 11 Replies Latest reply: Dec 20, 2012 1:40 PM by Csound1 RSS
LambdaEnt Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 18, 2012 8:42 AM

I have a @me.com email, with several aliases.

Apple (graciously) provided me with an @icloud.com email, for all of them!

 

I do not use, nor want to use, @icloud.com, but thank you.

 

I can turn off sending from @icloud.com addresses from the icloud.com website

but not from Mail (desktop).

 

I now have a send from list a mile long whenever I compose an email.

 

This is infuriating.

 

How do I fix this?

OS X Mountain Lion
  • Eric Root Level 6 Level 6 (13,900 points)
    Currently Being Moderated
    Dec 18, 2012 12:42 PM (in response to LambdaEnt)

    If I am understanding you correctly, Mail/Preferences/Accounts/iCloud has an "Enable this account" box which you can deselect. If that doesn't solve your problem, you can always reselect it.

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Dec 18, 2012 12:59 PM (in response to LambdaEnt)

    HI,

     

    I have been given an @iCloud.com ID as well as the @me.com one for my iCloud Account.

     

    However it does not appear in Mail (I never put it there)

    Mail Accounts.png

    Nor does it appear in System Preferences > Mail, Contacts and Calendars which is another place you can turn On  Accounts for Messages, Mail, Notes an Calendars.

     

    As you can see in my Pic I have some Accounts Turned Off (the Enable this Account option will be unticked)

     

     

    3Sigcopy2.png
    8:59 PM      Tuesday; December 18, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Eric Root Level 6 Level 6 (13,900 points)
    Currently Being Moderated
    Dec 18, 2012 5:07 PM (in response to LambdaEnt)

    This doesn't solve what you want to do.

     

    In Mail there doesn't appear to be any option other than set default send address. The only other suggestion I can think of is to send feedback to Apple:

     

    http://www.apple.com/feedback/

  • Imp68 Level 4 Level 4 (2,135 points)
    Currently Being Moderated
    Dec 18, 2012 5:12 PM (in response to LambdaEnt)

    When you set the option on the website, it's supposed to also bleed down to your mail.app.  I just tested, and it worked on my system, leaving only my @me.com address usable in the 'from' field.  One thing I did notice, I had to actually log out of icloud.com before it took affect on my computer (or it just kicked in and synced during that time - this is more likely).

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Dec 19, 2012 11:50 AM (in response to LambdaEnt)

    HI,

     

    I understood that you wanted to use the @me.com Apple ID.

     

    What I was saying was that Apple sent me and Email about the @icloud.com name  and it was not added automatically to the Mail app or the Mail, Contacts adn Calendars part of System Preferences.

     

    Separately I have checked out that I can use the @iCloud.com name as a Valid AIM name  (Like @mac.com and @me.com ones) and I can.

     

    @icloud as AIM name.png

    AS you can see this did add it to Mail, Contacts and Calendars but only as a Messages app ID.

     

    I have not linked them (the original ID I used to create the iCloud ID or the @me.com name I got at the time).

    All allow me access to the iCloud web page, the iTunes Store and to be able to post here.

     

    I also showed that I had "registered" for both the POP server and IMAP server fro my Google ID and had one turned Off in the Mail App.

     

    Having said that if I visit the iCloud > Mail web site and bring up  the Preferences > Accounts it only lists the @me.com and @iCloud.com names  (And not the creating Apple ID ).

    The @icloud one does seem to have become the "Send From Address if I were composing Mail here.

     

    In  testing from my Google Account to my @me.com name it does not get moved to @iCloud.com and neither does any return email.  (Despite the setting at iCloud it keeps to the Mail settings).

     

     

     

     

     

    3Sigcopy2.png
    7:50 PM      Wednesday; December 19, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Eric Root Level 6 Level 6 (13,900 points)
    Currently Being Moderated
    Dec 19, 2012 2:39 PM (in response to Imp68)

    For my information, how did you delete the alias iCloud.com? When I went to Mail preferences on iCloud there was no apparent way to delete it. The help (?) stated you could uncheck the box to have it not active, but there were no boxes for me.com or iCloud.com.

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Dec 20, 2012 11:35 AM (in response to Eric Root)

    HI Eric,

     

    It seems it can be turned Off in the Composing section of the On Line Settings rather that actually deleted.

     

    I must admit to never looking at this Apple Doc

     

    Nothing I see in the Doc  hard links the @me.com and @icloud IDs together.

     

     

    3Sigcopy2.png
    7:35 PM      Thursday; December 20, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Eric Root Level 6 Level 6 (13,900 points)
    Currently Being Moderated
    Dec 20, 2012 1:39 PM (in response to Ralph Johns (UK))

    Thanks Ralph. It was the deleted that was confusing me, not that it takes much.

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Dec 20, 2012 1:40 PM (in response to Eric Root)

    You're welcome.

     

     

    Delete in the Mail App (or turn  Off)

    Turn Off only in thre iCloud Settings for the Mail said

     

    3Sigcopy2.png
    9:38 PM      Thursday; December 20, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

     

    Message was edited by: Ralph Johns (UK)

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Dec 20, 2012 1:40 PM (in response to LambdaEnt)

    LambdaEnt wrote:

     

    No, you both misunderstand the problem. I still want to use my @me.com address.

    Apple added the same addresses @icloud.com

     

    If I turn off the iCloud account I lose both.

     

    On the icloud.com website I can select which email addresses are to be:

    icloud.jpg

     

    I don't have that option in Mail (desktop):

    Do it from the website then, Mail uses the same server.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.