Previous 1 2 Next 27 Replies Latest reply: Dec 20, 2012 1:43 PM by sanjampet
Kathy Bourassa Level 1 Level 1

I have settings set to check spelling while typing in the mail preferences and also when i go into edit, Spelling, check spelling now, it still won't work. No red underline, no right click with other options for a word that I know is misspelled.   Otherwise mail is working fine.  OS 10.6.8 and Mail 4.6

iMac, Mac OS X (10.6.8)
  • sanjampet Level 5 Level 5

    Try going to mail preferences>composing, and click spelling as I type,  Also try going to edit>spelling click spelling while typing,and try check spelling with grammar, and check correct spelling automatically.  See if this helps.

  • sanjampet Level 5 Level 5

    Kathy,  Sorry about the delay, kids have a knack for injuring themselves without even trying.  I don't know if you tried what I posted so far, I was not done as I had to do a little first aid, nothing serious fortunately.  After doing the  I gave you there are a few more things you need to do.  First, close out of all applications, press shift.command,U. This will take you to the utilities page, go to disk utilities, highlight your user disk (usually Macintosh HD, or unless you renamed it), click repair permissions and let it run, could take a few minutes. After it finishes, quit the application (commandQ). Shut down.  Next reboot in the safe mode (hold shift key and continue to hold the shift key till you see the progress bar, then release and allow it to finish booting. (This will take a little longer than usual, be patient) Launch mail and quit, as well safari then quit.  Power down, then press the keys holding the left side shift, control,option keys and push the power button for about 5 seconds.  Boot up as normal, login, and launch mail, do a mail address to yourself. with a meanless and mispelled words in the subject. (as you can seee my red line is now working, as i had the same issue as you.  Quit mail,and reboot, and all the contol functions should be back to normal.  I hopr this helps. If you have any questions, feel free to contact me and I willl help in any wat I can.  I LEFT THE MISSPELLING IN AS AN EXAMPLE).. ALL THE BEST, SJP


  • Kathy Bourassa Level 1 Level 1

    Thanks so much for responding.


    I printed out your instructions so I could follow them exactly and tried it all.  It didn't work. The odd thing is that there were a ton of permissions that came up saying they should be something else.  It said it fixed them, but then when I again chose verify disk permissions a ton of problems showed up again. Some said they coudn't be repaired even though it says permissions were fixed after I ran repair permissions. 


    I have been having problems lately with everything working very slowly.  The only major things I've done in the last week was to install CS6 and update Suitcase Fusion 4 with a minor no-cost update.  Photoshop has been displaying some of the menus with black background and black type so you can't see the names of the functions.  I don't keep any games or odd things on my computer since I do graphic design and use it for my business.  Just the big programs Photoshop, InDesign, Illustrator, Bridge, Dreamweaver, Acrobat.  I use Safari and Mac mail.  Have not put any new programs on the computer lately except the CS6 versions of the ones listed. 


    Any other ideas or is there any way to figure out why the permissions are looking like they aren't getting fixed?




  • sanjampet Level 5 Level 5

    If you have disk issues they need to be repaired, which will require your original install disks. I will include a few links so that you can see what you need to do to fix your disk. The MTN Lion info should not really apply, but more knowledge is etter than less. The 10.6.8. info should apply to your issuses.







    I think the first link should be the one for you, but I included a few more to help educate you, as there is plenty to learn and understand.

    Your Drive might be dying, if it starts up, do a back up first thing. If none of the links offer yu ant help, go to a Apple Store, they will diagnose it for free, and give you a repair price. They offer a flat rate, I justbrought my kids MBP thay I gave him, it was a 2008 thatI used for 3 years. I do production so it was worked hard. I brought it in, as I did not have the time to work on it as I was out on the road. They replaced thehard drive, the logic board 2 times, the LCD backlight, and the entire keyboard, al for $330.00 basically a new machine, 1/3rd the price of a new machine, as I could not afford to buy him a new machine, and when I buy a MBP I buy top of the line. So, if the links do not work, take it in for a check up. Your drive may be failing or something else.

    If you have any questions, feel free to contactme and I will be happy to help if I can.

    Just so you know we are not paid employees, just users much as yourself.


    We are Mac "freaks"

    All the best and I hope that something aI sent you will help.



  • Kathy Bourassa Level 1 Level 1

    My iMac was on the list for the recalled hard drives, and it was just replaced.  I'm pretty sure it's not the drive.  I keep 2 backups constantly, though.  My guess is that I somehow messed stuff up with incompatibilities when I loaded the new software.  It was not an upgrade becuase I qualified for the student discount, so bought new as it was less expensive than upgrading from CS5.  Probably have conflicting files or plugins or something.  I used MacKeeper to try to clean things up, but not sure I'm even doing that right. 


    I also will check the chat rooms to see if folks over at Adobe are saying that CS6 runs problem free with OS 10.6.8.  Could be that I need to upgrade the operating system now.  I usually like to let new system software get to be a year or so old and so all the bugs are fixed before upgrading. 


    Thanks for the references, though. I appreciate all the Mac "freaks" who are so willing to help educate the rest of us!   I've had Mac's since they first hit the market and LOVE them. 


    Thanks again,


  • sanjampet Level 5 Level 5

    Kathy,  MacKeeper is considered my most of the people on the Community to be malware, that starts out OK then grows into something worse. It tends to cause a great many problems and can difficult to remove. I will attach a link for you to remove this insidious program and strongly suggest that you do. It could be part of the problems you have been experiencing.





  • sanjampet Level 5 Level 5

    Kathy,  The drive that was installed could be bad, you should not be getting any errors on your drive, this could be the result of MacKeeper.  You might want to bring it in to the Apple store for a god going thru, there is a 90 day warranty on all repairs, take advantage of it.  In regards to an OS upgrade MTN lion 10.8.2 still has a fair amount of bugs, I run SL10.6.8 still because it is so stable, I also have Lion 10.7.5 which seems to have most of the bugs worked out. Still waiting for MTN Lion to settle out. As a rule, I NEVER install V.0 orV.1 of anything. I don't care to a manufactures beta tester/Guinea Pig.  Permission errors will always show up, and should be cleaned occasionally. But not with MacKeeper!  If you want to run a "cleaning app" here is a link that is very informative onyX in the cache cleaning has a link for a free download, follow the directions carefully.




    I hope that I've been of some help to you, and feel free contact me in future.



  • Kathy Bourassa Level 1 Level 1

    Thanks again for keeping up the info.  I am not really getting errors, I just expected that after I cleaned the disk permissions and they were all repaired, and then checked by clicking the verify disk permissions, nothing would be there.  Not getting any other errors.  I was using the Disk Utility to repair the permissions. I took your advice and got rid of MacKeeper and emptied the trash per instructions.  I had not encrypted anything. 


    Spell Check still not working.  It's like it is no longer a function of the mail which seems to be working fine in all other ways.  when I type in a draft with deliberate errors and go to the menu function of Edit>Spelling and Grammer>Show spelling and grammer there is just the grayed out box.  Highlighting the text doesnt turn the box active.


    The other thing that is still happening is that when I open a raw image in Photoshop CS6, the menu of camera adjustments has the sliders but the type naming what the slider is can't be seen, all black.


    Is there any way to load just the mail application without re-loading the whole OS system? Plus I can't find my original disks.  They are here somewhere, I just can't locat them.


    So is 10.7.5 something I should consider upgrading to?  Would that upgrade kind of reset all the OS stuff that might be causing these problems?

    Thanks again!

  • sanjampet Level 5 Level 5

    Kathy,  You did the safe boot and the smc reset as I posted above? As these reset my spell check which I disabled for testing for this.  If you open Safari and start tying in the text field does the spell check do the red line thing?  Let me know.

  • Kathy Bourassa Level 1 Level 1

    Where in Safari am I testing for the red underline?  In the google search part or the URL part?


    I followed all the rebooting exactly.  Might try it again, though, now that I've done a bunch more cleaning.

  • Kathy Bourassa Level 1 Level 1

    Typing in this reply doesn't spell check - should it be? 


    Do you recommend upgrading to 10.7.5 if doing the reboots again doesn't work?

  • sanjampet Level 5 Level 5

    in safari go to edit, spelling grammar and see if that looks right.

  • sanjampet Level 5 Level 5

    I meant the check spelling options and see if they are grayed out. I am going to do a couple of more tests, which will put me offline for a bit. You can reply and I'll get back to you ASAP.

  • Kathy Bourassa Level 1 Level 1

    it's not grayed out and the check spelling is checked.  But I don't know how to test and see if that's working.

    I'm on a chat with Adobe support to see if the photoshop thing can be fixed. Perhaps it's all related.

Previous 1 2 Next