13 Replies Latest reply: Dec 20, 2012 1:49 PM by MlchaelLAX
alperfrombrooklyn Level 1 Level 1 (0 points)

Hello,

 

I have 13" MacBook Pro 2.4 that came with Snow Leopard. I have found that it does not perform really well with Mountain Lion (although 8GB RAM and 7200rpm HD) so I decided to switch back to SL. I also own Parallels and it lets me use the ML download image to set up a new virtual os, which I can then use to run iBooks Author.

 

However, iBooks Author and iWork apps do not render in virtual ML. In the attached screenshots, you can see that the interface is there, but the content of the application is not showing up. Other applications like Safari perform just fine. So far, only iBA and iWork apps are affected.(Screenshots are from Parallels so they are of the virtual os)

 

 

I know this is a virtual ML issue cause I have ML on a separate partition that works just fine when booted into it. I am assuming this is a graphic card specific issue, where Parallels is unable to match the hardware graphics exactly.

 

I'd be happy to receive your comments and feedback to find a remedy to this situation, as I do not want to switch between partitions just to use iBooks Author.

 

Best regards

 

 

 

Parallels Picture.pngParallels Picture 2.pngParallels Picture 1.pngParallels Picture 4.png


Parallels Desktop with ML, OS X Mountain Lion (10.8.2)
  • MlchaelLAX Level 4 Level 4 (1,970 points)

    This issue extends to other Apple apps like Preview, which will not render when run in virtualization.  I use Snow Leopard virtualized in Lion and I always make sure I use Preview in Lion and not virtualized Snow Leopard.

     

    I believe this issue is discussed on the Parallels support forum, but with no satisfactory solution for now...

     

    They may also balk at offering you support as they do not officially support virtualizing Mt. Lion in Parallels in Snow Leopard.  I may have raised the issue on their support forum suggesting the problem was in virtualizing Snow Leopard Server in Lion, which they do officially support.

     

    Try a search of the Parallels Support forum...

     

    You could partition your hard drive and install Mountain Lion in that partition (or use an external hard drive) and use the "dual-boot" method as a workaround to your problem.  Of course, in this situation, you lose the ability to run Snow Leopard and Mountain Lion concurrently.

     

    Finally, you could reinstall Mt. Lion and then run Snow Leopard in Parallels, but it seems from your comments that this suggestion will not work for you.  This solution is primarily for those Lion/Mt. Lion users who need concurrent use of PowerPC applications requiring Rosetta:

     

    http://forums.macrumors.com/showthread.php?t=1365439

  • alperfrombrooklyn Level 1 Level 1 (0 points)

    Dear Michael, thank you for your reply.

     

    Honestly it never occured to me to raise this issue in Parallels forums, but now I realise this is a problem with their product, instead of Apple's OS.

     

    Thanks for all your feedback, I'll try the same there and let you know if anything comes up.

     

    Cheers!

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    Actually this forum has no official Apple Support posts; just us civilians hoping to help each other out...

     

    I do think it is an Apple problem, but I do not think they will address it, since it is using Mt. Lion installed into Parallels in Snow Leopard.

     

    However, since Parallels is more apt to support their own product, my guess is that they have the incentive to figure out the problem and find a solution.

  • LexSchellings Level 5 Level 5 (6,795 points)

    This is a problem that your hardware is not capable of running ML (as you have experienced). Although Parallels has a lot of drivers to run ML in a VM. But the problem remains that the hardware is not compatible.

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    LexSchellings wrote:

     

    This is a problem that your hardware is not capable of running ML (as you have experienced). Although Parallels has a lot of drivers to run ML in a VM. But the problem remains that the hardware is not compatible.

    I think you have read the OP too quickly and missed some important information.

     

    The OP stated that his Mac does support ML, it just does not "perform well" so he reverted to Snow Leopard.

     

    The OP also stated that the applications involved (iBooks Author and iWorks) operate fine when he boots his Mac from his ML partition.

     

    Perhaps you want to revisit your conclusion...

  • LexSchellings Level 5 Level 5 (6,795 points)

    I don't think I misread the OP:

    Macbookpro 2,4 that was delivered with Snow Leopard. AFAIK that has 10.7.5 as max OS.

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    There is no MacBook Pro 2,4; the OP said "13" MacBook Pro 2.4".

     

    The first MacBook Pro to be 13" was the model I finally retired my Powerbook G4 12" to purchase and is the 5,5 (2009).

     

    It can support Mountain Lion, as is clearly indicated by the OP; he just doesn't like its performance.

     

    In any event, the fact that iBooks Author and iWorks will not show imaging in Parallels (as with Preview) is a known problem of virtualization and not of running ML (as also noted by the OP that they run fine on his MacBook Pro when he boots into ML on his partition).

     

    Your conclusion is incorrect.

  • LexSchellings Level 5 Level 5 (6,795 points)

    Typo 13"?.

    Sure the 2009 model can run ML. My conclusion incorrect in that situation. Correct.

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    He probably has the 13" MacBook Pro 7,1 with a 2.4 GHz Core 2 Duo released in 2010 with Snow Leopard installed.

  • alperfrombrooklyn Level 1 Level 1 (0 points)

    The OP is here to clarify :)

    By the way thanks to everyone who participates in this discussion.

     

    I bought my MacBook Pro 13" in mid-2010 and it came with Intel Core 2 Duo 2.4 processor.

    I upgraded it to the maximum RAM, which is 8GB.

    I also installed a 72000rpm 750GB hard drive.

     

    It is qualified to install Mountain Lion, which I did, albeit performed not top notch so I downgraded.

    (I also did and still hate the Versions, especially with iWork, so I had incentive to roll back to SL)

     

    If interested in other details, here is the model: http://support.apple.com/kb/SP583

     

    I am inclined to think that Parallels is not able to fully imitate the built-in graphics card, and the applications fail to work because of that. I believe there is a difference between the document content (rendered live) and the interface (pre-designed graphic items).

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    Yes, I agree, so your best bet is to post on the Parallels Support Forum to see how, if and when they hope to fix the problem...

     

    If they respond, come back here and post their conclusions.

  • LexSchellings Level 5 Level 5 (6,795 points)

    One of my computers is the same model, but 15". I have a Crucial SSD 256GB in it and the original HDD in the place where I took out the Superdrive. Running Parallels Desktop, 8GB Ram. ML. Works perfect. No problem at all. But I run PD v7 and not v8. Windows XP Pro runs perfect. Second VM with W7.

    W7 is very different in that it tries to defragment in the background and works with a built in sort of Trim command. I do not use it any more, and maybe it was not set perfectly in my case. VM still with XP: i have to run XP in several technical systems that I run at remote locations, and I want a similar setup in my Mac also.

    In short: my PD 7 has no problems whatsoever with the graphics cards inside, but I cannot swear that for PD and the W7 VM, because I do not have it running anymore. I tried W8 for fun, but I have no exprience because a lot of apps will not (yet) run in W8.

  • MlchaelLAX Level 4 Level 4 (1,970 points)

    Remember, this is Parallels virtualizing Mac OS X within Mac OS X and the problem is Apple applications.

     

    I have the same problem with Preview within Snow Leopard virtualized in Lion (I do not have iBook Author or iWorks to attempt to duplicate the OP's problem). It is a known problem to Parallels.  I just do not know if they are putting any resources into fixing it.