8 Replies Latest reply: Dec 20, 2012 8:37 AM by RobertJ
RobertJ Level 4 (1,190 points)

I have two ATV's [2nd Gen]. I started the latest SW upgrade on the first one and after it downloaded and started Step 1 "Preparing Update", I started the process on the second one.


The second one went to Step 1 followed by Step 2 and is now upgraded. Took a total of about 10 minutes.


The first ATV is stalled in the middle of Step 1 "Preparing Update" and has been there for 30 minutes.


So what do I do now?

Mac Pro, OS X Mountain Lion
  • Winston Churchill Level 10 (95,687 points)

    If your problem persists get yourself a micro USB cable (sold separately), you can restore your Apple TV from iTunes:

        1.    Remove ALL cables from Apple TV. (if you don't you will not see Apple TV in the iTunes Source list)

        2.    Connect the micro USB cable to the Apple TV and to your computer.

        3.    Reconnect the power cable (only for Apple TV 3)

        4.    Open iTunes.

        5.    Select your Apple TV in the Source list, and then click Restore.

    If when you choose restore you get a message that the device cannot be found, download the file below

    Apple TV Software Restore 5.1.1 (2nd generation)

    Then hold down the option key while choosing restore and select the downloaded file when prompted.

  • RobertJ Level 4 (1,190 points)

    I found that by Googling but thanks. What I didn't find was the direct file download instructions. After upgrading iTunes to 11.0.1 [30 minutes] to get rid of "device cannot be found", I'm now upgrading via iTunes. Looks like a 2+ hour process; next time I'll try the direct download method. On second thought I think I'll stick with 5.1.1 unless Apple adds something worth the hassle like the ability to stream movies from Amazon since I'm a Prime member.

  • RobertJ Level 4 (1,190 points)

    Luckly my wife's Kindle has a USB to Micro USB cable.

  • Winston Churchill Level 10 (95,687 points)

    So far as I am aware 5.1.1 is the latest software for the Apple TV.

  • RobertJ Level 4 (1,190 points)

    So far as I am aware 5.1.1 is the latest software for the Apple TV.


    I know; however, the updating of firmware on ATV is much less reliable than updating SW on a Mac.


    So unless any future ATV firmware offers some new feature of value to me I will skip it. In the meantime I have 72 minutes to go before the iTunes update of my firmware to 5.1.1. Then of course I need to set it up on my network again using the remote and re-login to Netflix again using the remote. A real pain that shouldn't take more than another 10 - 20 minutes.


    This entire update to 5.1.1 will end up taking almost four hours and I have a 15M connection to the Internet.

  • RobertJ Level 4 (1,190 points)

    Winston Churchill provide what would appear to be a solution; however, it didn't work. Not his fault.


    After waiting over 2 1/2 hours for iTunes to down load the firmware it would not update my ATV. I got this message:


    The Apple TV "Apple TV" could not be restored. An unknown error occurred (3014).


    I then went to softpedia and downloaded it "manually" in 7 minutes, not 2 1/2 hours. Using Winston's instructions about the option key tried again. Again I got the 3014 error.


    After looking into the meaning of the error the suggestion was that my system was blocking iTunes from contacting gs.apple.com; however, in looking at my network logs that was not true.


    Reluctant to throw my ATV in the trash I made a desperate move. My wife still had iTunes 10.7 on her computer. I removed iTunes 11.0.1 from my computer and installed iTunes 10.7.


    I then followed Winston's option key instruction to access the file AppleTV2,1_5.1.1_10A831_Restore.ipsw sitting on my desktop using iTunes 10.7. The restore worked perfectly and my ATV is now sitting on my network and working perfectly with 5.1.1 .


    So while it appears that iTunes 11 is wonderful and the bugs they fixed in iTunes 11.0.1 allow you to actually start the restore process for ATV, they didn't get all the bugs.


    I'll be using iTunes 10.7 and watch for iTunes 11.0.2. Under no circumstance will I get rid of iTunes 10.7.

  • Winston Churchill Level 10 (95,687 points)

    I'm not really sure which file you tried to download (That site only offers one file and doesn't say what it is, but judging by the file size it seems more likely to be the wrong one), but were you sure it was for the Apple TV 2, the link I provided is.


    Personally I'd avoid downloading anything from that site and stick with the genuine Apple downloads I linked to.

  • RobertJ Level 4 (1,190 points)

    Absolutely sure AND, it did work properly when I used iTunes 10.7.


    The file is AppleTV2,1_5.1.1_10A831_Restore.ipsw


    I just downloaded it from a source I'm familiar with and trust.