3 Replies Latest reply: Dec 24, 2012 11:16 AM by jpcollins
jpcollins Level 1 (0 points)

I keep trying to disable automatic downloads from iTunes (don't want TV shows I've purchased through my Apple TV to download onto my computer), by going to iTunes - Preferences - Store - and it works for a while, then it starts to automatically download these TV shows again when I open iTunes. So it works some of the time, but not consistently. Very frustrating! Can anyone help?

iMac (20-inch Mid 2007), Mac OS X (10.6.8), External HD: 500 GB G Drive Q
  • jpcollins Level 1 (0 points)

    After reading some of the similar posts on here, I tried removing all the items from the iTunes downloads folder on my hard drive, and signing out from the iTunes store. Signing out from the iTunes store solved the problem temporarily, but as soon as I signed in again, the automatic downloads started again. When I looked in the iTunes downloads folder, there they were again - the .tmp files of the TV shows I DON'T want on my computer. Now I have another problem. When I went back into iTunes to check if the Store Preferences were still set to NO automatic downloads, I found those choices greyed out. They were still set to disable automatic downloads (no tick in those boxes) but now I can't change them at all. So I must have thrown out something I needed when I threw the contents of the downloads folder into the trash, and then emptied the trash. I tried to get the trash back using Time Machine, but couldn't find it in there. Sighhhh! I'm at my wits end and now I'm afraid to make things any worse than they already are.

  • jpcollins Level 1 (0 points)

    So I discovered why the automatic download items in iTunes Store Preferences were greyed out - they are greyed out unless I'm signed into the iTunes store. That's not a problem any more. However, no matter what I try, I can't get the iTunes store to stop automatic downloads of these TV shows as soon as I sign in. I am NEVER going to purchase Tv shows again from iTunes. I'm disgusted that they haven't found a fix for this problem.

  • jpcollins Level 1 (0 points)

    I thought I'd try one more time to solve this, and I think I may have found an answer. I signed into the iTunes store, went to iTunes preferences, and disabled (unchecked) the "enable automatic downloads of album artwork" button. That was the only other item there that seemed to have anything to do with automatic downloads that was still checked. So since then I've signed into and out of the iTunes store, and it's not starting ANY automatic downloads. NO TV shows! Lovely. I can hardly believe it worked! I hope this helps someone else with the same problem.