5 Replies Latest reply: Dec 21, 2012 4:43 AM by JohnTheMacGeek
JohnTheMacGeek Level 1 Level 1 (0 points)

This morning I woke up to a major problem. Although the external drive is mounted and I can manually copy files to/from said drive with no difficulty, iTunes 11 will not allow me to import files into my iTunes library which is located on this drive. How can I resolve this issue without reformatting and restoring from a cloned drive?


Screen Shot 2012-12-20 at 8.16.24 AM.png

iMac (20-inch Mid 2007), OS X Mountain Lion
  • Alix Leigh Level 2 Level 2 (150 points)

    I don't have iTunes 11 (which COULD be the root of your issue) but assuming it's not...

    Below assumes that you have followed Apple's instructions on how to move your iTunes media:

       iTunes for Mac: Moving your iTunes Media folder


    Now double check in iTunes prefs (advanced tab) that you've pointed iTunes to the "iTunes Media" folder on your external HD

    The iTunes media Location should read something like: "/Volumes/ExternalDriveName/iTunes Media", if not, use the browse button and point it to your iTunes Media folder


    If that's correct AND this is actually a permissions issue first quit iTunes then:


    Do a "Get Info" on your external HD (command-I) that's not an L.


    • IF: the check box "Ignore permissions on this disk" is checked, UNCHECK it.***
    • OTHERWISE: under "Sharing and Permissions" at the bottom of the Get Info window it should read:
        • YourUserName (Me).....Read & Write
        • staff (or Admin).....Read & Write

    Now, it's not a bad idea to reboot your computer at this point.


    Restart iTunes, try again.


    IF it still balks:

    A) its POSSIBLE that iTunes Mac expects an HFS+ formatted volume  (Many/most? drives come formatted FAT32)



    ***ALAS, if you copied your files with the "Ignore permissions..." checked, (or incorrect perm's were set) it's possible that proper permissions were not copied over.


    In either event (A or B) your best bet MIGHT be to reformat the external disk (VERY easy in Disk Utility), set the correct permissions, then restore your iTunes Media folder from a Time Machine backup. (Make sure you choose the date just before

  • JohnTheMacGeek Level 1 Level 1 (0 points)

    I checked these settings prior to posting. I've had the iTunes library content on the external drive for over two years now as my library is way too large (850gb+) for the internal drive (250gb).

  • JohnTheMacGeek Level 1 Level 1 (0 points)

    It has come to my attention that the problem lies solely with .mov files from my iPhone 4S. iTunes won't import them regardless of which way I try.


    Just to check the file itself, I tried importing it into iTunes on my MBP and it imported without any difficulty.

  • JohnTheMacGeek Level 1 Level 1 (0 points)

    It seems to be limited to the external drive. I have since reformatted the drive and cloned my iTunes library back over to it and it STILL won't allow .mov files into iTunes!

  • JohnTheMacGeek Level 1 Level 1 (0 points)

    Problem solved. I selected "Get Info" on the drive and selected the "Ignore ownership on this volume" box. All works fine now!